» »

Debian Gnu/Linux kot workstation

strani: 1 2 3 4 5 ... 40

JakobSTR ::

Zdravo!
Jst mam pa problem s pecenjem cdjev. sm naredu tko, kt je majster reku (nalozu un modul in zapisal tist text (primerno prirejen) v /etc/lilo.conf). pa mi k3b se zmer ne zazna pekaca, zazna ga kot bralnik.
Kako bi lahko to popravu?

Gandalfar ::

lilo si pognal seveda?

JakobSTR ::

kako to misls?
in kako se to naredi?

Gandalfar ::

napisi

lilo

kot root, da ti posodobi MBR sektor na disku.

JakobSTR ::

jp, sm to naredu, ampak spet problem:
jav napako!
ko odstranm uno, kar sm na novo vpisu, pa spet kewl dela.

kam tocn morm napisat uno, da bo delal (zdej sm napisu na konc, pa slabo kaze)

thx

Gandalfar ::

pokazi tvoj lilo.conf file

JakobSTR ::

# /etc/lilo.conf - See: `lilo(8)' and `lilo.conf(5)',
# --------------- `install-mbr(8)', `/usr/share/doc/lilo/',
# and `/usr/share/doc/mbr/'.

# +---------------------------------------------------------------+
# | !! Reminder !! |
# | |
# | Don't forget to run `lilo' after you make changes to this |
# | conffile, `/boot/bootmess.txt', or install a new kernel. The |
# | computer will most likely fail to boot if a kernel-image |
# | post-install script or you don't remember to run `lilo'. |
# | |
# +---------------------------------------------------------------+

# Support LBA for large hard disks.
#
lba32

# Overrides the default mapping between harddisk names and the BIOS'
# harddisk order. Use with caution.
disk=/dev/hdc
bios=0x80


# Specifies the boot device. This is where Lilo installs its boot
# block. It can be either a partition, or the raw device, in which
# case it installs in the MBR, and will overwrite the current MBR.
#
boot=/dev/hdc

# Specifies the device that should be mounted as root. (`/')
#
root=/dev/hdc1

# Enable map compaction:
# Tries to merge read requests for adjacent sectors into a single
# read request. This drastically reduces load time and keeps the
# map smaller. Using `compact' is especially recommended when
# booting from a floppy disk. It is disabled here by default
# because it doesn't always work.
#
# compact

# Installs the specified file as the new boot sector
# You have the choice between: bmp, compat, menu and text
# Look in /boot/ and in lilo.conf(5) manpage for details
#
install=/boot/boot-menu.b

# Specifies the location of the map file
#
map=/boot/map

# You can set a password here, and uncomment the `restricted' lines
# in the image definitions below to make it so that a password must
# be typed to boot anything but a default configuration. If a
# command line is given, other than one specified by an `append'
# statement in `lilo.conf', the password will be required, but a
# standard default boot will not require one.
#
# This will, for instance, prevent anyone with access to the
# console from booting with something like `Linux init=/bin/sh',
# and thus becoming `root' without proper authorization.
#
# Note that if you really need this type of security, you will
# likely also want to use `install-mbr' to reconfigure the MBR
# program, as well as set up your BIOS to disallow booting from
# removable disk or CD-ROM, then put a password on getting into the
# BIOS configuration as well. Please RTFM `install-mbr(8)'.
#
# password=tatercounter2000

# Specifies the number of deciseconds (0.1 seconds) LILO should
# wait before booting the first image.
#
delay=20

# You can put a customized boot message up if you like. If you use
# `prompt', and this computer may need to reboot unattended, you
# must specify a `timeout', or it will sit there forever waiting
# for a keypress. `single-key' goes with the `alias' lines in the
# `image' configurations below. eg: You can press `1' to boot
# `Linux', `2' to boot `LinuxOLD', if you uncomment the `alias'.
#
# message=/boot/bootmess.txt
prompt
timeout=150
# prompt
# single-key
# delay=100
# timeout=100

# Specifies the VGA text mode at boot time. (normal, extended, ask, )
#
# vga=ask
# vga=9
#
vga=normal

# Kernel command line options that apply to all installed images go
# here. See: The `boot-prompt-HOWO' and `kernel-parameters.txt' in
# the Linux kernel `Documentation' directory.
#
# append=""
append="hdb=ide-scsi"

# Boot up Linux by default.
#
default=Linux

image=/vmlinuz
label=Linux
read-only
# restricted
# alias=1

image=/vmlinuz.old
label=LinuxOLD
read-only
optional
# restricted
# alias=2

# If you have another OS on this machine to boot, you can uncomment the
# following lines, changing the device name on the `other' line to
# where your other OS' partition is.
#
# other=/dev/hda4
# label=HURD
# restricted
# alias=3
other=/dev/hdc5
label="Win/DOS(hdc5)"

other=/dev/hdc3
label="Other(hdc3)"


to je brez append="hda=ide=scsi" [drgac ga pa dodam na koncu]ž
LP, Jakob

Zgodovina sprememb…

Gandalfar ::

sem ti popravil lilo.conf tako, da ti bo pomojem zdej mal boljs delalo. (glej lokacijo rdecega teksta)

JakobSTR ::

sm tist vnesu pravilno v lilo.conf,vpisem ukaz lilo, deluje v redu. potem vpisem se modprobe ide-scsi (kot svetuje k3b), ampak k3b pekac se zmerej zazna kot bralnik. zdej mi pa ni vec jasn, kaj lahko naredim???
pekac je pa Sony CRX1611 (16-10-40)
Hvala za pomoc

Gandalfar ::

povej kaj ti javi:

dmesg | grep scsi

mile ::

hmm, a ni ponavadi cdrom /dev/hdc

append="hdc=ide-scsi"


saj pri meni je bilo ponavadi tako

Gandalfar ::

odvisno na kerem ide kanalu ga imas...

jaz sem predvideval da je potem hdb pri sebi spremenil v hdc..

JakobSTR ::

jakob@strbenk:~$ dmesg | grep scsi
Kernel command line: BOOT_IMAGE=Linux ro root=1601 hda=ide=scsi
ide_setup: hda=ide=scsi -- BAD OPTION
request_module[scsi_hostadapter]: Root fs not mounted
request_module[scsi_hostadapter]: Root fs not mounted
i2o_scsi.c: Version 0.0.1
scsi0 : SCSI host adapter emulation for IDE ATAPI devices
jakob@strbenk:~$



tole mi izpise...
torej je problem v scsi emulaciji...

Gandalfar ::

zakaj mas natipkano ide=scsi in ne ide-scsi?

JakobSTR ::

tm je bla torej napaka. zdej mi scsi emulacija dela!
ampak pekaca se zmerej ne zazna???
jakob@strbenk:~$ dmesg | grep scsi
Kernel command line: BOOT_IMAGE=Linux ro root=1601 hda=ide-scsi
ide_setup: hda=ide-scsi
request_module[scsi_hostadapter]: Root fs not mounted
request_module[scsi_hostadapter]: Root fs not mounted
i2o_scsi.c: Version 0.0.1
scsi0 : SCSI host adapter emulation for IDE ATAPI devices
Attached scsi CD-ROM sr0 at scsi0, channel 0, id 0, lun 0
Attached scsi CD-ROM sr1 at scsi0, channel 0, id 0, lun 1
sr0: scsi3-mmc drive: 40x/40x writer cd/rw xa/form2 cdda tray
sr1: scsi3-mmc drive: 40x/40x writer cd/rw xa/form2 cdda tray
jakob@strbenk:~$

tole napise dmesg |grep scsi
drgac mi pa zdej k3b zazna 3 cd pogone (mam samo 2), 2 sta SCSI, eden je navaden. Vsi se izpisejo pod reader.

Gapi ::

Jest kle uporabljam xcdroast ker pozna tud ATAPI pekače. hmm hmm to velja za zadnje verzije xcdroast.
No person is rich enough,to buy back his past.

b ::

Huh? Jaz sem uporabljal xcdroast ze pred vsaj tremi leti, z raznoraznimi pekaci. Nima xcdroast dosti veze, podpora za IDE/.ATAPI pekace je v kernelu, xcdroast in ostali pa uporabljajo tisti API (SCSI, za IDE naprave pa obstaja SCSI emulacija)

blazp88 ::

Kar se tiče mrežne inštalacije ...... imam Abit NF7-S, pa me zanima, kako skonfigurirati mrežo že med inštalacijo (nek paket je treba inštalirat), ali pa naj dam za takrat raje notri obično RTL8139, pa se s tistim potem zajebavam?

blazp88 ::

aja, kako je s serialata?

Simulacrum ::

Pozdrav...
sledil sem Gandalfarjevim navodilom pa sem naletel na tezave pri namestitvi KDEja. Ko vpisem "apt-get install kdebase kdesktop kdm" mi preprosto javi:
"Reading Package Lists... Done
Building Dependency Tree... Done
E: Couldn't find package kdebase"

Distribucijo mislim, da sem upgradal na sid verzijo-kako sploh preverim katero verzijo uporabljam?
Po vsej verjetnosti je cisto kaksna banalna napaka (kaksen slabo vpisan link v sources.list)...najlepsa hvala za pomoc.

LP
Riplix

Gandalfar ::

na zacetku ti na vrhu konzole napise kateri sistem imas..

oz. cat /etc/debian_version


glede tiste napake na nisem popolnoma preprican .. poskusi z apt-get install kde

apt-get update si pognal?

Simulacrum ::

Hm...se vedno nic...poskusal najprej apt-get update ter javi:
":/# apt-get update
Reading Package Lists... Done
Building Dependency Tree... Done"

Ce pa vpisem apt-get install kde ali pa kdebase ali pa karkoli v zvezi s kde (kdelibs,...) pa se vedno javlja, da ne uspe najti paketa imenovanega kde.
Boh.

lp
Riplix

Zgodovina sprememb…

roscha ::

Riplix:

Še enkrat preveri /etc/apt/sources.list Evo ti kar mojega, pa ga C/P...

deb http://ftp.si.debian.org/debian/ unstable main non-free contrib
deb-src http://ftp.si.debian.org/debian/ unstable main non-free contrib
deb http://non-us.debian.org/debian-non-US unstable/non-US main contrib non-free
deb-src http://non-us.debian.org/debian-non-US unstable/non-US main contrib non-free


Potem še enkrat poženi apt-get update. Zatem apt-get dist-upgrade, Še dela? apt-get install kdebase
Zdaj bi mogl gret.. Če ne, kaj ti izpljune apt-get install kde*

by!

Gandalfar ::

poskusi ne uporabljat karolininih kde virov ampak samo sid.. to kar je roscha dal..

Simulacrum ::

Najlepsa hvala obema...sem dal v sources.list linke, ki si jih Rocha dal pa deluje. Trenutno ravno updatam dist. Upam, da se ne bo kaj zalomilo pri KDEju.
Se enkrat hvala.

lp
Riplix

Gandalfar ::

trenutno uporabljam KDE iz sida in zadeva dobro deluje .. :)

Simulacrum ::

Ho...koncno uspel usposobiti XServer ter namizje KDE...zdaj pa se pocasi spuscam v bolj specificna podrocja :)). Rad bi usposobil Sambo, da bi sem ter tja kaksno datoteko povlekel iz Win masine. Kaksen nasvet kje zacet ipd? 8-O

lp
Riplix

Gandalfar ::

Samba howto :)

Naceloma je pa vse kar rabis..

apt-get install smbfs

potem pa lahko reces:

smbmount //ime_rac/share /mnt/point

in uzivas :)

vojkoz ::

a je že navoljo slučajno slovenski KDE???

Gandalfar ::

itaq.. ze dolgo casa

apt-get install kde-18n-sl ter v Nastavitvah K->Settings->Control Panel->Regional &..->Add language->..

in das slovenscino notr in zbrises anglescino in imas slovensko :)

roscha ::

Mali popravek paket je: kde-i18n-sl, da se tip ne bo po nepotrebnem mucil...

Še tko za "plošno izobrazbo" od kje ime i18n. Pride od besede internationalization, ker pa je malo dolgo za pisat, so pustili samo prvo in zadnjo črko, vmes pa napisali koliko znakov manjka :)


by!

Gandalfar ::

joj, typo .. se oproscam ..

CaqKa ::

kakak bedna fora tole z i18n.... sem se kr nekaj krat spraševal pa mislil kaj za ena verzija je to :)

hruske ::

Fantje, Debiana sem namestil na ra?unalnik, ki sem ga prinesel v dija?ki dom.

Stvar seka. Sploh apt-get, dokler dela v redu.

Samo nekaj me zanima.. a so serverji s paketki popolni mirrorji a majo shranjene samo dele debiana? Ker mi v?asih napi?e, ko ho?em kak paketek namestit, da je npr. kbear odvisen od ?e ene par drugih, ki pa NE bodo name??eni. N? jasn...
Errarum humane est.

Gandalfar ::

unstable ima vcasih probleme s soodvisnostmi .. naceloma je pa ftp.si.debian.org uradni celotni mirror primarnega debian streznika in prenasa _vse_ tudi celotni deb-src (sem ugotovil, da recimo arnesov mirror nima sourca..)

Verjetno bi bomo lazje pomagali, ce bos povedal kaksen konkretni paketek. Sicer te pa verjetno muci kaj v tem stilu:

The following packages have unmet dependencies:
evolution: Depends: libgnome-pilot1 (>= 0.1.70) but 0.1.64-1 is to be installed
E: Broken packages

To pac pomeni, da moras na roko resevat probleme s soodvisnotmi in je naceloma jeba, ce ne ves kaj delas oz. kaj se dogaja.. svetujem ti da tu povprasas kako in kaj oz. se bos ze naucil s casom :)

hruske ::

Jap, to je točno to kar si napisal.
Sej ni sile, važno da lahko lovdam zastonj. :D

Momogrede, a kdo uporablja Kbear, eden izmed download managerjev? Predvsem me zanima, če je boljši od Kget.
Errarum humane est.

Gandalfar ::

KBear uporabljam kot FTP client in mi je vsec :)

Simulacrum ::

http://www.osnews.com/story.php?news_id=2016&page=1
Zanimiv vodic za Debian NetInstall.

lp
Riplix

Simulacrum ::

Ho...ko naredim dist-upgrade se sredi nadgradnje ustavi ter izpise:
"E: This installation run will require temporarily removing the essential
package libpam-modules due to a Conflicts/Pre-Depends loop. This is
often bad, but if you really want to do it, activate the
APT::Force-LoopBreak option.
E: Internal Error, Could not early remove libpam-modules"

Kaj mi je storiti? No uporabil sem ukaz dpkg --force-depends -r libpam-modules ter nato apt-get -f dist-upgrade ampak se mi zdi, da se pojavljajo kar neke napake...tako da verjetno to ni najboljse izbira...mogoce kaksna ideja kako bi moral postopat?

lp
Riplix

Gandalfar ::

ja .. it's a known error - sem ga tudi jaz opazil par dni nazaj.

Reces:

apt-get -o APT::Force-LoopBreak=1 dist-upgrade

samo tokrat, da uspesno prides na unstable.

Xion ::

v konzolo napisem
smbmount //athlon/c /ath
in napise mi: Could not resolve mount point /ath
kaj naj naredim, da bo delalo?

Gandalfar ::

mkdir /ath

morda? :)

JakobSTR ::

unstable zdej sploh ne dela. zamenjam vse stable z unstable, prekopiram gandalfarjev seznam, jav napako!?! (v smislu da un direktorij ne obstaja)
a vam dela unstable?
BTW sm probu SLO, A in USA serverje. ne dela

kaj mi je storiti?

Gandalfar ::

deb ftp://ftp.si.debian.org/debian/ unstable main non-free contrib
deb-src ftp://ftp.si.debian.org/debian/ unstable main non-free contrib
deb http://non-us.debian.org/debian-non-US unstable/non-US main contrib non-free
deb-src http://non-us.debian.org/debian-non-US unstable/non-US main contrib non-free

ce imas _tocno_ tole ti dela. Probi skopirat tisto sporocilo o napaki.

seveda ne pozabi na: apt-get update

JakobSTR ::

zdej downloada v redu, ko je pa treba instalirat, pa jav napako:
Do you want to continue? [Y/n] y
E: This installation run will require temporarily removing the essential package libpam-modules due to a Conflicts/Pre-Depends loop. This is often bad, but if you really want to do it, activate the APT::Force-LoopBreak option.
E: Internal Error, Could not early remove libpam-modules
strbenk:~#

kaksne ideje? (sem probu 'apt-get -o apt::forceloopbreak=true dist-upgrade', pa se zgodi isto). poskusu sm tud xe ugasnt, pa ne pomaga.
-------------------------
problem resen (s pomocjo Gandalfarja)
naredu sm napako pri vpisu dodatnih opcij. pravilno je 'apt-get -o APT::Force-LoopBreak=1 dist-upgrade'

Zgodovina sprememb…

  • spremenil: JakobSTR ()

Simulacrum ::

Obstaja kaksen nacin za automountanje cdroma ali disketnika?

lp
Riplix

vojkoz ::

Problem:
jaz mam preko routerja (planetovega) pol v router imam adsl vštekan.. pol pa iz njega v 4 pc-je :) zdej pa na winsih dela linuxu pa neznam nastavit.. mogoče veš ti kako?

Gandalfar ::

Riplix: apt-cache search automount

na winsih ti samodejno dela? Ce ti potem v linuxu reci samo 'dhclient' ali pa 'pump' pa potem poglej z ifconfig, ce imas mrezo nastavljeno. Se prej pa z 'ifconfig -a' poglej, ce sploh imas mrezno kartico.

V primeru, da nimas dhcpja pa uporabi:

ifconfig eth0 192.168.0.xxx netmask 255.255.255.0

v /etc/resolv.conf si nastavi DNS streznike

vojkoz ::

hem.. zaminivo.. neče delat...
/etc/resolv.conf te datoteke sploh nimam!
Toraj je nekaj fejst narobe..

Gandalfar ::

niti ne.. ustvari jo, ce je nimas..
strani: 1 2 3 4 5 ... 40


Vredno ogleda ...

TemaSporočilaOglediZadnje sporočilo
TemaSporočilaOglediZadnje sporočilo
»

ATI linux gonilnliki in resolucija

Oddelek: Operacijski sistemi
12953 (840) rolihandrej
»

radeon 9200 suse10 brightness problem

Oddelek: Operacijski sistemi
25909 (725) rolihandrej
»

Ubuntu - par vprašanj

Oddelek: Operacijski sistemi
251390 (808) 64202
»

suse 9.1 in radeon 9800PRO

Oddelek: Operacijski sistemi
11684 (556) jurre
»

Linux in kWord

Oddelek: Programska oprema
11740 (587) Gh0st

Več podobnih tem