» »

Debian Gnu/Linux kot workstation

Debian Gnu/Linux kot workstation

««
38 / 40
»»

hruske ::

Meni je na unstable delal cisto lepo kak mesec nazaj. Sicer na kde, ki ni cisto prijatelj s compizom, ampak efekti so bili.

Potem sem ga izklopil, ker je bolj nadležen za uporabo kot ne.
Rad imam tole državico. <3

atasmrk ::

Upam da me ne boste krizali, ker vam jokam o tezavah z Ubuntujem v tej temi.

Probleme imam z zvokom. Slism lahko namrec samo en kanal (od dveh). Kolikor sem brskal po ubuntujevih straneh so ljudje malo posarili po alsamixerj, in stvar je do naslednjega reboota delovala. Ko jaz poskusam zagnati ta mikser, komp javi "function snd_mixer_load failed: Invalid argument". Ko sem gledal nastavitve za multimedijo, sem posumil, da sistem za zvok ne uporablja Alse, ampak OSS. Mikser naprava je namrec Realtek ALC883 (OSS mixer). Test audio sistema sicer piska tako kot more (seveda na en zvocnik) ne glede na to, ali uporablja ALSO ali OSS.

"lsmod | grep snd" izvrze naslednje:

snd_hda_intel          21912  1 
snd_hda_codec         205056  1 snd_hda_intel
snd_pcm_oss            44544  0 
snd_mixer_oss          17408  2 snd_pcm_oss
snd_pcm                79876  3 snd_hda_intel,snd_hda_codec,snd_pcm_oss
snd_seq_dummy           4740  0 
snd_seq_oss            32896  0 
snd_seq_midi            9600  0 
snd_rawmidi            25472  1 snd_seq_midi
snd_seq_midi_event      8448  2 snd_seq_oss,snd_seq_midi
snd_seq                52592  6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
snd_timer              23684  2 snd_pcm,snd_seq
snd_seq_device          9100  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
snd                    54020  10 snd_hda_intel,snd_hda_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,
                                snd_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
soundcore               8672  2 snd
snd_page_alloc         10888  2 snd_hda_intel,snd_pcm


Vse to me napeljuje na misel, da Linux uporablja OSS namesto ALSE. Zna to kdo popraviti? Sem ze vprasal na Ubuntujevih forumih, pa se stvar nic ne premakne. Comunity pa tak.

rok_p ::

Mam naslednji problem...poln disk hda1. V sistemu imam en 160Gb velik disk. A se da kako povečat hda1 na račun hda3 ne da bi bila potrebna ponovna inštalacija celotnega sistema? - kako?
Nikoli nisem pričakoval da bo sistem zasedel skoraj 10 Gb. Nameščen imam Linux debian 2.6.22-1-686.

debian:~# df
Filesystem 1K-blocks Used Available Use% Mounted on
/dev/hda1 9614116 9565252 0 100% /
tmpfs 193280 0 193280 0% /lib/init/rw
udev 10240 100 10140 1% /dev
tmpfs 193280 0 193280 0% /dev/shm
/dev/hda3 142782324 2688576 132840804 2% /home
debian:~#
rok

CCfly ::

Prvo malo popucaj /tmp in /var/tmp ter pobriši programe, ki jih ne potrebuješ. Če bo premalo pa lahko spremeniš velikost particije s programom parted.
"My goodness, we forgot generics!" -- Danny Kalev

Matevžk ::

"Namesto" parted svetujem grafični vmesnik gparted ;).
lp, Matevžk

hruske ::

apt-get clean ti bo tudi kak giga prinesel.
Rad imam tole državico. <3

rok_p ::

hvala za odgovore. sem počistil /tmp in /var/tmp ter naredit apt-get clean...nič od tega ni sprostilo prostora.

povečal sem particijo z gparted iz cca 10 Gb na cca 25 Gb, sedaj pa opažam da se disk polni.

pred uro in pol:
debian:~# df
Filesystem 1K-blocks Used Available Use% Mounted on
/dev/hda1 24733048 10820356 12907668 46% /

zdaj:
debian:/# df
Filesystem 1K-blocks Used Available Use% Mounted on
/dev/hda1 24733048 11895640 11832384 51% /

5s za prejšnjim:
debian:/# df
Filesystem 1K-blocks Used Available Use% Mounted on
/dev/hda1 24733048 11897516 11830508 51% /

očitno mi nekaj polni to particijo.

Prosim za nadaljno pomoč.
rok

Gandalfar ::

poglej kako velik imas /var/log

oz. /var nasplosno

rok_p ::

debian:~# du -hs /var/log/
9.4G /var/log/

debian:~# du -hs /var/
9.5G /var/

Predvidevam da gre za loge. Kako ugotovim kateri programi vse zapisujejo loge?
rok

hruske ::

cd /var/log
du -sh *

in sledis najvecjim mapam.
Rad imam tole državico. <3

Gandalfar ::

če ne veš kaj kakšen fajl počne ga ne slepo zbrisat. Raje ga najprej kam premakni oz. preimenuj, ker tudi apt baze ipd. živijo v /var in se da hitro kaj pokvarit.

V /var/log pa je situacija navadno manj kriticna.

hruske ::

Zgolj brisanje ti tudi ne bo pomagalo, najbolje bo, ce ugotovis kako izklopis (tako zgovorno) logiranje.
Rad imam tole državico. <3

Matevžk ::

Vkolikor imaš na voljo grafični (X) sistem (kar ga na workstationu najbrž imaš), lahko za analizo porabe prostora uporabiš tudi program 'baobab'. Ti lepo grafično strukturira velikost map. Tako boš najlažje odkril grešnega kozla.
lp, Matevžk

vojko20 ::

Imam eno vprašanje glede aptja.

Torej

v sources.list imam vpisano da mi tako stable tree in unstable tree upošteva.

Sedaj sem inštaliral en paket recimo pak1-ver-1 iz stable treeja v unstable treeju pa obstaja pak1-ver-2. Kako bi sedaj preprečil, da mi dist-upgrade updata ta paket na verzijo 2 (jaz hočem samo verzijo 1 ker je pač boljša/manj bloated od 2).

christooss ::

Temu se reče apt-pinning
Zakaj je nebo modro? Da imamo lahko sladoled Modro Nebo

vojko20 ::

super že dela :)

m1h4 ::

zanima me, ce je mozno, da pakete, ki jih zahteva dolocena aplikacija nalozim avtomaticno da mi jih ni potrebno rocno nalagati vsak paket posebej_
Recimo, da dam se en primer :


/home/miha/Desktop/Downloads# dpkg -i extragear-plasma_4.0.0-1_i386.deb
Selecting previously deselected package extragear-plasma.
(Reading database ... 121558 files and directories currently installed.)
Unpacking extragear-plasma (from extragear-plasma_4.0.0-1_i386.deb) ...
dpkg: dependency problems prevent configuration of extragear-plasma:
extragear-plasma depends on extragear-plasma-data (>= 4:4.0.0-1); however:
Package extragear-plasma-data is not installed.
extragear-plasma depends on kdebase-runtime; however:
Package kdebase-runtime is not installed.
extragear-plasma depends on kdebase-runtime-data; however:
Package kdebase-runtime-data is not installed.
extragear-plasma depends on kdebase-workspace-bin; however:
Package kdebase-workspace-bin is not installed.
extragear-plasma depends on kdelibs5 (>= 4:4.0.0-1); however:
Package kdelibs5 is not installed.
extragear-plasma depends on kdepimlibs5; however:
Package kdepimlibs5 is not installed.
extragear-plasma depends on libc6 (>= 2.7-1); however:
Version of libc6 on system is 2.3.6.ds1-13etch4.
extragear-plasma depends on libplasma1; however:
Package libplasma1 is not installed.
extragear-plasma depends on libqt4-core (>= 4.3.3); however:
Version of libqt4-core on system is 4.2.1-2+etch1.
extragear-plasma depends on libqt4-gui (>= 4.3.3); however:
Version of libqt4-gui on system is 4.2.1-2+etch1.
dpkg: error processing extragear-plasma (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
extragear-plasma

christooss ::

Seveda se da

apt-get -f install
Zakaj je nebo modro? Da imamo lahko sladoled Modro Nebo

space_monkey ::

Nalozen imam Debian 4.0 “etch”. Rad bi instaliral aplikacijo (libprs500) za python verzije vsaj 2.5.1. Problem je, ker zgleda, kot da python 2.5 ni podprt v debian 4.0, predvidevam.
Moram imeti potem debian sid, nestabilno verzijo gor, da lahko instalram aplikacijo ali bi slo kako drugace?

christooss ::

par postov gor poglej za link apt-get pinning
Zakaj je nebo modro? Da imamo lahko sladoled Modro Nebo

hruske ::

Ne se hecat, Python 2.5 je v Debian "etch".

A lahko prilepis tocno kaj ti izpise?
Rad imam tole državico. <3

space_monkey ::

Python 2.4.4 (#2, Jan 3 2008, 13:36:28)
[GCC 4.2.3 20071123 (prerelease) (Debian 4.2.2-4)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>>

Pa sem ze 2krat nalozil python2.5, naredil update...

apt-get install python2.5
Reading package lists... Done
Building dependency tree... Done
The following extra packages will be installed:
libdb4.5 python2.5-minimal
Suggested packages:
python-profiler python2.5-doc binfmt-support
The following NEW packages will be installed:
libdb4.5 python2.5 python2.5-minimal
0 upgraded, 3 newly installed, 0 to remove and 434 not upgraded.
Need to get 4572kB of archives.
After unpacking 15.9MB of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 ftp://ftp.debian.org testing/main libdb4.5 4.5.20-11 [525kB]
Get:2 ftp://ftp.debian.org unstable/main python2.5-minimal 2.5.1-7 [1165kB]
Get:3 ftp://ftp.debian.org unstable/main python2.5 2.5.1-7 [2882kB]
Fetched 4572kB in 1m26s (52.8kB/s)
W: Couldn't stat source package list ftp://ftp.nerim.net unstable/main Packages (/var/lib/apt/lists/ftp.nerim.net_debian-marillat_dists_unstable_main_binary-i386_Packages) - stat (2 No such file or directory)
Selecting previously deselected package libdb4.5.
(Reading database ... 62089 files and directories currently installed.)
Unpacking libdb4.5 (from .../libdb4.5_4.5.20-11_i386.deb) ...
Selecting previously deselected package python2.5-minimal.
Unpacking python2.5-minimal (from .../python2.5-minimal_2.5.1-7_i386.deb) ...
Selecting previously deselected package python2.5.
Unpacking python2.5 (from .../python2.5_2.5.1-7_i386.deb) ...
Setting up libdb4.5 (4.5.20-11) ...
Setting up python2.5-minimal (2.5.1-7) ...
Linking and byte-compiling packages for runtime python2.5...

Setting up python2.5 (2.5.1-7) ...

W: Couldn't stat source package list ftp://ftp.nerim.net unstable/main Packages (/var/lib/apt/lists/ftp.nerim.net_debian-marillat_dists_unstable_main_binary-i386_Packages) - stat (2 No such file or directory)
W: You may want to run apt-get update to correct these problems

space_monkey ::

pod "su" probam:
/etc/apt/sources.list
bash: /etc/apt/sources.list: Permission denied

nevem zakaj mi ne dovol?

christooss ::

ne dovolj ti zaradi tega ker hočeš pognat sources.list

probaj kot root

nano /etc/apt/sources.list
Zakaj je nebo modro? Da imamo lahko sladoled Modro Nebo

Screamboy ::

kej bi dobil najnovejso sourc listo za unstable debian seveda

Lp
-> Slovenska skupnost uporabnikov Ubuntuja <--
-----------------> www.ubuntu.si <------------------

Gandalfar ::

namesto stable naj pise unstable. To je to, ne rabis novejse source liste.

Urc ::

Zanima me kateri torrent odjemalec za linux je prijazen med inštalacijo in uporaben. Do zdaj sem poskusil cTorrent vendar nisem zadovoljen. Aja, seveda rabim stvar v konzoli...:)

Lp

Screamboy ::

se nekaj me zanima sem nalozil nov kernel 2.6.24.1-686 vsaj mislim d aje tako nima veze vsak odvejsi od 2.6.18.6 mi pri zagonu se ustavi pri waiting for root. Znan bug v kernelu vendar nikjer nisem nasel resitve.

"Waiting for root file system..."

ce kdo ve kako to popraviti
Lp
-> Slovenska skupnost uporabnikov Ubuntuja <--
-----------------> www.ubuntu.si <------------------

Zgodovina sprememb…

Urc ::

Zgleda da ne uporabljajo več Linuxa. Jah sej Linux je out of date, gremo vsi po Visto! :\

Ok, zdaj pa resno vprašanje... Uspelo mi je usposobit rTorrent, vendar kakorkoli editam rtorrent.rc se rtorrent ne požene več. Naj bi bilo zart tega ker se shrani kot DOS besedilo. Ma kdo kake izkušnje s tem ? Za editiranje uporabljam nano. |O

Zahvaljujem se vam za pomoč in lp

Zgodovina sprememb…

  • spremenil: Urc ()

Screamboy ::

a nima nihce tega problema?
-> Slovenska skupnost uporabnikov Ubuntuja <--
-----------------> www.ubuntu.si <------------------

BaRtMaN ::

@Urc: Če imaš desktop mašino, raje uporabi grafičnega klienta kot konzolni rtorrent. Priporočam Transmission zaradi preprostosti, če pa želiš nekaj precej podobnega uTorrentu in več nadzora, probaj Deluge.

Urc ::

BaRtMaN hvala ampak nimam desktop mašine, imam samo terminal dostop. No kakorkoli zadevo mi je potem uspelo poštimat tako da sem spremenu dos format v unix :)

hruske ::

Screamboy, poskusi preverit, če imaš pravilno nastavljeno root particijo v Lilo oz. GRUB-u oz. če imaš nameščen udev. Mislim da to izvira iz tega, da se kernel ustavi in čaka, da bo določena particija vidna, kar pa se nikoli ne zgodi ker ne obstaja.
Rad imam tole državico. <3

SkIDiver ::

Na virtualnem računalniku (innotek VirtualBox) imam nameščen Ubuntu 7.10. Lahko nekdo pove kako namestim dodatke za virtualca? Sem probaval nekaj metod, ki sem jih našel pa mi nekak ne uspe.

Daedalus ::

Pred zagonom virtualca mu nastaviš cdrom kot iso image - v /usr/share/virtualbox najdeš guestadditions iso fajl. Zaženeš, ob zagonu je itak mountan. Greš v cdrom direktorij in kot root/sudo poženeš *.run file, pa malo počakaš. Pol pa restart in to je to. Pravkar izvedeno na 8.04 guestu, Vbox pa lavfa na 7.10 host mašini.
Man is condemned to be free; because once thrown into the world,
he is responsible for everything he does.
[J.P.Sartre]

SkIDiver ::

Sem poskusil;

yyy@yyy-desktop:/media/cdrom$ sudo VBoxLinuxAdditions.run
[sudo] password for yyy:
sudo: VBoxLinuxAdditions.run: command not found
yyy@yyy-desktop:/media/cdrom$


Bolj kot ne očitno sem lesen z linuxom tako, da bi bil vesel kakega navodila kako in kaj, vključno s tem kako narediš mount iso datoteke.

Daedalus ::

Sem poskusil;

yyy@yyy-desktop:/media/cdrom$ sudo VBoxLinuxAdditions.run
[sudo] password for yyy:
sudo: VBoxLinuxAdditions.run: command not found
yyy@yyy-desktop:/media/cdrom$


Bolj kot ne očitno sem lesen z linuxom tako, da bi bil vesel kakega navodila kako in kaj, vključno s tem kako narediš mount iso datoteke.


Ok, ena hitra lunix lekcija - če poganjaš izvršljive datoteke, ki so na sistemski poti ($PATH spremenljivka), pol je ok, da napišeš sudo imeprograma. Če pa poganjaš program, ki ni na sistemski poti, pol se pa program poganja nekoliko drugače - pred ime datoteke dodaš piko in forward slash ./imeprograma. Drugače bo lunix pogledal v $PATH in ker tam seveda ni dodana pot do VBoxLinuxAdditions.run fajla, bo zajamral, da ukaza ne najde.

Torej v tvojem primeru:

sudo ./VBoxLinuxAdditions.run

Pa bo delalo.

p.s. - Foobuntu ti samodejno mounta CD pogon (pravi al pa emulacijo), ko pogrunta, da je v pogonu medij/iso fajl. Okoli tega ne rabiš skrbet. Če ne bi bil mountan, ne bi prišel do VBoxLinuxAdditions.run fajla:D
Man is condemned to be free; because once thrown into the world,
he is responsible for everything he does.
[J.P.Sartre]

Zgodovina sprememb…

  • spremenilo: Daedalus ()

SkIDiver ::

Daedalus sedaj pa je steklo. Hvala.

A lahko malo več poveš o sistemski poti ali pa podaš kako povezavo kjer si lahko kaj preberem o tem?

Daedalus ::

Recimo tole je en tak simpl tutorial

Edino še en dodaten nasvet - če te zanima trenutna pot, vrži v konzolo ukaz echo $PATH. Ostalo ti pa vse na zgornjem linku piše, mislim, da dosti razumljivo in nazorno.
Man is condemned to be free; because once thrown into the world,
he is responsible for everything he does.
[J.P.Sartre]

DixieFlatline ::

Ko poženem ./configure skripto mi javi, da manjka nekaj knjižnic. Sedaj sem potegnil manjkajočo knjižnico z interneta, a mi še vedno javi isto.
Kje ./configure skripta išče knjižnice, ki jih rabi(kam jih moram shraniti)?
Imam ubuntu 8.04.

Hvala
The sky above the port was the color of television, tuned to a dead channel.

BaRtMaN ::

Boljše je, da knjižnico namestiš preko orodja apt. Paketi, s katerimi se operira, imajo zapisano pot, kamor naj se datoteke namestijo, neprimerno lažje je nadgrajevanje in brisanje knjižnic/programov.

Najboljša pot je, da najprej poženeš
$ apt-cache search <ime knjižnice>

Izpišejo se ti paketi, ki ustrezajo iskanemu geslu (imenu knjižnice). Izluščiti moraš tisti paket, ki ga rabi tvoj program in ga namestiti z
# apt-get install <paket s knjižnico>

Zgodovina sprememb…

  • spremenil: BaRtMaN ()

zdobersek ::

Instalirat moraš *-dev knjižnico, recimo libgkt2.0-dev.

BaRtMaN ::

Ja, na to tudi jaz pogosto pozabljam. :)

Pri prevajanju C(++)-jevskega programa rabiš headerje knjižnic, ki jih dobiš s paketom <paket s knjižnico>-dev.

DixieFlatline ::

Tnx Bartman, že laufa!
The sky above the port was the color of television, tuned to a dead channel.

DixieFlatline ::

A tole drži:
NEVER EVER EVER type 'make install'. It's really messy and you need to keep the source if you ever want to uninstall. Instead do a 'sudo apt-get install checkinstall' and then INSTEAD of 'sudo make install' type 'sudo checkinstall'. That will make a .deb file and install that so if you want to ever remove it, you can just do a sudo apt-get remove packagename. It's very difficult to remove files from a 'sudo make install'
The sky above the port was the color of television, tuned to a dead channel.

BaRtMaN ::

Drži.

Daedalus ::

Odvisno od primera. Če se samo igračkaš, pol zna biti problem pucat stvari po "make install". Če spravljaš skup kaj produkcijskega, pol pa itak nimaš namena odstranjevati stvari. Pa v večini primerov lahko z ./configure --some-switch spremeniš direktorije, v katere naj make install zloži stvari. Jaz jih ponavadi mečem v /opt/imeprograma_verzija, pol pa to symlinkam na /opt/imeprograma, da ni problemov pri "inštalaciji" nove verzije. Tako da tisto opozorilo je bolj za one, ki ne vejo točno, kaj delajo>:D

Je pa precej lažje delat s paketki in se jih velja držati, kadarokoli je to možno.

Aja, pa za namestitev kompilerja, libc knjižnjic, kernel headerjev in še ene par stvari je dobro vedet:

apt-get install build-essential

za kernel module pa maš module-assistant. Hm, o tem bi kr šlo kak članek spisat:D
Man is condemned to be free; because once thrown into the world,
he is responsible for everything he does.
[J.P.Sartre]

DixieFlatline ::

Kako najdem lokacijo, kamor se je z apt-get install namestil določen program?
The sky above the port was the color of television, tuned to a dead channel.

CCfly ::

dpkg -L ime_paketka
"My goodness, we forgot generics!" -- Danny Kalev

Screamboy ::

Lp sem namestil clean install lenny. Sedaj pa ko zazenem startx in mi pride v gdm mi vecne deluje miska in tipkovnica ce pa pritisnem ctrl + f1 mi pride v lupino in takrat mi tipkovnica deluje. Kako bi to uredil?
Lp
-> Slovenska skupnost uporabnikov Ubuntuja <--
-----------------> www.ubuntu.si <------------------
««
38 / 40
»»


Vredno ogleda ...

TemaSporočilaOglediZadnje sporočilo
TemaSporočilaOglediZadnje sporočilo
!

[(K)Ubuntu] Vprašanja in težave (strani: 1 2 3 417 18 19 20 )

Oddelek: Operacijski sistemi
976272557 (6685) poldy_nwx
»

Python - pošlji aplikacijo na server

Oddelek: Programiranje
201213 (448) HotBurek
»

Debian in iptables

Oddelek: Operacijski sistemi
171414 (1136) karafeka
»

X window na Debianu mi ne dela

Oddelek: Operacijski sistemi
91121 (1040) roscha
»

Bi Linux? Bi Debian? Ubuntu! (strani: 1 2 3 48 9 10 11 )

Oddelek: Operacijski sistemi
53028608 (16149) Trubadur

Več podobnih tem