» »

SuSE 8.2 in NF7-S

SuSE 8.2 in NF7-S

MOJNET.net ::

Zakaj se mi noče namestit SuSe linux. Pride do tam ko ga butnem in klofnem instalacijo, potem pa samo še črn ekran.

Domnevam, da je kaj z gonilniki, ki jih suse ne prozna. Ima kdo mogoče rešitev?
WEBhosting / WEBdesign / WEBdomain / Security Solutions /

BaRtMaN ::

Mene pa zanima kako je s podporo on-board mrežnih kartic na nForce 2 Ultra400 ploščah (recimo Abit NF7-S) v distribucijah Linuxa. Na NESTu je Gandalfar rekel, da moramo vsi kupit mrežne kartice za PCI, če imamo integrirano.

OwcA ::

Odvisno od tega čigava mrežna je integrirana. S kakšnimi Intelovimi in 3COMovimi naj ne bi bilo prehudih zapletov.
Otroška radovednost - gonilo napredka.

Jebiveter ::

Glede mreznih: meni deluje super integrated mrezna od VIA-e (plata z KT333). Je delovalo tudi na NESTu zelo v redu! (beri: rozica):D

Glede instalacije Suse: Ob bootu z CDja v boot menuju spremeni resolucijo, ki jo uporablja med instalacijo. Mozno je, da je nastimana previsoka resolucija in monitor odpove (al pa drajverji nocejo...)
BTW: kaksna graficna? (oz. katera?)
Certainty of death. Small chance of success. What are we waiting for?

mile ::

MOJNET.net ::

Ste pa hitri :D

V gvanem resolcuja je pravilna (sem sprobal prav vse). Graficna pa je GF4TI 4200 .

Sedaj pa glavno vprasanje: Kako naj te gonilnike iz zgoraj naveden strani vmesam med istalacijo, ce pa ze vse prej odpove. [sem pac zacetnik in SuSE je moje izbira, da se ga malo naucim uporabljati, potem pa na Debilkota - če mi bo zaprinešeno >:D ].
WEBhosting / WEBdesign / WEBdomain / Security Solutions /

mile ::

Tist je blo za bartaman-a

Ti pa probaj ob boot-u vnest parameter "nofb"

Pomoje moraš izklopit framebuffer

Zgodovina sprememb…

  • spremenil: mile ()

MOJNET.net ::

ne, to ne dela :\
WEBhosting / WEBdesign / WEBdomain / Security Solutions /

BaRtMaN ::

mile: hvala! Najraj bi se v zemljo pogreznil, ker sem pozabil na nforce gonilnike.

mile ::

kaj pa vga=normal ?

matevzm2 ::

Jaz nisem imel problemov z grafiko, mrezna me pa je zafrkavala.
Instaliral sem sistem, Yast je trdil da kartico pozna in je vse skonfigurirano, ampak delala pa ni. Pri bootu (ce pritisnes F2) je lepo napisalo, da eth0 ne dela. Sem pobral nVidia gonilnike, instaliral, se vedno nic.
Potem pa je prisel na vrsto dobri stari ifconfig in je zacelo delati.

thezerox ::

mojnet: probaj pri bootu instalacije dati acpi=off ali pa izberi safe install ali nekaj podobnega, saj se vec ne spomnim. Namrec 8.2 ima tezave s acpi, takoj da ko enkrat izklopis acpi pri instalaciiji, ti bo sistem pognal vedno brez acpi.

root ::

Samo izberi opcijo APCI= off al nekaj takega ob instalaciji, ne rabiš savemoda. Jaz mam SuSE 8.2, plata je Abit NF7-S pa še radeona 9500 pro mam gore, pa mi dela vse super od mrežne, zvočne pa tudi 3d pospeševanje mi dela čeprav ne morem namestit tazadnih driverjev, ker majo težave z nforce2 platami.

Wox ::

root: Daj mi prosim povej, kaj moram vse nardit da lahko zaženem X window. Mene namreč vrže v ukazni način, skartka ne prepozna mi grafične.
Mam pa Suse 8.2, Abit NF7-S in grafično Radeon 9000.

root ::

Ja tak naredi.
Glede namestitve susov je tak ko boš butal s cdja izberi apci = off (al nekaj takega je ena opcija drugače pa bi mogo save mode delat 100%)
Ob namestitvi poglej da se ti namesti athlon kernel (k_athlon je ime paketa) in ne def. i586 kernel (k_def.). No upam da boš najdo to (tam med paketi je). Pa glej tudi da boš sorce od kernela tudi namestill.
No po instalaciji bi ti se ti mogo sistem lepo zagnat in tudi it v x winse. Nato pa si potegni nforce drivere z nvidijine strani. Evo
tukaj maš pa 2.9.12 firegl drivere za grafično kartico. Tukaj maš pa modifikacijo driverov, da delajo driveri na nforce ploščah.

Zdaj pa idi v /usr/src/linux direktorij in naredi make xconfig ali make menuconfig (za to moreš bit root) ter samo idi v pa spremeni tip procesorja iz i586 v athlon/duron nato idi ven pa shrani spremembe. Jedra ne rabiš prevajat, ker si tak med instalacij izbral athlon jedro, zdaj si samo spremenil nastavitve da boš lahko namestil firegl drivere.

Nato pa idi prvo instalirat nforce drivere (rpm -ivh NVIDIA_nforce-1.0-0261.suse82.i586.rpm ) nato pa instaliraj firegl drivere (rpm -ivh fglrx-glc22-4.3.0-2.9.12.i586.rpm) ter kopiraj build_mod.tar.gz v /lib/modules/fglrx nato pa razpakiraj build_mod z ukazom tar -xzvf build_mod.tar.gz. ter idi v potdirekorij build_mod ter izvedi ukaz ./make.sh nato idi v podirektorij in izvedi ./make_install.sh. Zdaj pa izvedi ukaz fglrxconfig.

To bi moglo bit vse zdaj. Za vel informacij pa lahko pogledaš tale forum. Drivere pa lahko downlodaš z te strani. Lahko pa greš tudi na atijevo stran pa tam izberi firegl grafično kartico. Ampak novejši driveri kot 2.9.12 ti za enkrat ne bodo delali vsaj dokler suse ne izda kakšnega novejšega jedra (2.4.22) ki ima vgrajene nforce agp podporo.

No pa tukaj lahko tudi kaj vprašaš se bom malo bol potrudo pa bolpogosto čital foum :D :D :D .

Wox ::

Wow. Hvala za izčrpna navodila. Bom probal.

Wox ::

Hja. Po neprespani noci lahko recem, da sem kar napredoval. Zgleda da ce ne namestim sourca mi po instalaciji noce iti v GUI. Samo 4 krat proba it notri pol pa me vrze v ukazni nacin. No, ce instaliram source, gre lepo v GUI. Tudi zvok dela takoj po instalaciji, brez Nvidiinih driverjev. Tudi driverji za nforce2 se lepo nalozijo in NIC dela. Tak da lahko grem celo na internet. In tole zdaj pisem v nekem Konquerorju. Samo ko tipkam, nimam sumnikov. Evo probam: 蚞ȊŽ.
One driverje za graficno mi sicer namesti, kljub temu da se ves cas pritozuje da nekaj ni vredi. Ko pa hocem zagnati ikse, pa pravi med drugim, da ne najde screena. Tak da sem zdaj v bistvu brez 3D grafike in pa tudi 2D je nekam pocasna. V nekem forumu sem zasledil, da naj bi ti driverji delali samo s karticami build by ATI in ne tudi z powered by ATI. Moja je namrec od Sapphira. Root, a ti mas build by ATI graficno?
No, bilo kako bilo. Sem se vsaj nekaj ukazov v Bash ukazni lupini nauco, pa vido da Linuxi niso samo tako. Je pa tole KDE namizje kar prijetno za oko.
Tolko zaenkrat, pa se enkrat hvala za pomoc.

root ::

Jaz mam tudi build by ati kartico, samo mam 9500pro tak da ne vem mogoče je zaradi tega.

Ja upam da si po namestitvi driverov za grafično zagnal fglrxconfig. Tak če si potem ti šumniki zaradi tega to popraviš tako da pogledaš fail /etc/X11/XF86Config-4 (recimo z pico /etc/X11/XF86Config-4 al pa čem drugem kaj hočeš). potem pa tam poišči tole:

Option "XkbRules" "xfree86"
Option "XkbModel" "microsoft"
Option "XkbLayout" "si"
No tak mam jaz ker mam mikrosoftovo tipkovnico, ti maš vrjetno drugi model. Tam pod layout pa moreš nastavit "si". Ko spremeniš lepo shrani (če si v pico z ctrl x pa y potem za potrditev da ti shrani) potem pa restartaj x winse pa bi mogla tipkovnica delat.

Hm glede 3d podpore pa ne vem probaj dat ukaz v xih fglrxinfo. Pa napiši mi kake erore ti venvrže da vidm če se da kaj naredit.


Vredno ogleda ...

TemaSporočilaOglediZadnje sporočilo
TemaSporočilaOglediZadnje sporočilo
»

Linux vprašanja

Oddelek: Operacijski sistemi
312238 (1471) BigWhale
»

Suse 9.0 (strani: 1 2 )

Oddelek: Operacijski sistemi
664052 (3338) moj_nick
»

nForce 2 driverji in Mandrake linux (strani: 1 2 3 )

Oddelek: Operacijski sistemi
1094091 (3279) sh4rk
»

nVidia+Suse(Linux nasploh)

Oddelek: Operacijski sistemi
8943 (875) jlpktnst
»

Problem z Linux Red Hat 9

Oddelek: Operacijski sistemi
171294 (1127) root987

Več podobnih tem