» »

jebe*** šumniki

jebe*** šumniki

tao_s ::

OK zdaj mi pa res ni nič več jasno!

Na strani naštimam encoding windows-1250, spravim kot win-1250. Na localhostu vse skupaj deluje lepo. Vsi šumniki pravilno prikazani, IE pravilno prepozna encoding.

Potem sem vso skripto prenesel na server. Šumniki so k** kvadratki, ker IE avtomatično prepozna, da je stran kodirana po ISO-8859-2 standardu. Če ročno nastavim encoding na win-1250 zadeva spet dela.

Kaj je lahko narobe, da mi IE VEDNO narobe prebere encoding stil???
A moram kaj dodati?


aja head dokumenta je pa takle (<> oklepaje sem zamenjal s (), ker drugače ne prikaže kode)


(head)
(meta http-equiv="Content-Type" content="text/html; charset=windows-1250")
(title)taborniški rod SAMORASTNIKI :: Z naravo k človeku!(/title)
(meta name="KEYWORDS" content="management, webcontentmanagement" /)
(meta name="DESCRIPTION" content="Z naravo k človeku!" /)
(meta name="ROBOTS" content="INDEX,FOLLOW" /)
(meta name="resource-type" content="document" /)
(meta http-equiv="expires" content="0" /)
(meta name="author" content="taborniški rod SAMORASTNIKI" /)
(meta name="copyright" content="Copyright (c) 2001 by taborniški rod SAMORASTNIKI" /)
(meta name="revisit-after" content="1 days" /)
(meta name="distribution" content="Global" /)
(meta name="generator" content="PostNuke 0.7.1 - http://postnuke.com" /)
(meta name="rating" content="General" /)
(link rel="StyleSheet" href="themes/PostNukeBlue/style/styleNN.css" type="text/css" /)
(style type="text/css">@import url("themes/PostNukeBlue/style/style.css"); (script type="text/javascript" src="javascript/showimages.php">
(script type="text/javascript" src="javascript/openwindow.php?hlpfile=modules/NS-Admin/lang/slv/manual.html">
(/head)
  • spremenil: tao_s ()

Loki ::

uporabi iso-8859-2.

in nastavi si IE na auto-detect.

in ce ze uporabljas xhtml, ga uporabljaj tudi v tem meta-tagu.

Zgodovina sprememb…

  • spremenil: Loki ()

tao_s ::

če uporabljam iso-8859-2 šumniki sploh ne delajo... oz moram vse lng datoteke na novo odpret in jih pospravit kot iso format :\

bom še mal počakal, ker je s tem kar nekaj dela, če drugege rešitve ne bom našel bom naredil tako... hvala

kaj misliš s tistim xhtml?

tao_s ::

kako se v ultra-editu nastavi iso-8859-2 encoding (da ti ga vedno loada in vedno shranjuje?)

darh ::

tao_s: žal se ne da...
Excuses are useless! Results are priceless!

matic ::

prejsnji dreamwevaer zna super delat z njim (z iso-8859-2)
Z MXom pa se nisem nastudiral.. neki me jebal.. zdej pa nevem.. a so kej zjebal al se zmer tko super dela kot je delal v presjnsji verziji?

Gandalfar ::

stupid question, a je mogoce ze kdo poskusil dat bug report avtorju ultraedita za ta problem? Zadnja razlicica je recimo 9.10a? In zgleda da bi znal avtor zelo hitro popraviti to napako, ce bi ga kdo pravilno obvestil o problemu.

JLP ::

Ja jest sm ga en cajt nazaj kr en cajt prosu za to pa drugi tud. Sam zgleda da ne zna narest al pa mu Bog ne pusti :))
Live long and prosper!

Ziga Dolhar ::

Kadar v DW MX urejam filetek, ki nima meta tagov (je samo "contents include"), vedno najprej desno kliknem, izbere charset 8859 2 ter kliknem "Reload". spremenim, dopišem, napišem..... potem shranim. Ko naslednjič odprem, pa zopet charset > Reload.

Zoprno, ni kej. Sicer sem poskušal s tem, da sem dal na vrh dokumenta v html komentarje meta tag s tem, vendar so se potem pritoževal razni validatorji.

tao_s ::

kaj pa Unicode UTF-8???

a tega nihče ne uporablja? Zakaj ne? Meni se zdi trenutno boljši od Iso in windows standarda

matic ::

jaz sploh se nisem slisal!? 8-O :\
Ampak vem pa da ISO dela povsod, windows standard pa ze po imenu razvidno samo v windosih.. pa se to ne vseh.. :D

tao_s ::

iso-2 je kura* -> predvsem, če hočeš datoteke večkrat popravljat&shranjevat..
windows1250 dela zelo lepo (seveda samo v win)


unicode UTF-8 naj bi bila prihodnjost - pa pravijo, da se ni povsod podprt... pa me zanima kje ni podprt? kaj mu manjka?

krho ::

mne utf8 dela cist lepo in V IE6 in v mozilli.

JLP ::

Hm če maš uredu editor pol se čist lepo shranjuje kakršnkol encoding k ga podpira editor, tud ISO-8859-2. Če ne dela prov je neki narobe z editorjem.
Drgač pa ja UTF-8 je zlo uredu standard za encodiranje. Pa še clo notepad u WinXP ga podpira. Jest če kej pišem večinoma kr UTF-8 uporablam in je še posod delov uredu.
Live long and prosper!

tao_s ::

utf sem zdaj preizkusil na win98, XP in linuxu - povsod delalo OK :D

potem sem spet optimistično spremenil vseh 35 datotek (za prevod portala v slo) v utf format... jebemti** zdej ne dela enostavo neke errorje javlja - a je mozno, da zardi encodinga al sem kje drugje zajebal... jst bom popizdil !

matic ::

pomje da si bolj kaj druzga.. kak narekovaj ipd kje prevec zbrisal ali pa celo dodal.. Ponavadi tudi ce v encoding napises cickeracke dela.. sam ne tocno tako kot si ti zamislis... :\

tao_s ::

ne, zihr nisem nič pobrisal... šel sem namreč poskusit nazaj - datoteke spet spreminjal v iso, pa potem v dat1.php ni bilo napake, je bila v dat2.php, ko sem dat2 spremenil v iso, je bila napaka javljena v dat3 itd...


drugače sem pa zdaj dobil DREAMWEAVER 4, MX pa pobrisal... čudežno dela tudi iso.8859-2 standard... ?!!!

hvala bogu, je bila napaka v programih, ker sem počasi res začenjal verjet, da sem jst neumen...>:D

matic ::

v dw4 je delal iso.8859-2 fulllll lepo! Brez problemov.. ali si pisal source ali pa v design modu al ka se ze rece unmu.. med tem ko v DWmx sem tut jaz mel neki problemov.. zdej sem ga mau nastavu in zgleda da dela ok.. morm se precekirat tocno.. se nisem..

tao_s ::

v MX dela lepo, samo če imaš na začetku v headu zapisan encoding, ki naj ga uporabi....

torej z iso2 lepo dela na kompletnih spletnih straneh! ko imaš pa naprimer 100 datotek s spremenljivkami za jezik (torej xyx.php katero moraš prevesti) in nimaš nikjer tega napisanega pa iso2 ne dela. Zakaj? Ne vem! Zgleda, da spravi kot iso2, ko pa naslednjič odpreš ti ga pa odpre kot iso1, al pa kaj druzga... jst sem pregledal VSE nastavitve, nastavil iso2 kot defult, posebej specificiral za vsako stran iso2, pa ni delal... potem sem začel verjet, da nekaj ni v redu z mano in sem poklical se prijatelja, ki je sel rocno cez vse nastavitve, pa tud ni delal... mora bit napaka v programu! Se dobro, da ga nisem kupil ampaksem laufal trial version!

Highlag ::

Delam na eni strani.
Do sedaj je imela stran enostaven html, brez form-ov ...

Charset je nastavljen na Iso-8859-2
Vse je lepo in prav.

Dodam formo z nekaj gumbi.
Tekst v gumbu je napačno prikazan.
V editorju pravilno kaže "š" , v IE-ju pa je namesto njega kvadratek. ;(
Ostali tekst je v redu.

Očitno zna IE forme prikazati pravilno le če so kodirani v Windows-1250 formatu?

Ali se to da kako popraviti??


lordgreg ::

pozdrav...

tudi sam sem po 6 letih htmlja pogruntal, da bo treba zacet nek standard uporabljat.

za pisanje html-ja in php-ja pač uporabljam ultraedit. zaj jaz ne vem kako je to,.. a moram za šumnik oz. šičnik kaj druga knofnit da se mi bo v browserju prav prikazal.

če nastavim na iso-8859-2, potem itak dela samo č, te pa zaj ne vem, kaj morm prtisnit...

če pa nastavim na UTF-8, potem pa mi namesto šumnikov izpisuje kitajske znake (al japonske kaj te vem),..


dajte mi proism eno resnično pametno rešitev predlagat!

a je to od programov odvisno al kak? v čem je fora? kaj prtisnit :'(

hvala vsem za pomoč ;)

krho ::

uporabi &_#352;&_#353; , za š, ... brez _

dela, če maš nastavljen na iso*-*-2 ali utf8

Zgodovina sprememb…

  • spremenil: krho ()

Highlag ::

Krho
A bi ti tole lahko malo bolj natančno napisal?

Imam eno kjigo kjer sem našel kode
&_#200; = Č
&_#232; = č

Sam mam problem ker se konča lista pri
&_#255;

Kje si našel kode še za ostale šumnike?
Mislim za š Š
&_#353 = š
&_#352 = Š

Znak _ pri vpisovanju spusti!

Lahko napišeš še za Ž in ž? :8)


Kako zaboga se v ta forum vnese tekst da ne bo interpretiran kot html ;((

Zgodovina sprememb…

  • spremenil: Highlag ()

krho ::

function SlovenianChars(str){
//array ("Č" => "\u010c","č" => "\u010d","Š" => "\u0160","š" => "\u0161","Ž" => "\u017d","ž" => "\u017e");
str = str.replace(/&_#268;/g,"\u010c");
str = str.replace(/&_#269;/g,"\u010d");
str = str.replace(/&_#352;/g,"\u0160");
str = str.replace(/&_#353;/g,"\u0161");
str = str.replace(/&_#381;/g,"\u017d");
str = str.replace(/&_#382;/g,"\u017e");

return str;
}

evo ti tle maš še unicode za v javascript message
si.Mail odprto-kodni odjemalec elektronske pošte. - http://www.simail.si
Uredite si svojo zbirko filmov, serij in iger - http://xcollect.sf.net

Highlag ::

Super :))

Tr0n ::

Jop, jaz sem tudi pogruntal, da je s temi encodingi pravo sranje po domace povedano. Ce je ok v ultraediju, ni na strani, ce je na strani ok, ni v ultraeditu in v bazi itd... Potem je pa spet odvisno kak encoding ima nekdo v browserju nastavljeno bla bla bla...

Na kratko: je se kak drug kewl text editor razen seveda notepada, ki ima dobro podporo za te encodinge?

krho ::

TrOn:

jaz potem v php ju popravim iz UTF-8 na iso-*-2 in šele nato shranim v bazo.
Ko pa preberem podatke jih pa zopet napišem v UTF-8.

Problemi rešeni.

aja pa UTF-8 bo ratal standard tako da,...
si.Mail odprto-kodni odjemalec elektronske pošte. - http://www.simail.si
Uredite si svojo zbirko filmov, serij in iger - http://xcollect.sf.net

Zgodovina sprememb…

  • spremenil: krho ()

darh ::

brez zamere... zanimivo kolk problemov imate pri teh šumnikih.. pa konvertanje ipd ipd... svašta.... jest tega neč ne dela.... ma ni dela vse BP...
Excuses are useless! Results are priceless!

Tr0n ::

No, jaz sem problem resil tako, da sedaj enostavno uporabljam Dreamweaver MX kot editor, ker ima ze pripravljene barvne stile za PHP in pa encoding dela tako, kot mora. Samo workstyle preklopis na coder-style in XML php template si popravis na nek default style pa je.

Bye-bye UltraEdit.

Zgodovina sprememb…

  • spremenilo: Tr0n ()

darh ::

ehm... če bi UE uporablju sam zarad syntax highlightinga.. pol bi že zdavnej šou drugam.. tko pa nekak vem 75% shortcutov na pamet.... pa še colum editing ipd ipd ipd ipd.... :)
Excuses are useless! Results are priceless!

Loki ::

tole, ce se bo dal kermu brat (dvomim).

xbite imas ti v UE nastimano, da ti sam shranjuje v iso2 (ti pises normalno ščćž) al mas kake kombinacije tipa Alt Gr + neVEMkajSE?

darh ::

Loki: ne... pisem ą namesto š ipd ipd...
Excuses are useless! Results are priceless!

rc-car ::

xbite: a bi bil tolk dober in napisal te konbinacije? 0:)

Jaz zdej uporabljam tiste kode za spešal znake...
Nothings gonna stop me now, I'm breaking the rules, I'm gonna do it if its not allowed

darh ::

Za tiste ki uporabljate UE...

napisu sem en preprost MACRO ki vam zamenja šžŠŽ v ustrezne znake v ISO-8859-2...

isoConv.zip

lp,x
Excuses are useless! Results are priceless!

tao_s ::

no jaz sem trenutno rešitev našel v DREAMWEAVERJU 4...

MX ima napako! Kodo namreč shranjuje v iso2 (če je tako nastavljen) in jo v lepem HTML-ju tudi interpretira kot iso2. Prblem nastane, če nimaš headerja in vpisanega charseta v dokumentu... potem dreamweaver MX pogori na celi črti...

zanimivo, da 4 dela kot je treba!

vsi ostali eitorji pa še opcije iso 2 nimajo - tolk da so še slabši...

na roke znake vpisovat kot &_3245832... kaj pa vem... verjetno gre res najmanj živcev in časa, pa najbolj ziher je...

samo sem jaz preveč trmast in mi gre za princip, da ne bom vpisoval cifer če hočem navaden š dobit!

Ziga Dolhar ::

Tao_s: ko odpreš v MXu dokument ter ta nima oznake charseta, pejdi v document properties pa dam iz Latin-1 spremeni na 8859-2 ter "Reload".

Deluje.

Tr0n ::

tao_s: ne gre za napako, ravno nasprotno. V MX deluje tako, kot bi moralo ze pri verziji 4. Namrec encoding taksen, kot je nastavljen v dokumentu.

Sicer se pa da nastavit default encoding ali pa tako kot je Ziggga napisal. Malce poglej po default XML dokumentih za posamezen tip dokumenta (Dreamweaver MX/Configuration/DocumentTypes/NewDocuments).

V MX se mi dopade izbira Apply Source Formatting, ki lepo uredi kodo. n33t :). Zelo mocen editor, ko se ga enkrat privadis.

Zgodovina sprememb…

  • spremenilo: Tr0n ()

Ziga Dolhar ::

tr0n: mi poveš prosim kje se nastavi default encoding?

Tr0n ::

Edit / Preferences... / New Document / Default Encoding. Tukaj si lahko nastavis tudi default document type. Ta encoding se nalozi pri novih dokumentih in dokumentih, ki nimajo vkljucenega meta tag-a.

Seveda ce bi rad sumnike prikazal v explorerju, potem moras vkljucit meta encoding tag, kar je cisto logicno.

V Dreamweaver MX/Configuration/DocumentTypes/NewDocuments diru imas pa XML specifikacije za vsak posamezen dokument. V Default.php si tako nastavis, kako bo zgledala stran, ko bos odprl nov PHP dokument itd...

Kewl je tudi podobno delovanje kot v Visual C. Ko napises recimo echo( ti izpise listo vseh parametrov. Zelo prirocni so tudi snippetsi, kjer si shranis pogosto uporabljeno kodo ali tage in jih z enim klikom priklices.

Ziga Dolhar ::

Emmm, ja, ampak new document preferences pač deluje samo za nove dokumente :-). Jes pa v vseh includah ne mislim imet celotnega html dokumenta ;-).

Pravzaprav bi rad vsespolni default encoding, torej da je 88592 VEDNO določen kot encoding, v kolikor ni v dokumentu drugače določeno :].

lp, Ž

Tr0n ::

Hmm, to pa ne vem ce gre naredit, ceprav se nastavi v opcijah, da je default 8895-2.

Pa se en problemcek je. Pri mysqldumpu npr. Noter se vpise preko iso-8859-2, ko se dumpua v .txt datoteko in vstavi na nek drug server preko phpmyadmin ali mysql komande, spet sumniki nekam izginejo, ceprav je encoding nastavljen na iso-8859-2.

Mislim, meni nix jasno.


Vredno ogleda ...

TemaSporočilaOglediZadnje sporočilo
TemaSporočilaOglediZadnje sporočilo
»

Šumniki in MySql

Oddelek: Izdelava spletišč
196168 (5705) SPEEEED
»

encoding

Oddelek: Izdelava spletišč
51190 (1044) jure1825
»

MySQL in czs

Oddelek: Izdelava spletišč
423257 (2347) krho
»

php in šumniki

Oddelek: Izdelava spletišč
263335 (3132) root987
»

page encoding - characters

Oddelek: Izdelava spletišč
121119 (973) JLP

Več podobnih tem