» »

šumniki v konzoli v gentoo linux

šumniki v konzoli v gentoo linux

Juventus ::

za kde šumniki delajo normalno, nastavil sem locate na sl_SI in tipkovnico na slovensko ne vem pa kako naj zrihtam da bo konzola prepoznala šumnike?

kaj naj naredim?

Hvala

Poldi112 ::

Jaz imam sistem nastavljen na utf-8 po navodilih iz njihove strani. Dela tudi v konzoli brez tezav.
Where all think alike, no one thinks very much.
Walter Lippmann, leta 1922, o predpogoju za demokracijo.

kriko1 ::

Poldi112: Lahko daš link, prosim?

Poldi112 ::

Where all think alike, no one thinks very much.
Walter Lippmann, leta 1922, o predpogoju za demokracijo.

nejc_ ::

na TLDP poisci slovenian howto

moj_nick ::

/etc/conf.d/consolefont si kaj pogledal?
110111001001010001010000

Juventus ::

moj_nick sem pogledal in to je to

# /etc/conf.d/consolefont

# CONSOLEFONT specifies the default font that you'd like Linux to use on the
# console. You can find a good selection of fonts in /usr/share/consolefonts;
# you shouldn't specify the trailing ".psf.gz", just the font name below.
# To use the default console font, comment out the CONSOLEFONT setting below.
# This setting is used by the /etc/init.d/consolefont script (NOTE: if you do
# not want to use it, run "rc-update del consolefont" as root).

CONSOLEFONT="lat2-16"

# CONSOLETRANSLATION is the charset map file to use. Leave commented to use
# the default one. Have a look in /usr/share/consoletrans for a selection of
# map files you can use.

#CONSOLETRANSLATION="8859-1_to_uni"

Poldi112 jaz imam nastavljen locale na sl_SI

locale
LANG=sl_SI
LC_CTYPE="sl_SI"
LC_NUMERIC="sl_SI"
LC_TIME="sl_SI"
LC_COLLATE="sl_SI"
LC_MONETARY="sl_SI"
LC_MESSAGES="sl_SI"
LC_PAPER="sl_SI"
LC_NAME="sl_SI"
LC_ADDRESS="sl_SI"
LC_TELEPHONE="sl_SI"
LC_MEASUREMENT="sl_SI"
LC_IDENTIFICATION="sl_SI"
LC_ALL=sl_SI

samo šumniki ne delajo pa bi morali!

Poldi112 ::

Jaz jih imam na en_US.utf8 pa delajo. Ce zamenjam keyboard layout pa delajo se posebni znaki tujih.

jure@Lethe ~ $ mkdir šžčČŠŽ
jure@Lethe ~ $ touch šžčČŠŽ/Šment.txtč
jure@Lethe ~ $ ls šžčČŠŽ/
Šment.txtč
jure@Lethe ~ $

jure@Lethe ~ $ locale
LANG=
LC_CTYPE="en_US.utf8"
LC_NUMERIC="en_US.utf8"
LC_TIME="en_US.utf8"
LC_COLLATE="en_US.utf8"
LC_MONETARY="en_US.utf8"
LC_MESSAGES="en_US.utf8"
LC_PAPER="en_US.utf8"
LC_NAME="en_US.utf8"
LC_ADDRESS="en_US.utf8"
LC_TELEPHONE="en_US.utf8"
LC_MEASUREMENT="en_US.utf8"
LC_IDENTIFICATION="en_US.utf8"
LC_ALL=en_US.utf8
Where all think alike, no one thinks very much.
Walter Lippmann, leta 1922, o predpogoju za demokracijo.

kriko1 ::

Poldi112: a tebi delajo znaki v kozoli, recimo v kdeju ali ’tapravi kozoli‘? Ker meni v tisti ’tapravi‘ konzoli ne delajo (dobim naglašen e...) imam pa LC_* na sl_SI.utf8.

Poldi112 ::

Prav imaš. Samo skozi kde delajo. Funny. Sicer jih ne rabim, sem pa presenečen.
Where all think alike, no one thinks very much.
Walter Lippmann, leta 1922, o predpogoju za demokracijo.

Juventus ::

ja točno tako je zato sem tudi postavil to temo ker šumniki delujejo v konzoli v kde v "pravi konzoli" pa ne tudi če uporabim tvoj locale Poldi112?-
kriko1 ni ti potrebno dodat .utf8 ker je že tak privzeti kodirni nabor za sl_SI v utf8.

moj_nick imaš kako idejo kako se to zrihta da v kontoli deluje ker včasih je blo to enostavno samo dodal si lat2-16 v consolefont in je delalo sedaj pa noče več to delat. kaja ideja?

borchi ::

men delajo šumniki tapravi konzoli v gentoo.

ne vem, če bi tako rad mel šumnike v konzoli, zakaj potem unbedingt hočeš unicode v consoli?
l'jga

kriko1 ::

Mogoče pa niso pravi fonti... Kako se b konzoli fonti menjajo.
SuSE mi pri boot-u napiše loading concole fonts NekoIme... done

MasterMind ::

He he. Sem prišel do nekega odkritja :). Če dam unicode_start in če napišem v diru ~ ls.. Mi napiše imena s šumniki normalno. Če pa želim sam napisat šumnik, mi da pa tisto enko itd. (se vid, da se uporablja latin encoding :P). Mislim, da je ključ v spreminjanju fonta. Sam kateri font je pravi?
Gentoo, KDE uporabnik.

kriko1 ::

Mogoče ve kdo kateri font je tapravi? Pravzaprav katere fonte se lahko v konzoli uporablja, .ttf verjetno ne...

MasterMind ::

Sem ugotovil, da je tisti font pravi, ki ima psfu. In default font ima unicode v sebi. Potem je problem v Keymap?
Gentoo, KDE uporabnik.

MasterMind ::

Našel rešitev! Problem je bil v Keymaps. Vse kar je treba naredit, je to da zvlečeš tale slovene-unicode.map.gz in ga daš v direktorij /usr/share/keymaps/i386/qwertz/ in v datoteki /etc/conf.d/keymaps spremeniš KEYMAP="slovene" v KEYMAP="slovene-unicode". V textmode boš mogel napisat unicode_start preden greš pisat šumnike :P.

slovene-unicode.map.gz
Gentoo, KDE uporabnik.

kriko1 ::

Sem proval, vendar sedaj mi pa izpisuje neke znake z vprašaji.
Ima mogoče še tale spremenljivka kakšen vpliv:

COMPOSETABLE="clear winkeys shiftctrl latin2"
?

NoOrdinary ::

V /etc/conf.d/consolefont imam

CONSOLEFONT="lat2-14"

in v /etc/conf.d/keymaps

KEYMAP="slovene"

Moj locale

LANG=
LC_CTYPE="sl_SI.utf8"
LC_NUMERIC="sl_SI.utf8"
LC_TIME="sl_SI.utf8"
LC_COLLATE="sl_SI.utf8"
LC_MONETARY="sl_SI.utf8"
LC_MESSAGES="sl_SI.utf8"
LC_PAPER="sl_SI.utf8"
LC_NAME="sl_SI.utf8"
LC_ADDRESS="sl_SI.utf8"
LC_TELEPHONE="sl_SI.utf8"
LC_MEASUREMENT="sl_SI.utf8"
LC_IDENTIFICATION="sl_SI.utf8"
LC_ALL=sl_SI.utf8

V make.conf med drugim USE="unicode" in šumniki v konzoli delajo, mi pa niso delal v KDE konzoli dokler nisem nastavil utf8 hehe. Sem pa ugotovil ko sem brskal z linksom iz konzole da mi v linksu ne delajo šumniki kar bi blo po svoje bol uporabno kot v sami konzoli (na enem od forumov mam v username šumnik in se ne morem logirat)
brez ideje sem za podpis

BigWhale ::

LC_ALL nadoknadi vse zgoraj omenjene LC_ spremenljivke. :)

NoOrdinary ::

Sej v bistvu v /etc/env.d/02locale napišeš samo LC_ALL in žokneš env-update :P Če je pa že tok prijazen da vse nastav pa ne boš pastal samo LC_ALL hehe
brez ideje sem za podpis

kriko1 ::

Če še koga zanima rešitev za SuSE:
v datoteki /etc/sysconfig/console spremeni vnos
CONSOLE_FONT="lat1-16.psfu"

v

CONSOLE_FONT="lat2-14.psfu"

to je to.

Brane2 ::

Pri spremembi locala je treba pogledati, če glibci imajo vcompilano.

če imaš pri glibcu aktiven USE flag "userlocales", potem se ti inštalirajo samo tisti localei, ki jih imaš definirane v /etc/locales.build.

Če tam nimaš slovenščine, jo dodaj in nanovo scompiulaj glibc

Vsebina mojega /etc/locales.build:

en_US/ISO-8859-1
sl_SI@euro/ISO-8859-2
sl_SI/ISO-8859-2
en_US.UTF-8/UTF-8
sl_SI.UTF-8/UTF-8
ja_JP.EUC-JP/EUC-JP
ja_JP.UTF-8/UTF-8
ja_JP/EUC-JP
en_HK/ISO-8859-1
en_PH/ISO-8859-1
de_DE/ISO-8859-1
de_DE@euro/ISO-8859-15
es_MX/ISO-8859-1
fa_IR/UTF-8
fr_FR/ISO-8859-1
fr_FR@euro/ISO-8859-15
it_IT/ISO-8859-1


in use flagi glibca pri meni-

emerge -pv glibc:

[ebuild R ] sys-libs/glibc-2.3.5-r2 -build -erandom -glibc-compat20 -glibc-omitfp -hardened -linuxthreads-tls (-multilib) +nls +nptl -nptlonly -pic -profile (-selinux) +userlocales 0 kB
On the journey of life, I chose the psycho path.

Brane2 ::

Poleg tega je treba nastaviti ustrezne LC spremenljivke v /etc/env.d/02locale:

LC_ALL="sl_SI.utf8"
LANG="sl_SI.utf8"

pa v /etc/rc.conf je treba aktivirati unicode:

UNICODE="yes"


po spremembi filetov v /etc/env.d sledi update (ali reboot):

env-update ; source /etc/profile

z ukazom "locale" lahko preverimo nastavitev. Pri meni reče:

LANG=sl_SI.utf8
LC_CTYPE="sl_SI.utf8"
LC_NUMERIC="sl_SI.utf8"
LC_TIME="sl_SI.utf8"
LC_COLLATE="sl_SI.utf8"
LC_MONETARY="sl_SI.utf8"
LC_MESSAGES="sl_SI.utf8"
LC_PAPER="sl_SI.utf8"
LC_NAME="sl_SI.utf8"
LC_ADDRESS="sl_SI.utf8"
LC_TELEPHONE="sl_SI.utf8"
LC_MEASUREMENT="sl_SI.utf8"
LC_IDENTIFICATION="sl_SI.utf8"
LC_ALL=sl_SI.utf8
On the journey of life, I chose the psycho path.

Juventus ::

ko dam unicode_start dobim tole

unicode_start
putfont: PIO_FONT: Invalid argument


samo pol šumniki začnejo delat!
Kako naj naredim da se bo to zagnalo ob zagonu?

Brane2 ::

ne delaj kar tako brezveze na pamet.

Je dober razlog, zakaj ti šumniki ne delajo.

Imaš USE flag "userlocales" aktiven pri glibc (poglej z emerge -pv glibc) ?

ti da "locale" med drugim tudi slovenščino ven ?

Si vnesel /etc/env.d/02locale datoteko ?

Si vnesel uporabo unicodeja v /etc/rc.conf ?

A sploh imaš potrebne fonte ? Kaj ti reče setfont lat2-16 ?

Pa loadkeys slovene ? Po obeh ukazih, a ti delajo šumniki v konzoli ?

Gentoojev LiveCD je trapast. Pol stavari ne dela, sploh če začneš s stage1. Vem, da so meni manjkali locali, timezonei in fonti.

Če rabiš stvar za AMD64, ti lahko pretočim postavljeno zadevo direktno s harddiska.

Sem se odločil,d a si bom naredil svoj LiveDVD, pa sem videl da nima smisla. Itak ne gre vse gor, če bi pa moral razrezati delujoč Gentoo da ga spravim na DVD, ne bo nikoli "svež".

Zato sem si omislil "Live Gentoo USB Hard Disk",kjer imam vedno tekočo verzijo in stvar dela super.
On the journey of life, I chose the psycho path.

Juventus ::

ne delam na pamet stvari tak da ni krize

emerge -pv glibc

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[ebuild R ] sys-libs/glibc-2.3.5-r2 -build -erandom -glibc-compat20 -glibc-omitfp -hardened -linuxthreads-tls (-multilib) +nls -nptl -nptlonly +pic -profile (-selinux) -userlocales* 0 kB

in tole je moj locale

locale
LANG=sl_SI.utf8
LC_CTYPE="sl_SI.utf8"
LC_NUMERIC="sl_SI.utf8"
LC_TIME="sl_SI.utf8"
LC_COLLATE="sl_SI.utf8"
LC_MONETARY="sl_SI.utf8"
LC_MESSAGES="sl_SI.utf8"
LC_PAPER="sl_SI.utf8"
LC_NAME="sl_SI.utf8"
LC_ADDRESS="sl_SI.utf8"
LC_TELEPHONE="sl_SI.utf8"
LC_MEASUREMENT="sl_SI.utf8"
LC_IDENTIFICATION="sl_SI.utf8"
LC_ALL=sl_SI.utf8


v /etc/rc.conf je unicode na YES

pri stfont lat2-16 se pa ustavi

setfont lat2-16
putfont: PIO_FONT: Invalid argument

v gnome v konzoli šumniki špilajo ustavi se v "pravi" konzoli. Kje naj dobim fonte lat2-16?

Hvala

Juventus ::

baje naj bi bil ta error zaradi tega

http://forums.gentoo.org/viewtopic-t-13...

Brane2 ::

emerge -pv glibc ti kaže -userlocales*

Zvezdica pomeni, da je paket bil emergean Z tem flagom, zato ga moraš sedaj emergeat še enkrat, če takrat, ko si jo emergeal prvič, nisi imel slovenskih definicij v /etc/locales.build

Če nimaš lat2-16, probaj kak drug lat2 , recimo lat2-14

če tudi tega nimaš, ti manjkajo fonti z LiveCDja. Lahko ti jih uploadam kam, a sedaj mam gužvo, mogoče pozneje.
On the journey of life, I chose the psycho path.

Juventus ::

Hvala Brane2 zrihtano sedaj deluje:D


Vredno ogleda ...

TemaSporočilaOglediZadnje sporočilo
TemaSporočilaOglediZadnje sporočilo
»

GIMP 2.4. - Kako spremeniti jezik?

Oddelek: Programska oprema
91781 (1657) d_streets
»

[Perl] izpis šumnikov

Oddelek: Programiranje
121910 (1750) Pimoz
»

Šumniki v Linuxu na STju- Gentoo way...

Oddelek: Operacijski sistemi
242323 (1747) ank
»

Linux in prepoznavanje trdega diska

Oddelek: Pomoč in nasveti
9830 (782) Brane2
»

[linux,OSX] Emacs, bash & slovenscina

Oddelek: Operacijski sistemi
181629 (1485) Gandalfar

Več podobnih tem