» »

[linux,OSX] Emacs, bash & slovenscina

[linux,OSX] Emacs, bash & slovenscina

Jebiveter ::

Prosim, dejte pomagat! Ker sem se ze totalno zgubu v how-to-jih in guide-ih! :'( Nic mi ni vec jasno!

V glavnem, rad bi usposobu sumnike v bash-u in emacs-u, tako v linuxu (Slack) in OSX-u.
Do sedaj me ni motilo, da v bash-u in emacs-u ne delujejo sumniki, a se je pac pojavla potreba po tem in bi rad to zrihtal.

Ker ste imeli linux guruji z tem ze opravka verjetno poznate resitev. Anyone?
Certainty of death. Small chance of success. What are we waiting for?

Gandalfar ::

pac nastavi si slovensko unicode tipkovnico ane

za linux pa si preberi kaksen howto :)

Jebiveter ::

pac nastavi si slovensko unicode tipkovnico ane


A to mislis v GUI? V System Preferences? Ker to imam nastelano in v terminalu ne deluje... ČŽŠ sploh ne izpise/prepozna. Tudi v emacsu zato ne deluje...In to bi res nujno rabu...

Se kaksen tip?
Certainty of death. Small chance of success. What are we waiting for?

Gandalfar ::

kaj pa ce nardis

export LC_ALL=sl_SI.UTF-8

Jebiveter ::

Nope.. (sm ze probal). Rezultat tega je, da ŠŽ prikaze kot "?"

A na tvojem booku mogoce tole deluje?
Certainty of death. Small chance of success. What are we waiting for?

roscha ::

Na Debilkotu je tkole:

V svojo ./profile datoteko dodaš:
consolechars -f lat2-16 -u lat1

obenem v /etc/inputrc odkomentiraš:
set convert-meta off

Če pa želiš naše znake že ob bootu pa v:
/etc/console-tools/config
dodaš:
SCREEN_FONT=iso02.f16
APP_CHARSET_MAP=iso02


na slacku tudi dela?

Brane2 ::

Za naše znake rabiš dve stvari:

1. Slovenske simbole tipkovnice. Stvar mora torej vedeti, d aimeaš neko tipko, kjer je črka "č" "š" itd.

To preslikavo naložiš z loadkeys "slovene"

Nato pa rabiš še slovenski font s šumniki.

tega naložiš z setfont lat2-16

Tisti LC_ALL tid so samo spremenljivke, ki same zase ne spremenijo ničesar...

Jebiveter ::

N slacku se nisem probal, ker mi je trenutno prioriteta tole postelat na OSX, ki pa zal ni cist tko k linux... in take standard debian/slack fore ne delujejo ravno.

Na Slacku sem to imel pri prvem instalu postelano, sam se morem spomnit, kako mi je ratalo (pozabu zapisat ;(( )
Certainty of death. Small chance of success. What are we waiting for?

HerrBaron ::

Veliko se nisem ubadal s slovensko tipkovnico, a sem opazil sledeče:
v xterm-u mi ne delajo đšćžč.
ko preklopim na konzolo (ctrl+alt+Fn, n=1-6), mi tudi ne delajo, dokler ne napišem ponovno setfont lat2-16

Uporabljam pa gentoo + xfce4 + x.org

Brane2 ::

Najprej nastavi konfiguracijski file Xov na slovensko tipkovnico in potem poglej, kaj se bo zgodilo. Xterm pobere nastavitve Xov.

V "DOSu" imaš za te stvari drugi driver, s katerim Xi nimajo veliko skupnega, ne vem pa zakaj ne vrnejo nastavitev fonta na staro vrednost...

Zgodovina sprememb…

  • spremenil: Brane2 ()

HerrBaron ::

v /etc/X11/XF86Config imam nastavljeno:

Option "XkbRules" "xfree86"
Option "XkbModel" "pc102"
Option "XkbLayout" "si"

Vem pa, da nastavitve za shell nimajo veze z X-i (ali pač?)

Brane2 ::

Sem pogledal pri sebi in imam isto nastavitev ( no ja razen tipkovnice, ki ja pc105). Imam pa v Xtermu nastavljen "locale default (UTF-8) encoding".

Postavi še to....

CCfly ::

Za Slackware:
v datoteki /etc/rc.d/rc.keymap popravi na
/usr/bin/loadkeys slovene.map

in pa v /etc/rc.d/rc.font na:
setfont -v lat2-16.psfu.gz

Jebiveter ::

CCfly: Tnx! Bom sprobal... ;)
Certainty of death. Small chance of success. What are we waiting for?

Brane2 ::

Tisto, kar sem prej rekel za encoding v prejšnjem postu, pozabi. Gledal sem v nastvitev za drug termninal.


Vendar meni XTerm dela.

Je pa nekaj. Preden se štartajo Xi, se pri meni tekkom inicializacije izvede loadkeys "slovene" in po tistem setfontu lat2-16 imam šumnike še pred vstopom v Xe.

Če potem odprem Xterm in poskusim naložiti US keye in fonte, se stvar sicer ne buni, vendar dela še naprej s šumniki...

Se pa te spremembe poznajo potem izven Xov.

Iz tega sklepam, da X aplikacije laufajo preko Xkbja itd, ki pa jemlje informacije preko ločenega sistema, ki ni povezan s tekstovnim načinom.

Poglej si tudi malo v /var/log/Xfree86.log kako so se zbbotali X-i, katero tipkkovnico so aktivirali itd...

CCfly ::

Vse X aplikacije delajo prek Xkb-ja, samo zakaj tlačite nastavitve v XF86Config. Uporabite ustrezen program za menjavo postavitve tipkovnice.

jype ::

Meni v Terminalu na OS X 10.3 dela vse tako kot mora (nimam emacs, uporabljam vim).

Najprej gres v Terminalu v meni Terminal in izberes tam Window Settings, potem iz dropdowna izberes Display in tam nastavis Central European encoding. Ce bi rad unicode, potem mora to podpirat tudi editor (ocitno).

Ce hoces da bash ne interpretira visokih znakov (nad 127) potem moras v svoj home dat .inputrc datoteko s tole vsebino (velja na vseh OS enako):

set meta-flag on
set convert-meta off
set output-meta on

Tele vrstice v .inputrc so pa uporabne da ti normalno delajo tipke end, home in delete.

"\e[1~": beginning-of-line
"\e[3~": delete-char
"\e[4~": end-of-line

Jebiveter ::

jype: Se pravi, ti nisi nic drugega nastvljal kot encoding v Window Settings? Ker sem probal ze prej pa ni delovalo... Mogoce je to odvisno od tipkovnice, ki jo uporabljas? Ker na iBooku ni ravno standardna tipkovnica (tko kot na vseh prenosnikih). Bom se enkrat probal...
Certainty of death. Small chance of success. What are we waiting for?

Gandalfar ::

Jebiveter: saj ti je napisal da ima podobno stvar kot ti..


Vredno ogleda ...

TemaSporočilaOglediZadnje sporočilo
TemaSporočilaOglediZadnje sporočilo
»

[Linux] Sprememba tipkovnice v konzoli

Oddelek: Operacijski sistemi
61421 (1361) epona
»

šumniki v konzoli v gentoo linux

Oddelek: Operacijski sistemi
292951 (2592) Juventus
»

Šumniki v Linuxu na STju- Gentoo way...

Oddelek: Operacijski sistemi
242323 (1747) ank
»

v textovnem načinu ni šumnikov

Oddelek: Operacijski sistemi
5849 (762) Senzacionale
»

grub (resolucija)

Oddelek: Operacijski sistemi
6787 (705) zaejec

Več podobnih tem