» »

Direct3D ne deluje

Direct3D ne deluje

LorD_DDooM ::

Bogdaj!

Glede mojega problema se obračam na vas, ker sam nimam ne volje ne znanja, da bi dotični problem rešil.
Zadeva je takšna, moj računalnik je postal invaliden, saj ni več zmožen poganjati kakršnihkoli D3D aplikacij, odnosno iger, programčkov... čudno se mi zdi, ker mi je kišta pet let delovala dokaj solidno, sedaj pa je postala invalidna. Bes jo popolentaj!
No, naj razložim. Nekoč, na devetem disku in za devetimi mapami, kraljuje imenik \igre, ki je dokaj redno obiskovan glede moje malenkosti. Kakih šest mesec nazaj sem si zaželel pognati nekaj iger (UT2003, C&C:Generals...v glavnem D3D), a glej ga zlomka, računalo je vedno zmrznilo. Nič hudega sem si rekel, sigurno so špili slabo napisani, ampak ob n-tem številu "defektnih" špilov mi je postalo jako sumljivo. Ne morem pognati nobenega D3D špila in to mislim nobenega. Še bolj zanimivo je, da OpenGL igre (Quake III, Star trek:EFII, ET, RTCW...) delujejo brezhibno, takisto vse 2D igre (Baldurs Gate 2, Worms ...), ampak nobena D3D igra.
In da preidem na težavnejši del. Računalo sem formatiral od takrat najmanj desetkrat in to mislim popolni format ne samo \Windows particije. V nobenem primeru se stanje ni izboljšalo. Namestil sem vse možne Catalyst gonilnike za mojega Radeona 7500 serije 2.x in 3.x; za 2.4 se spomnim, da so delovali np, a sedaj tudi te ne delujejo. Trenutno imam verzijo 3.4 (6.14.10.6343) in ponovne inštalacije gonilnikov ne pomagajo (Driver Cleaner..). Za matično ploščo novejši BIOS ne obstaja, vsaj ne za mojo verzijo (M726MRT), kaj posebnega z nastavitvami pa že dolgo nisem eksperimentiral. OS je WinXP, desetkrat na novo naložen, SP1 ali brez, je vseeno, ne deluje v nobenem primeru, WinUpdate redno obiskan. Ne uporabljam nobenega dodatnega programa (Powerstrip...), tako da tudi v tem ni problem.
Za foro sem zopet v računalo vgradil ATI Rage 128 in zadeva je celo delovala. Ne vem zakaj potem R7500 ne deluje?
Če poženem DxDiag je vse vredu dokler ne poženem D3D testa, kjer se mi računalnik obesi. Konec, brez pojasnil, samo obesi se. Ko poženem kak špil mi javi napako, da so se Okna obnovila od napake in me vrže v namizje (4-bitna paleta???), če pritisnem Alt-Tab slišim glasbo iz igre in lahko brskam po meniju a monitor je črn.

Kakorkoli obrnem, D3D mi ne deluje. Ima kdo še kak nasvet kaj naj naredim predem dokončno obupam?

boštjan ::

a ti sploh kaj napiše,ko hočeš D3D igro pognat?

LorD_DDooM ::

Popolnoma nič.
Recimo danes sem pognal Halo demo. Inštalacija vredu, dam Play, začne nalagati nakar pride do začetnega menija (napis Halo in oni planet-obroč v ozadju), nato pa tuf, črni ekran, namizje (4-bitna paleta :) ) in okence: Okna so obnovila od napake, prosimo shranite svoje delo... ; pritisnem OK, če dam Alt-Tab mi preklopi v igro, a ekran je mrtev.

Isto pri UT2003, Deus EX, Diablo II... takoj ko program preklopi v D3D način. OpenGL in 2D pa delujejo brezhibno.

boštjan ::

pol pa se lepo razpiši o tvojem hardveru,da vidimo v čem naj bi bil problem

LorD_DDooM ::

OK, hvala za hitre odgovore.
Grafična kartica Radeon 7500 64MB DDR. Nenavita, v upanju na boljše rezultate sem jo odvil na pod-default nastavitve-brez uspeha. Ventilator deluje vredu, hlajenje ni problem.
CPU je PIII 450MHz Slot1, (100x4.5), vendar zadeva ne deluje niti s Celeronom 500MHz (66x8) Socet 370. Plošča podpira obe podnožji, vendar ne dva procesorja naenkrat.
Osnovna plošča je M726MRT, strah in trepet vsakega igričarja. BIOS sem probal flashati, a brez uspeha.
RAM: 1x265MB SDR 133MHz, 1X128MB SDR 133MHZ, 1x128MBSDR 100MHz. Ramniki so vredu, v sosedovem račnualniki delujejo normalno, uspešno prestali Memtester.
Disk: Fujitsu MPE3102AT 10GB. PIO mode 4, ker DMA ne deluje.
Zvočna: PCI Hercules Sound MUSE XL (najnovejši gonilniki)
DirecctX 9.0b (originalni 8.1 in 9.0 ne pomagajo).

boštjan ::

če se prav spomnim,ko sem še sam mel 750MHz CPU AMD duron in radeon 7000,nisem moral noramlno igrat D3D igerc.Seris Sam sem moral na openGL preklopit če sem hotel na 1024X768 špilat.vse druge openGL igre so laufale zelo dobro.

Senitel ::

Hmm... Poglej na Control Panel -> System -> Device Manager -> View -> Resources by connection in poglej kaj vse je na istem IRQ-ju kot grafična?

LorD_DDooM ::

Asign IRQ for VGA imam v BIOSu izklopljen.

V Device managerju pa izgleda takole:

Zgodovina sprememb…

  • zavaroval slike: Predator ()

Senitel ::

Daj vklopi "Assign IRQ for VGA"...

LorD_DDooM ::

Brez efekta, še vedno javi napako ko zaženem aplikacijo.
IRQ za RADEON 7500 je 10, IRQ za Realteka pa se prestavi na 11.

Senitel ::

Kakšno napako ti javi?

LorD_DDooM ::

Karkoli poženem, vedno mi javi isto napako.

Zgodovina sprememb…

  • zavaroval slike: Predator ()

LorD_DDooM ::

Kdorkoli, karkoli? :'(

undefined ::

Najnovejše Catalyst 3.8 maš nameščene?

Senitel ::

Se ti morda tepe z kakšnim ostalim software-om (če se prav spomnim so bili neki problemi naprimer z NetMetingom)? Poskusi pognati kaj z čim manj programja v ozadju.

mchaber ::

Sem meu podobne težave glede zmrzovanja, pa sm zamenju napajalc pa je blo ok.


glede tistih napak...






















pojma nimam:8)
.

LorD_DDooM ::

Hm, probal sem tudi tako, da sem na novo naložil WinXP (brez kakršnihkoli popravkov), naložil Catalyst 3.4, gonilnike za zvočno, matično, miško, monitor, mrežno, z DX 9.0, a javi mi isto napako. Probal sem tudi na novo naložene WinXP z vsemi popravki--> brez uspeha, na novo naložene winse z drugimi Catalysty--> brez uspeha. Na novo naložene winse s starimi Catalysti 2.x in DX 8.1-->breu uspeha. Če dam notri Rage 128 igre delajo (ja, no..."delajo" ;) ), ampak z Radeonom 7500 pa nikakor ne deluje. Še bolj zanimivo pa je, da so mi včasih D3D aplikacije delovale! Zdaj pa, z istimi nastavitvami, istimi gonilniki, istimi igrami...ne delujejo.

Nekdo mi je svetoval nadgraditi BIOS radeončka... je to pametno?
Mogoče kak AGP gonilnik ni pravi? Vse kar sem našel na netu je tale stran. Plošča je M726MRT.

Izklopljene pa imam vse programe v ozadju (nobenega MSNja ... na prejšni sliki sem ga sicer imel, samo ne upliva na rezultat; Refresh toola, Powerstripa...). Pojma nimam kaj bi lahko bilo narobe.

Zgodovina sprememb…

LorD_DDooM ::

Malo sem šaril po logih in odkril sledeče sporočilo:

The driver ati2dvag for the display device \Device\Video0 got stuck in an infinite loop. This usually indicates a problem with the device itself or with the device driver programming the hardware incorrectly. Please check with your hardware device vendor for any driver updates.

Če to komu kaj pove... Jaz sem takoj pomislil na napajalnik, imam 200W, tako da ne vem če je kaj s tem. Tudi zato, ker OpenGL in 2D grafika delujeta normalno. Na WIn98 tudi deluje brez problema.

Nekdo mi je svetoval nadgraditi BIOS radeončka... je to pametno?
Mogoče kak AGP gonilnik ni pravi? Vse kar sem našel na netu je tale stran. Plošča je M726MRT.

Senitel ::

Flashanje BIOSa grafične po moje ne bo pomagalo. Če je "driver stuck in infinite loop", potem je problem običajno v driverju. To ALI Aladin II PRO chipset right? Daj poizkusi si za vsak slučaj sposodit pri kakšnem kolegu močnejši napajalnik. Če imaš možnost sprobaj še kekšnega drugega Radeona (ni pa nujno, da ravno Radeon-a). Če to ne uspe poizkusi sledeče: Iz računalnika vzemi vse ostale kartice, izklopi modem v BIOSU. Formatiraj disk in inštaliraj SAMO Windowse XP, Catalyst 3.8 driverje in DirectX 9.0b driverje, ter poženi Direct3D test v dxdiag.
Če to ne pomaga povej, da grem ATI-jevcem težit.
Če prav razumem zadnji post ti tudi v Win98 dela Direct3D povsem normalno?

LorD_DDooM ::

Da, to je dotično čipovje.
Sosed mi je pred kratkim posodil svoj 300W ATX napajalnik, a brez uspeha. V BIOSu sem eksperimentiral z APM in APCI (ali karkoli je že) nastavitvami, kakor je pisalo v FAQ in in raznih google straneh. Nič, razen dodatnih težav.
Z Rageom 128 EXPERT 2000 AGP zadeva deluje normalno (počasi a zanesljivo), takisto z Voodoo 3 2000 PCI.
Nazadnje sem formatiral disk in na novo naložil sistem, v kišti sem pustil le grafično, USB/PS/2/COM kontrolerje, onboard modem in zvočno izklopil (itaq ima plata čudno nastavitve, da če izklopiš zvočno, avtomatsko izklopiš tudi modem), in pustil 256MB 133MHz RAMa. WinXP SP1 DX9.0 in Catalyst 3.4 (takrat najnovejši). Popolnoma brez uspeha.

Ugotovil sem, da vsakič, ko mi javi napako, ima nek ati2dvag.dll prste zraven. To je del Catalyst gonilnikov, več o njemu pa ne vem. Opazil sem še, da ima veliko uporabnikov, sploh uporabniki R9500 in R9600 podobne ali popolnoma enake težave, vendar na nobenih forumih in FAQjih še nisem našel prave rešitve (bojda naj bi bili konflikti med Intel E7205 čipovji in Catalysty). Pravi misterij.

Kar imam namen narediti:
BIOS na matični ne morem nadgraditi (imam verzijo iz leta 1999), ker ima novi BIOS 2MB datoteko, moj BIOS pa sprejme le 1MB veliko datoteko. Naj me kdo prosim popravi, če se motim. Torej nadgradnja ne pride v poštev.
Z nastavitvami v BIOSu sem že preveč eksperimentiral, verjetno nastavitve niso krive.
IRQ nastavitve so vredu.

Še enkrat bom skušal dobiti močnejši napajalnik.
Nekje sem prebral, da SMARTGART povzroča podobne efekte, bom se še malo poigračkal z Fast writeom in AGP settingom.
Naložil Catalyst 3.8
Formatiranje v kratkem ne bo izvedljivo, tudi verjetno ne bi pomagalo.

In da, na Oknih 98 SE je vse delovalo normalno.

LorD_DDooM ::

Torej:

Močnejši napajalnik ni pomagal (350W).
Catalys 3.8 (prejšnji gonilniki lepo odstranjeni + pomoč Driver Cleaner-ja 2.6). Ne pomaga.

Mnogo nasvetov na raznih forumih sem dobil glede SMARTGARTa in Fast Write-a. Izklop/odstranitev/zmanjšanje nastavitev ne pripomoreta k izboljšavam. Takisto ne izključitev Omogoči hkratno zapisovanje.
Sedaj imam AGP hitrost nastavljeno na 1x (default), če prestavim na 2x se mi Okna zrušijo ob zagonu in vsi gonilniki gredo papa (Okna sama naložijo VGA adapter na non-pnp monitor... ???). Čudno.
Nobena nastavitev glede APM in ACPI v BIOSu ni delovala...

OK, kakor sem opazil problem "infinite loop-a" je dokaj razširjen, sploh med uporabniki R7500, R9500, R9600 in tudi med uporabniki nVidie. Veliko uporabnikom se dogajajo iste ali zelo podobne napake, a nobeden ne ve natančnega odgovora na problem. Tudi jaz ne. In verjetno bo tako tudi ostalo...
Hvala za vso pomoč in odgovore!

Lp

boštjan ::

Kaj pa VPU recover maš izklopljen? Ko gledam ono slikico,ko ti javi napako sem se spomnil,da je tudi meni podbno opozorilo vrglo ven in kriv je bil powerstrip.Maš mogoče kaki overclocker utility naložen.

LorD_DDooM ::

Ne, nobenega.... samo gonilnik za Radeona in Kontrolno ploščo.

Zgodovina sprememb…

Senitel ::

Daj gor Cat 3.9, DirectX 9.0b poženi dxdiag (obkljukaj check for WHQL signatures) klikni na Save All Information in mi pošlji generiran file na mdolenNO@SPAMsiol.net, bom jaz mal povprašal na "the dark side".


Vredno ogleda ...

TemaSporočilaOglediZadnje sporočilo
TemaSporočilaOglediZadnje sporočilo
»

AMD (ATI) Catalyst™ (strani: 1 2 3 415 16 17 18 )

Oddelek: Zvok in slika
850130921 (41400) ferdo
»

Problem z igranjem iger- Directx

Oddelek: Pomoč in nasveti
211586 (1266) Venta20
»

Vivo na Radeon 9000

Oddelek: Zvok in slika
231520 (1306) polde66
»

Problem z grafiko v igrah!

Oddelek: Pomoč in nasveti
241444 (1010) ska-core
»

Abit KT7-Raid in AGP???

Oddelek: Pomoč in nasveti
91534 (1364) ijatebi

Več podobnih tem