» »

Kako poganjati različne verzije OS X sistema?

Kako poganjati različne verzije OS X sistema?

razr ::

V namene testiranja različnih poštnih aplikacij (Apple Mail) bi rad poganjal čimveč verzij Apple OS X sistema.

Recimo naslednje:
- Version 10.5: "Leopard"
- Version 10.6: "Snow Leopard"
- Version 10.7: "Lion"
- Version 10.8: "Mountain Lion"
- Version 10.9: "Mavericks"
- Version 10.10: "Yosemite"

Kako lahko to najceneje in legalno realiziram?
Obstaja rešitev, ki ne vključuje nakupa 6 različnih Apple računalnikov?

klinker ::

Lahko poskusis s hackintosh varjanto in vec diski, al pa virtualke.
Sam ti lahko castim legalne iso-te za ML, Mavericks in Yosemite, za ostalo se bos pa mogu znajdet.
Drugace zelo uporabne strani za te zadeve so http://www.tonymacx86.com in http://www.osx86project.org

razr ::

Z veseljem bi rešil z virtualkami, če bi vedel, da bo to delovalo z VMWare / Virtualbox. Deluje to brez težav, ne glede na mojo strojno opremo?

amacar ::

Najboljše da probaš. Meni Yosemite kr leti v virtualki, še animacije so povečini ok, sem pozitivno presenečen.

klinker ::

Zal ti tu ne znam pomagat dosti. Kar vem, je to da se na travnikih najdejo verzije postimane prav za virtualke, ne vem pa ce je z virtualkami kaka HW omejitev, kot je to s hackintoshem. Nisem virtualk nikoli prakticiral.
Moja platforma (i3/i5 in i7 prve generacije) je dala skozi vse od Liona dalje, pred tem sem pa imel Leopard in SnowLeopard na Core2Quad 6600, manjsi problem zna bit tudi grafa, ceprav bi naceloma na Nvidiji 8xxx ali 2xx, mogle delat vse te OSX verzije.
Samo za potestirat kak app pa res ne rabis vseh teh OS-ov legalnih, sploh ker jih ne bos dobil, razen ce ima doma kdo se DVDje s starim OSX in se preko kake bolhe dokopljes do njih.

razr ::

@amacar:
kateri je pa host OS, ki poganja tvoj virtualization software?
Uporabljas Vmware, Virtualbox ali kaj tretjega za virtualizacijo?

@klinker:
Hvala za vse informacije.
Je bila tvoja platforma (i3, i5 in i7) PC ali Mac?

no comment ::

Najlažje: šest particij, na vsako svojo verzijo OSX-a in bootaš v željeno verzijo - rabiš dovolj star računalnik, da je še podprta najnižja verzija OSX-a, ki ga želiš poganjat
Najbolj udobno: VMWare/Parallels - boš pa nekaj časa porabil za konfiguracijo VM mašin, da boš lahko namestil non-server pre-10.7 verzije OSX-a v virtualke (če me spomin ne vara je 10.7 prva verzija, ki dovoljuje install v virtualke brez uporabe raznih trikov)

amacar ::

Poganjam na windows 7 Pro z Vmware player (mislim da sem delal po enem izmed tutorialov od tega userja: https://www.youtube.com/channel/UC6v6lj... ), proc je intel E3-1230v3, grafa AMD. Poskusil sem Mavericka in Yosemite, pa sta oba gladko delala. Sedaj delam tutoriale v xCode in tudi iOS simulator dela brez problema. Se spomnim, da sem par let nazaj eno verzijo osx naložil v vmware, pa je delalo porazno.

mojca ::

Prva možnost: VMware Fusion (ali ekvivalent). Vzameš en spdoben kos Applovega hardvera in preko virtualk poganjaš vse stare sisteme. Legalno in brez tehničnih zapletov lahko zagotovo poganjaš 10.6 Server Edition. Če lahko strežniško različico za 10.6 kje legalno dobiš po "človeški ceni", ti sicer ne vem povedati. Ko sem jaz iskala 10.5 za PPC, sem obupala (naposled sem sicer našla originalen DVD).

Druga možnost, ki mi je pri Applu zelo všeč: vzameš šest USB ključkov (ali en večji disk), namestiš sistem na USB ključek/disk in pri bootanju izbereš particijo, iz katere bi rad naložil sistem. Dokler paziš, da se USB ne odklopi sredi dela, bo sistem delal "nativno", brez virtualk. Glavna poanta: ni potrebe, da bi vseh 6+ sistemov imel na internem disku.

Meni oboje dela brez težav tudi na prenosniku iz leta 2009 (virtualka zaradi majhnega števila jeder sicer ne leti). ("no comment" ima glede druge možnosti sicer prav. Preveč nov računalnik morda ne bo v celoti podprt.)

razr ::

Torej, če prav razumem: če se odpovem 10.5 "Leopard" in 10.6 "Snow Leopard" lahko zadevo rešim z VMWare in sodobno PC strojno opremo?

Imate kaj občutka, koliko ljudi sicer sploh še uporablja 10.5 in 10.6?

klinker ::

Imam PC, i5 750, Gigabyte P55A UD3 in GTX560Ti+GT240.
10.5 in 10.6 uporabljajo tej, ki imajo starejsi HW, kateri ne podpira novejsih OSX verzij, to pa lahko preveris kje na netu.

mojca ::

Jaz z VMware-om brez težav poganjam tudi 10.6 (Server Edition; "navadnega" nisem testirala).

10.5 je za vse uporabnike PPC-jev, ki ne morejo posodobiti na novejšo različico OS-a. Sumim, da jih je sicer precej malo.

10.6 je pa zame skoraj "ekvivalent XP-ja", skratka en fantastičen OS. Zaradi častitljive starosti sicer ni nevemkako razširjen, ni pa povsem zanemarljiv. Tule omenjajo 10% (meni se zdi ta številka previsoka):
http://www.intego.com/mac-security-blog...

(Jaz sem na 10.7.)

no comment ::

razr je izjavil:

Torej, če prav razumem: če se odpovem 10.5 "Leopard" in 10.6 "Snow Leopard" lahko zadevo rešim z VMWare in sodobno PC strojno opremo?

Tehnično, ja. Legalno, ne vem. Mislim, da mora biti host Apple mašina.

razr je izjavil:


Imate kaj občutka, koliko ljudi sicer sploh še uporablja 10.5 in 10.6?

Malo. Ljudje, ki zaradi tega ali onega razloga morajo poganjati PPC kodo.

Zgodovina sprememb…

Map ::

Bom kar tule uprašal. V virtualki mam nameščeno Mavericks verzijo, ampak ne dela ne vem kako hitro in animacije niso tekoče. Za probo bi nabavu Kingston S200 30GB ali S300 60GB, pa me žanima, a sta to vredu diska in kok težja je namestitev Hackintoska na disk kot v virtualko, a je kej več problemov?


Vredno ogleda ...

TemaSporočilaOglediZadnje sporočilo
TemaSporočilaOglediZadnje sporočilo
»

Kateri OS uporabljate (strani: 1 2 3 )

Oddelek: Operacijski sistemi
13821231 (14231) Apache90
»

Beli macbook 2007 10.4 pomoč

Oddelek: Pomoč in nasveti
101440 (1243) Gandalfar
»

MabBookAir OS

Oddelek: Operacijski sistemi
121266 (996) medosg
»

Mac OS X desetletnica

Oddelek: Novice / Operacijski sistemi
186212 (5420) Ginginova
»

Mac OS X 10.6 v petek (strani: 1 2 3 4 5 )

Oddelek: Novice / Operacijski sistemi
21018059 (12561) ShARk63

Več podobnih tem