Prijavi se z GoogleID

» »

[UBUNTU SERVER 10.04] Grub se ne postavi

[UBUNTU SERVER 10.04] Grub se ne postavi

matijaz74 ::

Pozdravljeni! Problem imam z postavitvijo GRUB-a. Ko poženem server se ustavi pri
grub >
. Enostavno se kernel ne naloži.
Je pa res da sem, pred izklopom pritisnil ukaz uredi GRUB ali nekaj v tem smislu. Tako, da je prejšnje verzije linux iz menija zbrisalo. Kako naj rešim to težavo. Hvala vam za pomoč!
lp
Matijaž

tintorel ::

Ni po slovensko, ampak v pomoč bo:
http://www.linuxzasve.com/grub-ne-prepo...

Icematxyz ::

Če te prav razumem, do Grub 2 izbirnika, kjer lahko izbereš želeno jedro še prideš in zagon kateregakoli se konča na omenjen način?

Kaj točni si počel, na novo si nameščal Grub 2 ali pognal ukaz sudo update-grub, ročno si brisal jedra, kjer si tudi kakšno od le-teh zagotovo pustil, ročno si urejal kakšne datoteke za Grub 2?

matijaz74 ::

Icematxyz je izjavil:

Če te prav razumem, do Grub 2 izbirnika, kjer lahko izbereš želeno jedro še prideš in zagon kateregakoli se konča na omenjen način?

Kaj točni si počel, na novo si nameščal Grub 2 ali pognal ukaz sudo update-grub, ročno si brisal jedra, kjer si tudi kakšno od le-teh zagotovo pustil, ročno si urejal kakšne datoteke za Grub 2?


Ammm ... grub menu se ni pojavil ampak se je ustavilo pri ukazu kot sem prej zapisal
grub >
. Na začetku piše Minimum-Bash. Točno prikažejo slike. Če pritisnem tipko TAB mi pa izpiše cel kup ukazov. Slike bi lahko priložil zraven, vendar ne deluje. Prikaz slik iz drugega servisa.
lp
Matijaž

Zgodovina sprememb…

matijaz74 ::

Naj bolj točno opišem kje se mi ustavi. Napisal bom samo delno.
Minimal BASH-like line editing is supported. For the first ...

Potem ko pritisnem tipko TAB pa
Possible commands are: . 915resolution [ acpi ...
Torej ... GRUB menija ni. GRUB meni se je zrušil sedaj pa moram nazaj izpostaviti ali kaj moram narediti, da lahko poženem sistem. Malo bom še pogledal po netu, če je kakšna rešitem. Enostavno razložena. Na serverju je pa samo en sistem tako, zakaj se je GRUB pojavljal, Verjetno zaradi tega ker se je sistem tudi upgrade-u in tako je polnil GRUB meni. Hvala vam za pomoč, če boste prej najdli rešitev kot jaz.
lp
Matijaž

Zgodovina sprememb…

Icematxyz ::

Če nimaš izdelanega kakšnega RAID polja ali ločenega /boot razdelka s pomočjo namestitvenega LiveUSB/LiveCD izvedi sledeč postopek:

Obnovi Grub



Navodila

Obstajajo tudi GUI orodja, ampak načeloma se mi postopek višje zdi dovolj enostaven in kratek in najprej preizkusi to in poročaj o rezultatu. Če česar v navodilih ne razumeš pa vprašaj!

Zgodovina sprememb…

matijaz74 ::

Hvala bogu da nimam še te razdelke RAID. Nameščal sem Ubuntu Server privzeto tako da je razdelke Ubuntu sam uredil. Hvala bom probal na tak način, drugače sem pa najdel še en način. Seveda bom sporočal o rešitvi.
lp
Matijaž

matijaz74 ::

Pozdravljni! Sedaj sem se spravil reševanje serverja. Potegnil sem si iz neta Ubuntu Rescue Remix Live CD. Pognal sem ukaz
fdisk -l
in mi prikatal sledeč. Po vsakem razdelku je napisano
Partition 1 does not end on cylinder boundary.
... no bom probal kaj se naprej zgodi.
lp
Matijaž

Icematxyz ::

Grub se v normalnih razmerah ne bi "okvaril" sam od sebe in višje nisi povedal, kaj točno si počel, da je prišlo do te težave in za to ti torej ne morem pomagati bolj konkretno, kot to da ti predlagam da po postopku, ki sem ga že podal poskusiš znova namestiti/obnoviti Grub 2 in vidiš če se Ubuntu zažene. Sumim, da si se igral z spreminjanjem strukture razdelkov tik pred to težavo?

Kakorkoli sledi najprej navodilom, ki sem ti jih podal in poročaj kakšen bo torej rezultat!

matijaz74 ::

Iščem meni kateri se prikaže preden se server fizično ugasne. Najprej sem napisal
sudo shutdown now
Po postopku prekinitve sistema se je pojavil meni. Na njem je bilo, kot se spomim ... pisalo. Uredi GRUB ... al nekaj takega ... prijava na varni desktop safe...., zogon sistema iz prvega diska al nekaj takega. No ker sem opazil, da je Uredi GRUB (da počisti meni) sem to pritisnil in je opravil, kar je opravil. Zakaj sem pa server hotel ugasniti? Zato ker mi napajalnik, je nagajal (vsakih ko je server želel narediti kaj težjega se je resetiral). Tako da imam dve težave (napajalnik, zagon sistema). Ja vem da GRUB2 se ne bi samoodsebe pokvaril to vem. Bom jutri sporočal kako je šlo.
lp
Matijaž

BlaY0 ::

Grub ti ne najde konfiga (menu.lst). Probaj ga poiskat kar krek te ukazne vrstice. Malo se sprehodi po particijah. Gre nekako takole... odtipkaj "root (hd0," in stisni tab. Zlistale se ti bodo particije. Nadaljuj recimo "root (hd0,1)" za drugo particijo. Potem odtipkaj "configfile /" in tab pa se ti bodo zlistali direktoriji na tej particiji. Iščeč /grub ali /boot/grub direktorij. Če ni nobenega od dveh na tej particiji zamenjaš particijo z "root (hd0,0)" in spet probaš poiskati menu.lst. Če ga nikjer ne najdeš poskusi najti kernel ter initrd sliko in ju naložiti na roke. Recimo takole... predvidevam da imaš recimo ločeno boot particijo, ki je prva primarna:
root (hd0,0)
kernel /vmlinuz-lcgjhfgjh ro root=/dev/sda2
initrd /initrd-kdjhcf
boot

matijaz74 ::

Icematxyz je izjavil:

Grub se v normalnih razmerah ne bi "okvaril" sam od sebe in višje nisi povedal, kaj točno si počel, da je prišlo do te težave in za to ti torej ne morem pomagati bolj konkretno, kot to da ti predlagam da po postopku, ki sem ga že podal poskusiš znova namestiti/obnoviti Grub 2 in vidiš če se Ubuntu zažene. Sumim, da si se igral z spreminjanjem strukture razdelkov tik pred to težavo?

Kakorkoli sledi najprej navodilom, ki sem ti jih podal in poročaj kakšen bo torej rezultat!


Tako danes sem se spet lotil reševanje GRUB 2. Šel sem po prejšnjem postopku ki si ga posredoval. Vse je šlo lepo razen na koncu ne. Pred točko D. piše:
Restart your computer. As previous Grub 2 entries are removed, run the following command to restore them:

Ko napišem ukaz
sudo update-grub
mi javi napako.
/usr/sbin/grub-probe: error: cnanot find device for / (is /dev mounted?). 
No ... sem potem še mountau nazaj. Vendar mi še zmeraj javi napako. No še nekaj. Iz neta sem si potegnil Ubuntu Mini Remix 10.04 Live CD ... Rescue nima vseh ukazov. Pred začetkom sem napisal ukaz
sudo fdisk -l
izpisal mi je razdelke pri prvem /dev/sda1 pa je še dopisal
Partition 1 does not end on cylinder boundary.
. Kaj to pomeni da je problem v prvem razdelku? Da je pokvarjen? Hvala za odgovor.
lp
Matijaž

BlaY0 ::

Ne nujno. Danes CHS geometrija pri diskih ne igra več nobene vloge. Večina orodij za formatiranje ti naredi začetek prve particije na sektorju 2048, se pravi na drugem megabajtu.

Daj ti poglej kje imaš grub.cfg.

PS: Moj zgornji post se sicer nanaša na legacy GRUB ampak princip ostaja enak.

Icematxyz ::

@matijaz74

Točka D se izvrši šele po ponovnem zagonu računalnika, če je zagon uspešen. Se pravi natančno izvedi točke A, B in C in potem znova poženi računalnik.

Če se Ubuntu ne bo zagnal in če si uporabil v navodilih pravilen razdelek in namestil Grub 2 na pravilen podatkovni nosilec potem je verjetno težava drugje in ne gre za kaj preprostega.

Torej še enkrat od začetka izvedi navodila brez točke D in znova poženi računalnik in poročaj in najbolje bi bilo, če bi pri tem uporabil namestitveni Ubuntu LiveCD/LiveUSB enaka različica in arhitektura, kot je nameščen Ubuntu in če postopek ne bo uspešen bomo se torej naprej ukvarjali s tem, kje dejansko leži težava!

matijaz74 ::

Icematxyz je izjavil:

@matijaz74

Točka D se izvrši šele po ponovnem zagonu računalnika, če je zagon uspešen. Se pravi natančno izvedi točke A, B in C in potem znova poženi računalnik.

Če se Ubuntu ne bo zagnal in če si uporabil v navodilih pravilen razdelek in namestil Grub 2 na pravilen podatkovni nosilec potem je verjetno težava drugje in ne gre za kaj preprostega.

Torej še enkrat od začetka izvedi navodila brez točke D in znova poženi računalnik in poročaj in najbolje bi bilo, če bi pri tem uporabil namestitveni Ubuntu LiveCD/LiveUSB enaka različica in arhitektura, kot je nameščen Ubuntu in če postopek ne bo uspešen bomo se torej naprej ukvarjali s tem, kje dejansko leži težava!


Danes sem enako naredil brez točke D (sem prebral navodila). Nobene spremembe ni bilo. Pa čeprav je bilo napisano, da je uspešno. Uporabil sme kot sem prej navedel pravilo verzijo Ubuntu-ja torej 10.04 LiveCD samo da še piše zraven Remix. Deluje v kozolni različici.
Še en podatek. Ko sem mountau /dev/sda1 v /mnt sem pogledal seznam datotek in map ter opazil zelo veliko datotek ko sem update server. Potem sem pa pogledal tudi mapo grub v njem nisem opazil datoteke grub.cfg ampak grub.cfg.new. Pa še enekaj. Kosi omenil verzijo. Upam da ni razlika v kernelu zadnji upgrade ima verzijo 2.6.32-41 Ubuntu Live CD pa 2.6.32-24.
lp
Matijaž

Icematxyz ::

A tako torej praviš.

Danes sem enako naredil brez točke D (sem prebral navodila). Nobene spremembe ni bilo. Pa čeprav je bilo napisano, da je uspešno.


OK, torej to sva lahko dokaj prepričana, da to področje ni več težava.

Še en podatek. Ko sem mountau /dev/sda1 v /mnt sem pogledal seznam datotek in map ter opazil zelo veliko datotek ko sem update server. Potem sem pa pogledal tudi mapo grub v njem nisem opazil datoteke grub.cfg ampak grub.cfg.new.


Tako se to počne da in sicer potrebna je dvosmerna komunikacija pri reševanju težave.

Z nekaj sreče torej odvisno od vsebine datoteke, bo zadostovalo, če boš ročno preimenoval grub.cfg.new v grub.cfg in znova pognal računalnik!

P.S. Če pa to ne bo zadostovalo ali vsebina datoteke ne zadošča pa boš poskusil še nekaj drugega in torej sedaj s ukazom sudo cp ali gksudo Nautilus, če je na voljo GUI preimenuj datoteko znova poženi računalnik in poročaj, če se torej Ubuntu uspešno zažene!

matijaz74 ::

Icematxyz je izjavil:

A tako torej praviš.

Danes sem enako naredil brez točke D (sem prebral navodila). Nobene spremembe ni bilo. Pa čeprav je bilo napisano, da je uspešno.


OK, torej to sva lahko dokaj prepričana, da to področje ni več težava.

Še en podatek. Ko sem mountau /dev/sda1 v /mnt sem pogledal seznam datotek in map ter opazil zelo veliko datotek ko sem update server. Potem sem pa pogledal tudi mapo grub v njem nisem opazil datoteke grub.cfg ampak grub.cfg.new.


Tako se to počne da in sicer potrebna je dvosmerna komunikacija pri reševanju težave.

Z nekaj sreče torej odvisno od vsebine datoteke, bo zadostovalo, če boš ročno preimenoval grub.cfg.new v grub.cfg in znova pognal računalnik!

P.S. Če pa to ne bo zadostovalo ali vsebina datoteke ne zadošča pa boš poskusil še nekaj drugega in torej sedaj s ukazom sudo cp ali gksudo Nautilus, če je na voljo GUI preimenuj datoteko znova poženi računalnik in poročaj, če se torej Ubuntu uspešno zažene!


Napisal sem ukaz
sudo cp grub.cfg.new grub.cfg
in restartal računalnik. Ubuntu server se ni ponovno pognal in se je spet ustavil pri ukazu
grub>
Kako pa je to mogoče da je en navaden ukaz iz menija
grub Update grub bootloader

Še kaj lahko reši zadevo?
lp
Matijaž

Icematxyz ::

Kot kaže vsebina datoteke grub.cfg.new ni zadoščala in torej tukaj je tudi kot kaže težava, preizkusi sledeče, poženi LiveCD/LiveUSB in vpiši sledeč ukaz:

sudo fdisk -l

Kot v navodilih višje se prepričaj na kateri razdelek si namestil Ubuntu in kateri podatkovni nosilec je zagonski (v navodilih bom za lažje razumevanje uporabil za razdelek podatek sda1 in podatkovni nosilec sda). Vnese vse ukaze zaporedoma v enak terminal in pazi, da boš v dveh ukazih z dodatnimi navodili vnesel pravilen podatek:

Zamenjaj v tej vrstici sda1 s pravilno vrednostjo:

sudo mount /dev/sda1 /mnt
sudo mount --bind /dev /mnt/dev
sudo mount --bind /proc /mnt/proc
sudo mount --bind /sys /mnt/sys
sudo chroot /mnt


Zamenjaj v tej vrstici sda s pravilno vrednostjo:

grub-install /dev/sda
update-grub
exit
sudo umount /mnt/dev
sudo umount /mnt/sys
sudo umount /mnt/proc
sudo umount /mnt
sudo reboot

matijaz74 ::

Icematxyz je izjavil:

Kot kaže vsebina datoteke grub.cfg.new ni zadoščala in torej tukaj je tudi kot kaže težava, preizkusi sledeče, poženi LiveCD/LiveUSB in vpiši sledeč ukaz:

sudo fdisk -l

Kot v navodilih višje se prepričaj na kateri razdelek si namestil Ubuntu in kateri podatkovni nosilec je zagonski (v navodilih bom za lažje razumevanje uporabil za razdelek podatek sda1 in podatkovni nosilec sda). Vnese vse ukaze zaporedoma v enak terminal in pazi, da boš v dveh ukazih z dodatnimi navodili vnesel pravilen podatek:

Zamenjaj v tej vrstici sda1 s pravilno vrednostjo:

sudo mount /dev/sda1 /mnt
sudo mount --bind /dev /mnt/dev
sudo mount --bind /proc /mnt/proc
sudo mount --bind /sys /mnt/sys
sudo chroot /mnt


Zamenjaj v tej vrstici sda s pravilno vrednostjo:

grub-install /dev/sda
update-grub
exit
sudo umount /mnt/dev
sudo umount /mnt/sys
sudo umount /mnt/proc
sudo umount /mnt
sudo reboot


Hmmm ... bo en problem ... directory sys ne obstaja. Čudim se da chroot ne deluje čeprav vsepovsod uporabljam sudo. Hmmm ... ne vem. Pa še resetira kar sem navedel v tej temi. Imam občutek da se je sistem zelo pokvaril z enim samim GUB Update-om.
lp
Matijaž

Icematxyz ::

Imam občutek da se je sistem zelo pokvaril z enim samim GUB Update-om.


Ne tega ne verjamem in vzrok je najverjetneje drugje. Gre pa za bolj resno okvaro/napako, kar predvidevam že nekako od začetka teme in vsi podatki v temi to nekako potrjujejo. Priporočam torej reševanje podatkov s pomočjo LiveCD/LiveUSB v kolikor varnostna kopija ne obstaja -> odprava napake na strojni opremi in začetek znova.

Kvečjemu še preizkusi sledeče (ustrezno popravi ukaza, ki vsebujeta sda1 in sda):

sudo mount /dev/sda1 /mnt
sudo chroot /mnt
grub-install /dev/sda
update-grub
exit
sudo umount /mnt
sudo reboot


In tudi če slučajno po tem postopku uspešno poženeš Ubuntu priporočam:

Reševanje podatkov v kolikor varnostna kopija ne obstaja -> odprava napake na strojni opremi in začetek znova!

matijaz74 ::

Pozdravljen! Danes sem se spet lotil reševanje strežnika. Ker uporabljam prej omenjeni LiveCD Ubuntu Remix verzija 2.6.32-24-generic Ubuntu server ima tudi verzijo 2.6.23-.
Ne vem kje naj dobil polni CD Live Ubunntu linux-a. Zakaj? Zato ker pri ukazu
sudo chroot /mnt
ne deluje, ker chroot ukaza ni.
Nato sem napisal (kar predvidevam, če prejšnji ukaz ni uspel)
grub-install /dev/sda
sem dobil povratno informacijo
cp: cannot crate regulat file '/boot/grub/915resolution.mod': Permission denied
. No potem nisem šel naprej. Če sta bila že dva neuspeha.
Razmišljam o reševanju podatkov tako, da prenesem disk na drug računalnik in prenesem podatke tudi mysql bazo na ta drug računalnik, nato pa ponovno namestim Ubuntu server. Ali je še kakšna druga rešitev? Hvala!
lp
Matijaž

Icematxyz ::

1.)

http://releases.ubuntu.com/lucid/

Snemi LiveCD in sicer, PC (Intel x86) desktop CD, če uporabljaš 32-bit različico Ubuntu 10.04 ali 64-bit PC (AMD64) desktop CD, če uporabljaš, oziroma je nameščena na strežnik 64-bit različica Ubuntu 10.04.

2.)

Izdelaj LiveCD/LiveUSB, za izdelavo LiveUSB lahko uporabiš sledeč program UNetbootin.

3.)

Vstaviš LiveCD/LiveUSB in poženeš strežnik, pri čemer je zagonska naprava optična enota/USB ključ in izbereš opcijo "Try Ubuntu".

4.)

Slediš navodilom, če ne bo po novem zagonu računalnika nič bolje ponoviš točko 3 in preizkusiš ta navodila.

matijaz74 ::

Pozdravljen!
Sedaj sem se ponovno lotil reševanja strežnika. Tokrat sem zamenjal mašino. V njej sem vklopil samo disk iz serverja. V cd-rom sem dal dobesedno Ubuntu Desktop 10.04 in pognal. Ko se je vse naložilo sem selotil najprej prvih navodil.
sudo mount /dev/sda1 /mnt
sudo chroot /mnt
grub-install /dev/sda 

Zataknilo se je že pri zadnjem ukazu. Ker sem najprej dobil ta rezultat
cp: cannot create regular file `/boot/grub/915resolution.mod': Permission denied
Sem dodal še ukaz sudo. Tokrat sem dobil rezultat.
/usr/sbin/grub-probe: error: cannot find a device for /boot/grub (is /dev mounted?).
No path or device is specified.
Try `/usr/sbin/grub-probe --help' for more information.
Auto-detection of a filesystem module failed.
Please specify the module with the option `--modules' explicitly.

Potem sem resetiral računalnik in prešel na druga navodila. Najprej se mi je zataknilo pri
ubuntu@ubuntu:~$ sudo mount --bind /sys/ /mnt/sys
mount: mount point /mnt/sys does not exist
Potem še pri
ubuntu@ubuntu:~$ sudo chroot /mnt/
chroot: cannot run command `/bin/bash': No such file or directory

Nato pa še pri
ubuntu@ubuntu:~$ sudo grub-install /dev/sda
/usr/sbin/grub-probe: error: cannot find a device for /boot/grub (is /dev mounted?).
No path or device is specified.
Try `/usr/sbin/grub-probe --help' for more information.
Auto-detection of a filesystem module failed.
Please specify the module with the option `--modules' explicitly.
Še kakšna rešitev? Ali je mogoče vsaj podatke prekopirate iz sda5 razdelka? Hvala za odgovor.
lp
Matijaž

Icematxyz ::

Prilepi še sem kaj vrne ukaz:

sudo fdisk -l

matijaz74 ::

sudo fdisk -l

Disk /dev/sda: 200.0 GB, 200049647616 bytes
255 heads, 63 sectors/track, 24321 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x0004eeb3

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1          32      248832   83  Linux
Partition 1 does not end on cylinder boundary.
/dev/sda2              32       24322   195109889    5  Extended
/dev/sda5              32       24322   195109888   8e  Linux LVM
lp
Matijaž

Icematxyz ::

No čisto tako torej vendarle ni in torej imamo tako ločen /boot razdelek, kot LVM, kar je že nekoliko bolj napredna struktura s katero se ponavadi povprečen "home user" ne srečuje.

Poženi LiveCD/LiveUSB Ubuntu 10.04 (enaka arhitektura, kot jo uporabljaš pri nameščenem Ubuntu 10.04) in omogoči dostop do interneta in vpiši v terminal sledeče:

sudo apt-get install lvm2
sudo vgscan


In prilepi sem vrnjen izpis ukaza!

matijaz74 ::

Hmmm ... upam da je tak rezultat praviln.
ubuntu@ubuntu:~$ sudo vgscan 
  Reading all physical volumes.  This may take a while...
  Found volume group "ubuntu-server" using metadata type lvm2
Drugače imam jaz sedajv drugem računalniku disk in skoz prižgan na LiveCD Ubuntu 10.04.
lp
Matijaž

Icematxyz ::

sudo vgscan
sudo vgchange -ay ubuntu-server
sudo lvscan


In prilepi sem vrnjen izpis zadnjega ukaza in pusti terminal odprt, da bova torej nadaljevala od te točke naprej.

Zgodovina sprememb…

matijaz74 ::

srednji ukaz bom izpisal ker sva prejšjega že.
ubuntu@ubuntu:~$ sudo vgchange -ay ubuntu-server
  2 logical volume(s) in volume group "ubuntu-server" now active
za tazadnji pa ne vem. Nek znak me moti pred scan. Seveda bom pustil odprto. Računalnik bo ostal prižgan in terminal tudi.
lp
Matijaž

Icematxyz ::

Ne razumem? Po tem ukazu sudo vgchange -ay ubuntu-server copy/paste v terminal še sledeč ukaz:

sudo lvscan

In potem prilepi sem izpis ukaza.

matijaz74 ::

aha ... se opravičujem sem študiral kateri znak je to. Sem kr tako naredil kot si rekel copy/paste. No rezultat po tem pa je:
ubuntu@ubuntu:~$ sudo lvscan
  ACTIVE            '/dev/ubuntu-server/root' (183.21 GiB\) inherit
  ACTIVE            '/dev/ubuntu-server/swap_1' ([2.86 GiB\) inherit

ni dobesedno kopirano ker mi ne dovoli vnosa v ta urejevalnik besedil zaradi oglatega oklepaja. Zato sem zamenjal z zavitim oklepajem.
lp
Matijaž

Zgodovina sprememb…

Icematxyz ::

OK sedaj bom raje vse skupaj združil in ti bom podal celotna navodila za copy/paste vrstico po vrstico v terminal, če bo po ponovnem zagonu računalnika izpis sledečega ukaza identičen temu seveda pa načeloma lahko nadaljuješ od tam, kjer sva torej ostala.

sudo fdisk -l

Poženi LiveCD/LiveUSB Ubuntu 10.04 (enaka arhitektura, kot jo uporabljaš pri nameščenem Ubuntu 10.04) in omogoči dostop do interneta in vpiši v terminal sledeče (izpis do sedaj izvedenih ukazov se mora ujemati s tem izpisom, ki si ga že prilepil sem):

sudo apt-get install lvm2
sudo vgscan
sudo vgchange -ay ubuntu-server
sudo lvscan
sudo mount /dev/ubuntu-server/root /mnt
sudo mount /dev/sda1 /mnt/boot
sudo mount -o bind /proc /mnt/proc
sudo mount -o bind /dev /mnt/dev
sudo chroot /mnt
grub-install /dev/sda
update-grub
exit
sudo umount /mnt/dev
sudo unmount /mnt/proc
sudo unmount /mnt/boot
sudo unmount /mnt
sudo reboot

matijaz74 ::

Dobkončal sem vse ukaze. Pri update-grube sem zaledil napako ... čisto dobesedno verjetno se ne bom spomnil. Vse je najdel prejšnje verzije ubuntu linuxa nato pa je zapisal da ne najde več? No samo tu je bila težava, drugače je šlo vse lepo skozi. Ko sem reboot-u pa se mi je pojavila napaka. Besedila je zelo veliko, upam da ni razlika med procesorji ali pa rami. Zato ker disk deluje na drugem računalniku kot je bil instaliran. Kako naj dam sliko v ta urejevalnik. Ali je najbolje da povežem z kakšnim drugim strežnikom?
lp
Matijaž

Icematxyz ::

Se pravi po izvedenem postopku imaš spet v Grub izbirniku na voljo na izbiro jedra in zagon Ubuntu OS se začne vendar se ne izvrši uspešno? Preizkusi še torej kakšno drugo jedro in pa načeloma boš moral povedati za kakšno napako pri zagonu gre, ker torej ne gre več za težave s Grub.

P.S. Lahko pa seveda podatkovni nosilec priključiš nazaj na originalen strežnik na katerem je torej že deloval in preizkusiš zagon še tam!

matijaz74 ::

Sedaj sem pognal disk v serverju. Ker ne morem drugače prikazati napake, ki se zgodi, sem fotografiral.

fotografija


Ne vem ... v čem je problem več. :(

lep vikend
lp
Matijaž

Zgodovina sprememb…

  • zavaroval slike: Icematxyz ()

Icematxyz ::

Zato ker mi napajalnik, je nagajal (vsakih ko je server želel narediti kaj težjega se je resetiral). Tako da imam dve težave (napajalnik, zagon sistema)


Okvarjena strojna oprema je verjetno bila sploh vzrok za te težave in po tem, ko sva rešila težavo s Grub sedaj preprosto pusti, da se preverjanje datotečnega sistema na katerem se nahajajo napake samodejno izvede do konca in te operacije NE PREKINI!

matijaz74 ::

Pismo .... sem moral nekaj prekiniti ... ker je prišlo do splošne strojne napake (zavohal sem kako se nekaj žge). Po ponovnem zagonu sem ugotovil, da je šla grafična. Upam, da ni ta prekinitev kaj pokvarila. Bom probal še enkrat izvesti z zdravim računalnikom.
lp
Matijaž

Icematxyz ::

Da na strojni opremi, katera deluje brezhibno ta postopek izvedi do konca in ga ne prekinjaj in potem bo se izvršil ponovni zagon in potem poročaj.

matijaz74 ::

Upam, sem dal disk na računalnik ki deluje in izvedel postopek. Prikazal se mi je zaslon na katerem pišem naslov Ubuntu pod njim pa pikice spreminjajo barvo, kot da deluje. Kako dolgo bo to delovalo?
lp
Matijaž

Icematxyz ::

Se pravi ta postopek si pustil, da se izvede do koca in po ponovem zagonu torej te težave nimaš več?

Sedaj se pa torej pojavi nova težava, kjer se Ubuntu zaganja, ampak se ne zažene? Zaženi torej Ubuntu še enkrat in ko se postopek zagona ustavi ali že pred tem, takoj ko se začne (po izbiri v Grub) pritisni na tipko Esc. Verjetno bo na zaslonu izpisana napaka in jo torej prilepi sem!

matijaz74 ::

Pustil sem celi dan in še ponoči ker je delovalo ... nekaj je delovalo. Ko je opravilo je se prikazal to

zaslonska slika


Torej nisem še ponovno zagnal ampak sem pustil da sistem opravi svoje.
lp
Matijaž

Zgodovina sprememb…

  • zavaroval slike: Icematxyz ()

matijaz74 ::

Šele sedaj sem opazil. Branje diska je vsakih nekaj sekund. Torej ali popravljanje še zmeraj deluje?
lp
Matijaž

Icematxyz ::

Ne morem trenutno preizkusiti v praksi, ampak poženi LiveCD/LiveUSB Ubuntu 10.04 (enaka arhitektura, kot jo uporabljaš pri nameščenem Ubuntu 10.04) in omogoči dostop do interneta in vpiši v terminal sledeče ukaze:

sudo apt-get install lvm2
sudo pvscan
sudo vgscan --mknodes
sudo vgchange -ay
sudo lvscan
sudo fsck /dev/mapper/DOPOLNI


Tam kjer piše DOPOLNI uporabi tipko Tab, da samodejno vnese torej preostanek ukaza, ker ne vem ali bo izpisalo ubuntu-server-root ali malenkost drugače.

Po končanem postopku znova poženi računalnik in poročaj!

matijaz74 ::

Icematxyz je izjavil:

Ne morem trenutno preizkusiti v praksi, ampak poženi LiveCD/LiveUSB Ubuntu 10.04 (enaka arhitektura, kot jo uporabljaš pri nameščenem Ubuntu 10.04) in omogoči dostop do interneta in vpiši v terminal sledeče ukaze:

sudo apt-get install lvm2
sudo pvscan
sudo vgscan --mknodes
sudo vgchange -ay
sudo lvscan
sudo fsck /dev/mapper/DOPOLNI


Tam kjer piše DOPOLNI uporabi tipko Tab, da samodejno vnese torej preostanek ukaza, ker ne vem ali bo izpisalo ubuntu-server-root ali malenkost drugače.

Po končanem postopku znova poženi računalnik in poročaj!


Ni mi bilo potrebno narediti.
Še enkrat sem pognal sistem in se je sam od sebe resetiral in se postavil na login. Sistem se je končno postavil.
Najlepša ti hvala! En majhen problemček je še nastal. Čeprav imam postavljeno mrežo mi ne prepozna mrežo. Ko vtipkam ukaz
ifconfig
in opazil da obstaja samo lo. No sedaj mi manjka samo še strojna oprema. Še enkrat ti hvala za pomoč, sam nebi moral rešiti oz. bi reševanje trajalo še dlje kot je dosedaj. Hvala!
lp
Matijaž

Icematxyz ::

Še enkrat sem pognal sistem in se je sam od sebe resetiral in se postavil na login. Sistem se je končno postavil.


Super, torej je kot kaže fsck opravil svoje delo brez potrebe po ročnem postopku na opisan način in je to torej zadostovalo:

Torej nisem še ponovno zagnal ampak sem pustil da sistem opravi svoje.


Ker gre za strežnik na katerem poganjaš baze in ne gre za klasično namestitev, ampak za strežniško namestitev, ki ima določene specifike sedaj najprej izdelaj strategijo varnostnega kopiranja, da bo naslednjič se preprosto Ubuntu znova namestil na strežnik in boš uvozil varnostno kopijo (baze in druge podatke) in to je to.

En majhen problemček je še nastal. Čeprav imam postavljeno mrežo mi ne prepozna mrežo. Ko vtipkam ukaz

ifconfig

in opazil da obstaja samo lo.


Tako na prvo žogo verjetno gre za drugo strojno opremo sedaj in morda se nahajajo kje še kakšne ročne nastavitve za prejšnji strežnik (strojno opremo)?

cat /etc/network/interfaces

No sedaj mi manjka samo še strojna oprema.


Dobro preveri katera komponenta deluje dobro in katera ne in jo zamenjaj v prvotnem strežniku in strežnik ne sme ugašat med obratovanjem ali pod obremenitvijo ali se kakšna komponenta pregrevati nad normalnim stanjem, če je poskrbljeno za ustrezno hlajenje.

Najlepša ti hvala!

Še enkrat ti hvala za pomoč, sam nebi moral rešiti oz. bi reševanje trajalo še dlje kot je dosedaj. Hvala!


You're welcome.

matijaz74 ::

Sedaj skušam urediti še tehnično težavo. Vnesel sem ukaz za zaustavitel sistema
sudo shutdown now
in prišel do menija od koder je cel ta šmoren nastal. Kliknil sem na
grub      Posodobi zagonski nalagalnik GRUB
no potem pa je nastalo kar je nastalo. Prilagam še sliko menija.

Zagonski nalagalnik GRUB

lp
Matijaž

Zgodovina sprememb…

  • zavaroval slike: Icematxyz ()

matijaz74 ::

Tako server je v polnem teku. Zvečer bom uredil še backup v primeru če se bo kdaj spet kaj zataknilo. Hvala še enkrat.
lp
Matijaž

Icematxyz ::

matijaz74 je izjavil:

Tako server je v polnem teku. Zvečer bom uredil še backup v primeru če se bo kdaj spet kaj zataknilo. Hvala še enkrat.


Da tako varnostna kopija ti naj bo sedaj primarna naloga. Lepo, da torej deluje.


Vredno ogleda ...

TemaSporočilaOglediZadnje sporočilo
TemaSporočilaOglediZadnje sporočilo
»

Namestitev GRUB-a

Oddelek: Operacijski sistemi
161144 (907) Icematxyz
»

Ubuntu 10.10 - 10 Out Of 10 (strani: 1 2 3 419 20 21 22 )

Oddelek: Operacijski sistemi
1093109715 (67308) Icematxyz
»

[UBUNTU 10.04] GRUB se ne postavi

Oddelek: Operacijski sistemi
332578 (2362) matijaz74
»

Ubuntu 10.04 LTS - Change is coming (strani: 1 2 3 417 18 19 20 )

Oddelek: Operacijski sistemi
99990257 (53143) Icematxyz
»

GRUB linux boot loader

Oddelek: Pomoč in nasveti
111305 (1019) Icematxyz

Več podobnih tem