» »

Windows xp bluescreen

Windows xp bluescreen

Robocop1 ::

Pozdravljeni!

Na računalniku se mi zadnjih nekaj mesecev dogajajo čudne stvari: Priklopim USB ključek, pa me preseneti bluescreen. Potem resetiram računalnik in opazim, da mi v Mojem Računalniku manjka ikona za CD-ROM. Sicer pa računalnik dela v redu, moti me le ta napaka. To je pomembno: pred kakšnim mesecem ali 2 se mi je ob vklopu začelo prikazovati okence "Sistem se je po resni napaki obnovil". To se mi je prikazovalo vsakič in me je motilo, zato sem to napako nekako odpravil (obkljukal nekaj, da mi take napake ne prikazuje). Od takrat pa se mi dogaja tudi ta problem z bluescreen-om. Aja... zadeva se dogaja občasno, včasih pa deluje v redu.

Res je, da sem pred kakšnega pol leta nadgradil RAM (zdaj mam 1GB+512MB), ampak verjetno to ni krivo, ker: na istem računalniku imam nameščen tudi Ubuntu Linux in USB ključki delajo brez problema.

Če to bere kakšen strokovnjak, bi lepo prosil, da mi razloži ali gre za napako programske ali strojne opreme (po mojem so kar windowsi krivi, ampak rabim potrditev). In če mogoče kdo ve, kako se ta problem popravi - obnovitev sistema ne pomaga. Lahko probam zamenjat napajalnik in windowse, ampak nič ne bi rad delal na pamet, zato rabim kakšen nasvet.
  • spremenil: Robocop1 ()

gorenjc ::

Je problem samo na določenem usb portu(morda spredaj)? Težave dela eden ali vsi usb ključi? Koliko usb naprav je priklopljenih na mašino?

Robocop1 ::

Takole imam priključene naprave: Spredaj imam 2 usb vtičnice, ampak so proste. Na zadnji strani pa imam priključeno: tiskalnik (ga sproti ugašam), web kamera, 1 vtičnica je prosta, na drugo pa imam priključen usb podaljšek, kamor priključujem usb ključke.

Kot rečeno, na Ubuntu mi vse dela ok, na Windowsih pa občasno dobivam take napake. Na druge porte nisem še probal priključit, ampak mislim da ni težava v tem (sicer bi bilo na linuxu isto). Ključek uporabljam tudi na drugih računalnikih, pa ni problemov.

Pa še ena ugotovitev: Po tem, ko mi je v Mojem računalniku izginila ikona za CD-ROM, sem si ogledal dnevnik dogodkov. Ugotovil sem, da so ikono odstranili Windowsi.
Zdaj nekoliko povečal odstranjevalno datoteko. Bom videl, če mogoče to vpliva. Če ima kdo kako mnenje, bom pa tudi vesel.

Duhec ::

Imaš vsaj XP SP2 ali SP3 ?
Ali v varnem zagonu tudi fašeš BSOD ?
Kakšen je celoten sistem strojne opreme (HW)- predvsem osn.plošča ?
Če komp ni brandname (Hp, Dell ...) ampak sestavljen, je smiselno vprašanje @gorenjca, ko sprašuje okoli sprednjih usb priklopov, saj jih marsikateri pikzigmar, ki sestavlja komp, ne priklopi pravilno in vtik usb ključka povzroči stik linij, ki niso za skupaj... posledično bsod, zamrznitev ali restart.

SasoS ::

Kaj ko bi za začetek naredil memtest?

Robocop1 ::

Gre za 5 let star računalnik s konfiguracijo:
ASRock k7vt4a+, AMD Sempron 2800
1GB+512MB RAM
ATI RadeOn 9600

Naj omenim še, da računalnika nisem sestavljal sam, edino RAM sem sam nadgradil, ampak je na začetku delalo v redu. Kot rečeno, RAM sem namestil pred cca pol leta, problem pa se pojavlja zadnji mesec ali 2.
Nameščen imam Windows XP Professional + SP2 in originalne gonilnike. Na istem računalniku imam tudi Ubuntu 9.04 (ampak to nima veze).

Safe mode še nisem probal... bom naslednjič, pa sporočim kako bo. Memtest (tisti od Ubuntu-ja) sem tudi naredil in pokaže OK. Sprašujem se, ali to napako res povzroča ključek ali je morda le naključje... do sedaj se mi je pojavilo 3-krat, zato nisem zagotovo prepričan.

Robocop1 ::

Spet napaka... bsod pravi takole:

PAGE_FAULT_IN_NONPAGED_AREA
... (potem nekaj besedila, naj obvestim administratorja ipd)

Technical information:
*** STOP: 0x00000050 (0xE3235000, 0X00000000, 0X8056C251, 0X00000001)

Beginning dump of phisical memory.
Phisical memory dump complete.

Ne omenja pa nobene datoteke ali karkoli. Samo tiste naslove mi izpiše, kar mi ne pomeni dost. Je možno, da je narobe kaj z RAM-i? Ponavljam: napaka je samo, ko priključim usb ključek (in tako je samo zadnji mesec).
Trenutno vsebolj razmišljam o ponovni namestitvi sistema, ampak se bojim, da bi bilo potem spet isto, zato bi raje najprej poiskal razlog.

Se komu kaj sanja kaj bi lahko blo?

Robocop1 ::

Evo še screenshot programa BlueScreenView:
 screenshot

screenshot



Pa še nekaj sm pozabil napisat: preden pride do bsod, mi tudi miška začne štekat (zaostaja), pol pa naenkrat moder zaslon.

Zgodovina sprememb…

  • spremenil: Robocop1 ()

gorenjc ::

Ali je bil ram stestiran z memtest-om? Naj se začasno vzpostavi stanje z ram-om kot je bilo pred njegovo nadgradnjo.

Robocop1 ::

Stestiral sm oba slota hkrati in ni bilo napak. @gorenjc, misliš da bi vzel tazadnji slot ven in stestiral tako kot je bilo pred nadgradnjo?

Na tistem screenshotu me motijo tiste 2 rdeče vrstice - najprej avast, pol pa ntoskrnl.exe.
Po zgornjem bsod sm računalnik resetiral, in priključil ključek, da si skopiram gor par fajlov. Zdaj je bil postopek takšen: najprej zaostaja miška, gor skopiram kar sm nameraval in ključek odklopim (varno odstranjevanje). Do ponovne napake ni prišlo - ni mi jasno, zakaj po ponovnem zagonu vedno dela. Miška zdaj normalno dela, a v Mojem Računalniku manjka ikona za CD-ROM. V dnevniku dogodku se je napaka zabeležila: Naprava odstranjena, ne da bi bila prej ustavljena.

Par stvari še probam. Če do naslednjega vikenda ne popravim, sledi formatiranje. Če kdo pogrunta kaj bi bilo, mu dam za pir.

gorenjc ::

Kar se tiče manjkajoče ikone za cd-rom. Naj se proba tole. Glede Bsod-jem bi pa osebno testiral tako, da bi pustil notri Ram, ki je bil pred nadgradnjo. Lako bi bil pa kriv tudi Avast. Naj se pri njem začasno izklopi real time protection, kadar se vstavi usb ključ.

Duhec ::

Še vedno nisem zasledil odgovor na vprašanje, če usb ključek dela v varnem zagonu.
Počakaj s formatiranjem, s tem se prehitro predaš in ti (mi) ne bi izvedeli zakaj se to dogaja. ;)

Osebno bi se lotil najprej stvari, ki bi morale biti že v osnovi narejene in se šele potem lotil problema z usb ključem.

Najprej vizuelno preglej notranjost kompa, če so kje napihnjeni kondenzatorji in če ni na splošno preveč prahu, sploh v okolici spomina, kamor ga z leti namede cpu vent.
Če je več različnih bsod napak je lahko krivec spomin. Ni mus, da je hin, lahko je zgolj zaprašen, če vanj piha cpu ventilator in z leti zamede prah med kontakte.

Če predvidevam, da ni spyware/virus zajedalcev in da memtest ni našel napak potem bi nadaljevanje sledilo takole:

1. izklopi ali najboljše kar deinštaliraj antivirusni program za čas testiranja in posodobitev
2. Zgolj preveri, če imaš mogoče starejšo verzijo Biosa kot je tale zadnja verzija 1.30 z dne 30.07.2004.

Nato bi se lotil samega XP sistema:
3. Bootni sistem z XP cdjem, izberi R za Recovery konzolo ... če kaj sprašuje izberi Windows particijo, če zahteva admin geslo in če ga imaš ga vtipkaj, drugače samo stisni Enter in padeš v ene vrste Command Prompt kjer v promptu odtipkaj:
CHKDSK /R
kar bo delal kar nekaj časa in popravil morebitne težave.
Ko konča pusti XP cd v enoti, odtipkaj EXIT za izhod in restart ter pusti normalni zagon iz trdega diska (ne iz CDja ...pač počakaj tistih 5 sekund).

Sledi :
4. Start/Run in v polje vpiši:
SFC /SCANNOW
ki posodobi ali osveži morebitne sfižene sistemske fajle iz XP cdja. Če zahteva restrart ga spet izvedi. Zdaj lahko XPcd vzameš ven.

Sledi:
5. posodobitev sistema iz SP2 na SP3 (tule je link do SP3 exe, dolg 316MB) ter naredi še preostali windowsupdate. To boš delal kar nekaj časa in večkrat vmes restartal sistem.

Še nekaj idej, ki jih lahko narediš pred vso zgornjo solato:

Če imaš ps/2 tipkovnico in ne USB potem v Cmos nastavitvah Biosa (zavihek Advanced/ Chipset Configuration) poglej, če je USB legacy support slučajno Enejblan in ga Disejblaj. Edino, če imaš usb tipkovnico pa pusti to vklopljeno, ker drugače ne boš mogel preko F2 v Cmos nastavitve Biosa, ker ti tipkovnica pred bootom pač ne dela.

Testiraj usb ključek, ko sta tako tiskalnik kot usb kamera izklopljena ali bodi pozoren na kombinacijo, če je takrat mogoče tiskalnik vklopljen ali tudi kamera. Mogoče se kaj stepe z nadzornim programom, ki komunicira z usb napravo.

Robocop1 ::

Tole pozorno preberite, ker je zadeva bolj komplicirana, kot sm mislil:

Do sedaj sm večinoma uporabljal XP-je, zato nism vedel kako je na Ubuntu. Vsaj po ponovnem zagonu (XP zaustavil, zagnal Ubuntu) je stvar delala normalno. Zdaj sm naredil tako:

Prižgem računalnik in bootam v Ubuntu. Tokrat priključim drugi ključek, a v isto vtičnico. Po nekaj sekundah mi zginejo vse ikone in pladnji, tako da računalnik obvisi v praznem namizju. Ker mi drugega ne preostane, računalnik resetiram in ponovno zaženem Ubuntu. Probam isti ključek v isti vtičnici... dela. Probam isti ključek v drugi vtičnici... dela. Zamenjam ključek in poskusim obe vtičnici... dela.
Računalnik resetiram in tokrat izberem XP, toda v safe mode. Probam ista 2 ključka v istih 2 vtičnicah... dela. Resetiram računalnik in ga kot običajno zaženem v XP-jih. Najprej dobim obvestilo o obnovitvi sistema (slika spodaj). Probam drugi ključek v tisti vtičnici, ki je prej povzročala probleme... najprej zaostajanje miške (istočasno obvestilo o nadgradnji Avast-a), potem se miška umiri in ključek dela. Ključek odstranim (varno odstranjevanje)... v Mojem računalniku mi zgine ikona za CD-ROM. Probam še drugo vtičnico z istimi ključki... vse dela.

Aja, pa glede BIOS-a: Imam verzijo 1.30, kar naj bi bila zadnja. Preveril sem naprave: najde mi vse priključene naprave - 2 diska, disketnik in cd-rom, kar je OK.

Najprej obvestilo o napaki (odprta vsa okna):
 Sistem se je po resni napaki obnovil

Sistem se je po resni napaki obnovil



Zdaj pa moja vprašanja:
Dejstvo je, da računalnik po prvem zagonu ne dela dobro. Po resetu (pritisk na gumb reset) pa ni nobenih problemov. Teoretično gledano z resetiranjem računalnika izgubim vse podatke v RAMu, zaustavim vse naprave, vključno z BIOSom in vse ponovno zaženem (se pravi bi računalnik moral delat isto kot pri 1. zagonu). Ni mi jasno, kako lahko računalnik po resetu dela OK (ne glede na operacijski sistem), če sm izgubil vse podatke in nastaviteve - kar je tudi namen reseta. Mi lahko kdo malo to razloži, ker mi je zadeva skrajno čudna?

Sm se premislil in ne bom formatiral, ker verjetno problema ne bom rešil. Vse kar sm v HW spremenil je: dodal 1 trdi disk in dodal 1 slot RAMa (1GB), ampak računalnik je tudi po nadgradnji delal, zdaj pa imam take probleme. Kaj bi lahko bil vzrok? Kako bi se lotili reševanja?

Duhec ::

safe mode: usb key dela
vizuelni pregled (kondenzatorji): ?
bios legacy usb support: ?
1: ?
2: ok
3: ?
4: ?
5: ?

Robocop1 ::

Zdej sm stvar sprobal še na enem podobnem računalniku - vbistvu še malo slabši od mojega. Vse nastavitve se ujemajo in verzija BIOSa enaka na obeh računalnikih.
Spet sm fasal bsod, tokrat se sporočilo o napaki glasi:

IRQL_NOT_LESS_OR_EQUAL
Technical Information:
*** STOP: 0x0000000A (0xC0032574, 0x00000002, 0x00000000, 0x80504750)

Po resetu pa mi winsi vržejo Win32 Generic Host Error.

V BIOS-u sm nastavil privzete nastavitve, tako da imam zdaj nastavljeno:
Spread Spectrum: Disabled
CPU Host Frequency: Auto
DRAM Frequency: Auto (v računalniku imam pa DDR333 in DDR400)
Flexibility Option: Disabled

Chipset Confguration:
USB Controller: Enabled
USB Device Legacy Support: Disabled
DRAM CAS# Latency: Auto
Suspend to RAM: Disabled

Iste nastavitve so na tistem drugem računalniku, v katerem sm pravtako nadradil RAM (že dolgo nazaj) in dela OK.

Windowsov samih nima smisla pregledovat in iskat napako, ker se problem pojavlja tudi na Ubuntu (ni bsod, ampak obvisi v namizju). Notranjost računalnika sm nahitro pregledal in na videz nič posebnega. V safe mode se računalnik sicer ne resetira, ampak miška šteka, kar pa tudi ni v redu.

RAM verjetno ne povzroča napak - probal 2 memtesta in ni najdenih napak.
Disk, ki sem ga dodatno vgradil, tudi verjetno ne vpliva na to napako, poleg tega pa lepo dela.
Če že iščem krivca v računalniku, mi je sumljivo: USB kartica (integrirana) ali pa miška (ki ima USB priključek, vendar imam PS/2 pretvornik).

Zdaj bom pregledal še winse, mogoče še kaken live linux probam (če se bo obneslo, bom napisal).
Slabe izkušnje mam z napajalniki. Je možno, da je preslab napajalnik? Kaj lahko še sam probam?

Zgodovina sprememb…

  • spremenil: Robocop1 ()

Robocop1 ::

Mislim, da sm že bliže rešitvi. Zdaj sm odlopil web kamero in priključil samo USB ključek (in tiskalnik, ki je sicer ugašnjen)... računalnik se ni resetiral. Še vedno pa mi zginja ikona za CD-ROM. Ikono kasneje prikličem tako, da kliknem na "dodajanje strojne opreme" in mi samo zazna CD-ROM in doda ikono.
Potem sem ključek odklopil in priklopil kamero... kamero mi sicer zazna, vendar namesto slike vidim samo sivino. Potem sem se malo igral in probal še druge vtičnice (ključek/kamera). Ključek normalno dela (ne povzroči reset računalnika; včasih le miška šteka), kamera pa včasih dela, včasih ne... zato sem jo preizkusil še na drugem računalniku, kjer je v vseh poskusih delala.

Moj zaključek je, da napaka izvira iz UBS. Zdej moram samo preverit, ali je napaka na USB kartici (imam intergrirano), ali imam se napajalniku bliža konec. Zanima me, kako lahko preverim delovanje napajalnika in usb portov brez odpiranja računalnika? Obstaja kakšen program? Kaj pa drugi menite - je lahko krivec nekaj od tega?

Duhec ::

Duhec je izjavil:

....Testiraj usb ključek, ko sta tako tiskalnik kot usb kamera izklopljena ali bodi pozoren na kombinacijo, če je takrat mogoče tiskalnik vklopljen ali tudi kamera. Mogoče se kaj stepe z nadzornim programom, ki komunicira z usb napravo....

Tole zgoraj sem ti sicer že predlagal .... in sam zdaj ugotavljaš, da je v povezavi s kamero.
Poglej, če imaš inštalirano tisto Logitechovo solato za nadzor miške in jo deinštaliraj ter restartaj. Za test bo dovolj že osnovna XP podpora za miš.
Ravno tako poglej, če obstaja kak novejši gonilnik za tvojo web kamero in mogoče še tiskalnik.
Da te heca napajalnik bi tako na hitro sicer dvomil, ker usb se futra s +5V in če bi se na tej napetostni veji kaj dogajalo bi se sistem tudi naključno resetiral in ne samo ob vklopu USBja. Prej bi bila plošča. AMpak, če imaš možnost menjave napajalnika tudi to ne bo odveč, le pazi, da bo vsaj enake ali večje moči.

Robocop1 ::

Nimam nič za nadzor miške. Miška je sicer USB, ampak jo imam preko pretvornika priklopljeno na PS/2. Z gonilniki tudi ni nič narobe - že zaradi tega, ker zadeva na Ubuntu čudno deluje. Če dva operacijska sistema čudno delujeta, je pomoje stvar v strojni opremi.

Naprave so testirane na drugih računalnikih in nobena ne povzroča napake. Iz izkušenj vem, da napajalnik prej crkne, kakor plošča, zato sumim napajalnik (možno pa je tudi slednje). Glede napajalnika sm mislil tako: mogoče je malo oslabel in ne oddaja polnih 5V, zato bi prišlo do "obremenitve" napajalnika, kar bi lahko povzročilo reset. Ampak tega ne morem 100% potrdit. Ni pa rečeno, da se mi že danes ne bo resetiral sam od sebe, saj napajalnik ne crkne kar čez noč. Če me razumeš?

Je pa tudi možno, da so tudi winsi že pokvarjeni... vsaj glede izginjajoče ikone za CD-ROM. Tudi na Ubuntu uporabljam cd-je, pa mi zato ikona ne zgine. Poleg tega sm danes dobil še neko novo obvestilo, da nimam inštaliranih golilnikov za zvok... pa je kljub temu po resetu bilo vse ok.

Kako naj se pa prepričam, da ni napaka na usb kartici, ki je integrirana na ploščo? Pregledal sm notranjost in ni nič sumljivega. Programsko pa se tega verjetno ne da preverit?

amigo_no1 ::

Zdej sm stvar sprobal še na enem podobnem računalniku - vbistvu še malo slabši od mojega. Vse nastavitve se ujemajo in verzija BIOSa enaka na obeh računalnikih.
Spet sm fasal bsod, tokrat se sporočilo o napaki glasi:

Kaj če je usb ključek krivec ?

Na 2 pcjih 2x bsod ob tem usb ključu pomoje ni naključje.

Robocop1 ::

Ne, tudi to sem že preveril. Še več: tudi svojo kamero sm že priključil na drugi računalnik (druga kišta, moj ključek in kamera), pa je stvar delala. Niti miška ni zaštekala.

Vse kar vem, je to, da je krivo nekaj v mojem računalniku. Vprašanje je samo, kaj je to.

Glede miške je pa tako: Ko priključim USB ključek mi nekako naraste poraba CPE, ampak niti vsi procesi skupaj toliko ne obremenijo, kolikor je poraba. Kje mi toliko nabije, mi ni jasno. To je vzrok zakaj miška šteka (v safe mode je isto). Po nekaj sekundah poraba CPE pade na 0 in tudi miška se umiri. Se mi je pa že zgodilo, da sm priključil in ni nič štekalo (tipično po resetu). Kot rečeno, stvari so nepredvidljive.

Toliko o winsih. Zdaj se bom še malo igračkal na Ubuntu, da vidim kako so stvari tam. Če mi zna kdo pomagat, mu lahko čestitam in častim pir.

Duhec ::

Dokler ne boš menjal HW opreme, bi jaz izvedel še točke 3, 4 in 5. Beri moj drugi post v tej temi.
Torej "chkdsk /r" , nato "sfc/scannow" in inštaliral "SP3". Kar nekaj časa ti bo šlo za to.

Robocop1 ::

Še 1 popravek: pravkar sm ugotovil, da bsod dobivam tudi če je kamera odklopljena in priključim samo ključek. Torej očitno ni kriv USB, razen če mu kaj drugega povzroča problem. Spet sm dobil: PAGE_FAULT_IN_NONPAGED_AREA.
Mogoče sploh ni kriv ključek, ampak ga kot usb napravo najpogosteje prikapljam/izklapljam, zato ni čudno, če bsod glih takrat dobim.

Samo za informacijo: winse sm naložil pred skoraj 2 leti in je do nedavnega vse delalo v redu. In če je bilo do zdaj vse v redu z SP2, potem ne vem zakaj zdaj ne bi blo. Pomoje nima smisla nadgrajevat na SP3.
Ker imam tudi cel kup svinjarije na kompu, bom najprej na novo namestil winse. Če tudi po tem ne bo boljše, se podam na lov za novim napajalnikom. Če tudi po tem ne bo v redu, si lahko omislim vsaj novo kišto.

Vidim, da mi tukaj na forumu ne bomo rešili problema (vseeno hvala vam za pomoč), zato najprej probam zgoraj omenjeno, torej novi winsi in napajalnik. Ko najdem krivca, pa napišem.

Duhec ::

Odpiraš nove teme za (po vsej verjetnosti) isti problem:
USB problem

Kaj je smiselno in kaj ne je predvsem odvisno od tebe.
Bom zdaj govoril zase: Če se ti ne da izvajat SW predlogov glede tvojih težav, potem seveda z lahkoto za konec napišeš, "da mi tukaj na forumu ne bomo rešili problema", ker na ta način nisi niti korak dlje do rešitve ampak zgolj ugotavljaš vedno nove težave in njih kombinacije.

Potem se že 1x odloči in takoj preidi na HW rešitve; za začetek menjaj napajalnik, nato spomine, plato, cpu itd...in počasi boš slej kot prej prišel od chkdsk /r, preko sfc/scannow do XP SP3, če ne boš prej kar na novo inštaliral XPje.
Ali je cenejše naredit določene kombinacije sw testov in znanih rešitev ali pa brez nekih testiranj kar menjava hw vsevprek pa veš samo ti.
Zaenkrat se umikam iz te teme, če pa najdeš rešitev bi jo bilo fer v to temo tudi napisat, pa ne zaradi mene, da se razumemo.


Vredno ogleda ...

TemaSporočilaOglediZadnje sporočilo
TemaSporočilaOglediZadnje sporočilo
»

Windows 10 BSOD memory_management

Oddelek: Operacijski sistemi
92141 (1672) slovo
»

Kako namestiti OS

Oddelek: Pomoč in nasveti
121935 (1635) Csharp
»

Ideje - kaj je narobe s tem računalnikom

Oddelek: Pomoč in nasveti
231233 (756) m0LN4r
»

Izšel Ubuntu 10.10 (strani: 1 2 3 4 5 )

Oddelek: Novice / Operacijski sistemi
22164548 (54632) Icematxyz
»

Vtaknem USB --> PC se obesi

Oddelek: Pomoč in nasveti
291581 (1215) hojnikb

Več podobnih tem