» »

[php] compile php-ja z gettext supportom

[php] compile php-ja z gettext supportom

jelly ::

Živjo!

Želim uporabljati neko open source aplikacijo v phpju, ki potrebuje gettext support.

Imam php PHP 4.3.8, ki zgleda nima po defaultu php_gettext.dll extensiona.

Na netu sem zasledila da je potrebno php compajlati z ukazom --with-gettext, zdaj bi pa nekako to poskusila narediti.

Naj omenim da nisem ravno vešča v tovrstnih zadevah, tako da bi rabila kak "How to compile PHP for Dummies" navodila.

LP, J.

jelly ::

A bi morala še kaj dodati, da bo bolj jasno kaj sprašujem?

Kami ::

Zaj je vprašanje na kirem OS-u maš php.

Kaj maš windows oz *nix?
http://www.ubuntu.si || http://www.freebsd.si

jelly ::

Windowse imam.

Fora je pa tudi, da je moja php verzija že tako obsolite, da niti ne najdem za zdljat full package (php-4.3.8-Win32.zip).

Skratka vedno bolj se mi dozdeva da bom morala verzijo phpja upgradat (kar ubistvu ni gut, ker je ta OS aplikacija ki jo nameravam uporabljat stabilna točno na tej verziji :S )

Sem poskusila iz verzije 4.3.9 (to sem še nekje našla za zdljat) samo skopirat php_gettext.dll pa dat v extensions folder, pa je potem apache kar zaštekal. Probat ni greh pač.

Hvala Kami za tvoje vprašanje :)

Kami ::

Am, če daš v default extension folder ni dovol, moreš še extension enejblat v php.ini, extension=php_gettext.dll (to dodaš npr. na konec fajla)
http://www.ubuntu.si || http://www.freebsd.si

sverde21 ::

enejblat ali odkomentirat... ker v mojem php.ini fajlu ga je treba sam odkomentirat :))

btw ti si kr zdownloadi najnovejšo 5.1.2 verzijo, men dela čist stabiln, pa delam gor vsega boga :D (res je pa da mam PHP na linux box-u) :)
<?php echo `w`; ?>

jelly ::

sem odkomentirala seveda v php.ini, pa restartala apache, pa je potem zaštekalo

in to tako da html pejđi so delali (brez slikic) - recimo una dafault apache stran se je naloadala. Kakorkoli sem pa kak php requestala je pa mlelo mlelo mlelo pa nič iz tega.

Potem sem seveda extension zakomentirala nazaj, in res je potem apache spet pridno vračal php-je

mal je problem ker tale OS php applikacija pride z instalerjem z vsem kar potrebuje zraven (apache, php, mysql) zato bi raj nekak nardila da mi ni treba nove verzije phpja gor dajat

je pa izrecno zahtevano da je php verzija 4.3.x ("stabilno" in stestirano le na 4.3.8) na php 5 pa sploh naj nebi delalo :(

krho ::

Načeloma bi ti moralo delovati tudi na 4.4.
In extension mora biti iz iste verzije php-ja kot jo uporabljaš ti, da bo to delovalo.

Bom jaz malce pogledal, če bom na šihtu pri kakšnem developerju našel 4.3.8, čeprav naj bi vsi že imeli 5.1.2
si.Mail odprto-kodni odjemalec elektronske pošte. - http://www.simail.si
Uredite si svojo zbirko filmov, serij in iger - http://xcollect.sf.net

jelly ::

upam da ima kdo :)

hvala

krho ::

Našel 4.3.8 na enem računalniku. Samo je brez gettext-a.
Našel sem tudi 4.3.11, ki pa ima gettext.
Glede na to, da je .11 samo bugfix verzija bi ti program moral delovati brez problema.

Glej zasebna sporočila za povezavo za download.
si.Mail odprto-kodni odjemalec elektronske pošte. - http://www.simail.si
Uredite si svojo zbirko filmov, serij in iger - http://xcollect.sf.net

jelly ::

hvala lepa, bom poročala o uspehu


Vredno ogleda ...

TemaSporočilaOglediZadnje sporočilo
TemaSporočilaOglediZadnje sporočilo
!

Postavitev Apache serverja s podporo za PHP in MySQL (strani: 1 2 3 4 5 6 7 )

Oddelek: Izdelava spletišč
318206291 (7489) jaka89
»

[php-mysql] Call to undefined function mysql_connect()

Oddelek: Izdelava spletišč
51049 (1008) slovencl
»

PHP in Apache problem...z POST

Oddelek: Izdelava spletišč
151142 (1037) Trubadur
»

phpBB forum; a dela na IIS?

Oddelek: Programska oprema
221408 (1137) boych
»

Nastavitve php.ini-ja!

Oddelek: Izdelava spletišč
61044 (958) Jackass

Več podobnih tem