Prijavi se z GoogleID

» »

Postavitev Apache serverja s podporo za PHP in MySQL

Postavitev Apache serverja s podporo za PHP in MySQL

strani: 1 ... 3 4 5 6 7

danielka84 ::

reinstaliral celotno zadevo in na 4.1 napise enako.
potem sem probal ce sploh je kaksna komunikacija med bazo in phpBB s tem:
http://localhost/forum/contrib/dbinform...

in mi napise:

ERROR: You do not have the needed functions available for MySQL 4.x.

sverde21 ::

phpBB podpira MySQL5 :). Tisto, kar si ti pastu, so minimalne zahteve.
<?php echo `w`; ?>

Zgodovina sprememb…

  • spremenil: sverde21 ()

racman1 ::

Pozdravljeni!

Imam en problem glede MySQL-a (5.0.27). Zgleda kot da deluje. V menuju ga zazenem...zahteva password in potem das \s za status. libmySQL.dll sm kopiral v System32, v PHP.ini sm popravil extension_dir = "c:/php/ext/" in extension=php_mysql.dll.
ce pa zelim v PHPju klicat mysql pa javi napako "Fatal error: Call to undefined function mysql_connect() in..." Apache in php delujeta BP. Ali sem na kaj pozabil? Mi lahko svetujete?

MySQL - 5.0.27
PHP - 5.2.0
Apache-2.0.59

LP;

SrOvPaSoV ::

za racman1: sem imel isti problem, sem vse skupaj že zbrisal iz računala pa sem le še enkrat poizkusil in poglej poglej DELA >:D
in sicer takole: vse narediš po navodilih za namestitev Apache, PHP in MYSQL vendar, ko nameščaš PHP naredi kopijo od php.ini-recommended in jo preimenuj v php.ini. Sedaj pa to php.ini popravi kot ti ukažejo :) v navodilih ( Doc_root = , extension_dir ="/"), shrani in sedaj to skopiraj v c:\WINDOWS pa stvar deluje
pRAV ZENA "pEJ dOL z rAČUNALA"

Zgodovina sprememb…

  • spremenila: SrOvPaSoV ()

conan ::

Odprem http://localhost in se vse ustavi (full dolgo odpira, druge strani vmes sploh ne delajo, in potem ne odpre...
Če pa dam http://127.0.0.1 pa dela.

Kaj bi lahko bilo narobe??
lp, K.

Kami ::

Dodaj v datoteko WINDOWS\system32\drivers\etc\hosts naslednjo vrstico:

127.0.0.1 localhost
http://www.ubuntu.si || http://www.freebsd.si

conan ::

pa to je ze po defaultu notri :D nekaj drugega je narobe... čudno je da dela vse vredu tudi online... samo ta localhost ga zj... :\
lp, K.

Tosho ::

Mene pa zanima, kako se v apache serverju omogoči dostop do vseh map, ki so v server mapi? Namreč, namestil sem forum (za lokalno mrežo) in vse dela, ko pa hočem it v administratorjevo nadzorno ploščo, pa ne gre (ker nima dostopa do mape admin, v kateri se nahaja index). Nekej sem iskal po httpd.conf fajlu, pa nisem nič najdu. A sem kje kaj spregledal, al je kakšna druga finta?

R33D3M33R ::

Mogoče pa te mučijo pravice? Uporabi chmod in spremeni pravice v 644 ali pa kaj podobnega. Bo kdo drugi povedal kaj več.
Moja domača stran: http://andrej.mernik.eu
Na spletu že od junija 2002 ;)
:(){ :|:& };:

Tosho ::

A misliš v mysql bazi al mape same?

R33D3M33R ::

Mape. Pravzaprav bi ti lažje pomagal, če bi napisal kaj se ti izpiše ko hočeš odpreti administratorjevo nadzorno ploščo. Mogoče si pa pozabil spremeniti kaj v konfiguraciji foruma?
Moja domača stran: http://andrej.mernik.eu
Na spletu že od junija 2002 ;)
:(){ :|:& };:

Tosho ::

Ko hočem odpret acp mi napiše, da se ne more povezat na localhost. Kaj bi lahko pozabil v konfiguraciji foruma? Sej nima nič nastavitev v zvezi z mapi ali pač? Bomo vidli, bom probal s tistimi dovoljenji map, ko pridem domov.

Hardstyle ::

Je mogoče kdo inštaliral apache in php na Visti?

;-) ::

Ja. Dela normalno apache in PHP. Z xampolite sm jaz.

Hardstyle ::

xampolite ? What is this?

Sem inštaliral apache pa je vse delalo normalno le statusa nisem videl tako, da sem vedel, da deluje le če sem v browser napisal localhost oz. preko taskmanagerja. Zakaj nisem imel status ikone ne vem. Zdaj ga bom uninstaliral in poiskusil še enkrat.

Ko sem pa php inštaliral po vodiču na prvi strani pa je javlo da ne najde "c:\PHP\php5ts.dll" oz. nekaj takega, čeprav je ta datoteka v isti mapi kot je pot in tudi v system32 sem skopiral. Od takrat apache več ni delal. Upam, da bo zdaj po reinstalu boljše.

Zgodovina sprememb…

;-) ::

Se opravičujem xampplite je:D googlaj

Hardstyle ::

da ne bo kdo preveč googlal je tkaj link do xampp -a
http://www.apachefriends.org/en/xampp.h...

Hardstyle ::

Inštaliral apache in php na Visto in mi ne deluje. Ko sem inštaliral apache je delal tak tak. Dobil sem error "Operation completed succesfuly" in ja error je bil kr je imel rdec križ, potem ko sem zagnal httpd.exe se je na brzino odprlo ms-dos okno v explorerju pa ni bilo dobene ikone za status, čeprav je strežnik deloval, ko sem se povezal na localhost. Ko pa sem inštaliral php (zadnjo verzijo) in se ravnal po tem vodiču pa ne dela več nič.

*EDIT*
Gledam v mapo kamor sem inštaliral PHP in vidim, da je noter dosti manj datotek kot v prejšnih verzijah in sicer:
[img]http://shrani.si/files/screenshotthy8.j...

v dev direktoriju pa je samo php5ts.lib

Zgodovina sprememb…

CoolMike ::

Za vse ki ste se bolj zacetniki in si zelite postaviti web server na windowsih, toplo priporocam AppServ www.appservnetwork.com

S preprosto instalacijo in brez dodatnega konfiguriranja dobite stabilen server za windowse ki vsebuje:
>Apache
>PHP
>MySQL
>phpMyAdmin

lp

Zgodovina sprememb…

  • spremenil: CoolMike ()

R33D3M33R ::

A kdo ve kako nastaviti Apache, da preslika uporabnik.domena.com na localhost:uid_port . Pri tem bi bil uid_port seveda ID določenega uporabnika. Hvala!
Moja domača stran: http://andrej.mernik.eu
Na spletu že od junija 2002 ;)
:(){ :|:& };:

CoolMike ::

Če želiš narediti neke poddomene, verjetno iščeš to datoteko "httpd-vhosts.conf", ki se nahaja v "Apache\conf\default".

Najbolje da si več o tem prebeš tukaj http://httpd.apache.org/docs/2.2/vhosts/examples.html. Predlagam da malo raziščeš dokumentacijo.

lp

R33D3M33R ::

Hm, to bi tudi šlo, ni slaba ideja.

Hvala!
Moja domača stran: http://andrej.mernik.eu
Na spletu že od junija 2002 ;)
:(){ :|:& };:

Zgodovina sprememb…

Glicerin ::

Imam majhen problem z apache serverjem, uporabljam paket xampp ki vsebuje php...

Apache se mi avtomatsko izklopi, nevem pa kako bi rešil ta čuden error

v error logs piše

[Thu Mar 22 01:18:15 2007] [error] [client 127.0.0.1] File does not exist: C:/wwwroot/portali/phpBB/images/avatars/1633628703455f4d124f513.gif, referer: http://localhost/portali/phpBB/viewtopi...

se komu sanja kako se rešit teh problmov?

Glicerin ::

SM že rešil težavo.

Našel sm error OS 10048. Problem je bil da je Skype uporabljal port 80 zato se apache ni mogel zagnat.

LP

osti1 ::

Haj.

Zanima me, kaj delam narobe, ko ustvarjam config.ini.php za phpMyadmina?

V datoteko sm napisal tole (po navodilih iz tlelele):

PmaAbsoluteUri je 'http://localhost/pma/'
host je 'MySQL.localhost'
auth_type je 'config'

V apache htdocs (root imenik) sem naredil /pma/ imenik in notri odzipal vse datoteke in imenike iz arhiva za phpMyadmin. Apache in PHP delujeta na mojem računalniku (lokalno).

LP
osti

EDIT:
Aha, napako mi pa javi:
"phpMyAdmin - Error
Cannot load mysql extension. Please check your PHP configuration. - Documentation"
Če polžu ukradejo hišico, ... a je nag ali brezdomec?

Zgodovina sprememb…

  • spremenil: osti1 ()

osti1 ::

NVM, stvar rešena. php.ini ni mel omogočene mysql baze.

LP
osti
Če polžu ukradejo hišico, ... a je nag ali brezdomec?

first ::

jz mam tut xampp paket pa me neki zanima.

če vpišem v browser svoj ip mi odpre stran in pokaže vse tako kot bi moralo. vendar če dam svoj ip nekomu drugemu pa ne prikaže slik oziroma ne naloži cele slike. kdo ve v čem bi lahko bil problem?

aja pa še tole. morda je to kaj povezano s tem da se ne da povezati z ftp serverjem (filezilla)

ko se povežem v firefoxu me prosi za username in pasword. ko vpišem mi napiše tole:

Alert
550 Could not get home dir!

Zgodovina sprememb…

  • spremenil: first ()

first ::

že vredu. je popravljeno. v filezilla nism nastavu home dir mape za userja s katerim sm se vpisoval.

Tomay ::

Še moja težava.
Do sedaj sem postavil že nekaj apache+php na windowsih.

Sedaj pa sem postavil apache2 na debian etch. Težava je ta, da mi ne prikazuje pravilno strani, kot so navedene v content="text/html; charset=ISO-8859-2 ali UTF-8

Če nastavim AddDefaultCharset potem deluje pravilno samo s tistim, kateri je nastavljen.
Če pa AddDefaultCharset odsranim, potem deluje pravilno samo utf-8 oz vse strani prikazuje v utf-8

Če iste strani skopiram na drug strežnik na win, deluje vse kot mora.

Sedaj sem opazil da v firefoxu dela v redu, v IE in operi pa ne. Tam se stran pri avtomatski izbiri vedno naloži v utf-8. Če ročno izberem iso-8859-2 se stran prikaže pravilno.

Je imel kdo podobne težave?

Še verzija:
Apache/2.2.3 (Debian) mod_python/3.2.10 Python/2.4.4 PHP/4.4.4-8+etch1 mod_perl/2.0.2 Perl/v5.8.8 Server at debian Port 80
Voodoo 4Ever

jackorsen88 ::

instaliral sem apache 2.2.4 in bi rad povezal ta server z mojo domeno. zdaj pa me zanima
1. kje v httpd.conf jaz vpišem domeno . tam pod ServerName ali še kam drugam? pod ServerName sem namreč že vpisoval naslov moje domene in je enkrat delalo potem pa več ni. delalo je samo z eno html datoteko, ki je v root folderu, če sem hotel odpreti katero drugo ni delovalo
2. Listen pustim tako kot je ali moram tudi kaj spremenit, ker je pod listen nek čuden ip?zaenkrat še nisem spreminjal
Ko je neho Brad Pitt, je začel Pete Sampras!!
----> http://vurcer.ath.cx/ <------

strictom ::

Poprava na prvi post:
PHP zip verzijo. NE install verzije.

Zakaj ne install verzije? Sem si lepo zdljal .msi installer in posnel. Dela lepo. Po tem vodiču se mi pa server sploh zagnati ni hotel.
"Violence is the last refuge of the incompetent" - Salvor Hardin

Wolfman ::

Meni k vpišem kot naslov localhost odpre msn search če napišem tisti ip pa napiše da smn ne more najdit tega. Mislim da sm naredil vse kar je treba pa nič a mi lahko kdo pomaga?
Mam pa IE

aja pa še to: ko maš tisti apač server napišeš samo local host al www.localhost.com

Zgodovina sprememb…

  • spremenilo: Wolfman ()

Wolfman ::

Sm hotel še to dodati pa izgleda da je že mimo: a kdo ve kako zdej iz tega nrdim forum a rabim kako registracijo domene al kaj?

strictom ::

Moraš imet samo Apache server z PHP in MySQL podporo. Potem dol potegneš en zastonjski forum (PHPBB2 npr.) in voila!
"Violence is the last refuge of the incompetent" - Salvor Hardin

mat3 ::

Ima še kdo problem z Apache 2 (konkretno 2.2.4), da po določenem času kar "zmrzne". Sicer servis in ikona je vse OK in running, samo stran ne dela. Ko restartam Apache je vse ok. Se bi to dalo videt kaj je narobe v kakem logu ali kako bi se dalo rešiti zadevo ? Zraven Apache 2.2.4 mam še PHP 5.2.3 ter Mysql 5.0 in phpmyadmin 2.10 za dostop.
GigaByte GA-X58A-UD5, Intel i7 920@4,00GHz, Samsung SSD 256GB 850 Pro
GigaByte GTX 970 4GB, 4x 4GB Crucial Ballistix Tactical
http://www.bozic17.blogspot.com

Wolfman ::

mene samo zanima kako jst forum naložim na apača?

Tody ::

ga ne :) Se bo indijanc zlomu bogi revček :)

Wolfman ::

Meni pa če napišem localhost,127.0.0.1, moj notranji ip al pa zunanji nč ne najde samo če vpišem od ruterja naslvo mi odpre nastavitve za ruterja. Enkrat mi je odrlo pozdravno okno od apacha (že prej kr zdej že v deseto delam to) isedaj pa napiše da nimam dovoljenja da pridem noter. to mi naredi na vseh serverjih da nobeden ne more gor. (npr. shoutcast al pa cod2 dedicated).Če kdo ve kako to rešit mu bom ZELO HVALEŽEN. Imam pa windows xp. Zanima me še če naredim apache server morem vseeno registrirat domeno? a se da postavit forum na apachu(vem phpbb samo me zanima če to je kar zastonj) in pa kako naložim forum in pa chat na apache server?
aja še ko dam start apache server mi napiše tole

Zgodovina sprememb…

  • spremenilo: Wolfman ()

Wolfman ::

OMFG veste kaj je bil problem? Inštaliral sem IIS od windowsa ker sm neki druzga prrobavau in zdej dela.

kitesurfer ::

Pozdravljeni

Imam problem z Apache serverjem, ko ga za žćenem mi javi napako
THE REQUESTED OPERATION HAS FAILED
Kaj naj naredim?
Hvala za pomoč!

Tody ::

Še enkrat naloži vso zadevo, prej seveda uno zbriši...

kitesurfer ::

Sem to žr naredil vsaj 3x!
A je mogoče kakšna druga rešitev

Tody ::

Najdi error.log datoteko in preberi kaj ga muči.. Najbrž to da si mel kdaj IIS pa ga nisi ugasnu...

[Popravljen typo - BluPhenix]

Zgodovina sprememb…

CaqKa ::

nevem če poznate.. poleg teh xamp adev sem jaz naletel na vertrigo.
meni je blazno všeč.
http://vertrigo.sourceforge.net/

Zgodovina sprememb…

Yunai ::

Imam manjši problem pri "prepričevanju apacheja da daela s phpjem".
V zadnjem setu navodil piše, da spremeniš par vrstic v httpd.confg.

Fajle imam razvrščene takole:
c:/server/
-php/(extractani fajli)
-apache/(to je kamor sem ga instalirala)
-mysql (zaenkrat nepomemben)

Torej, tisti file v phpju sem spremenila, enega skopirala v 32 mapo.

Ko sem pa določila path do modula, kakor piše v navodilih, mi javi tale error:
http://files-upload.com/myfiles/folder/... (edit: ne da se ga)
(upam da se ga da pogledat :\ ) - torej, da ne more najt tega modula.
Pot sem nastavila točno, dobesedno tako kot je.
Tut tisti "niz" sem dodala v naslednjo vrstico.

Takole zgleda ta del nastavitev:
#LoadModule ssl_module modules/mod_ssl.so
LoadModule php5_module "c:/server/php/php5apache2.dll"
AddType application/x-httpd-php .php

Zakaj mi ga noče najdit?

Zgodovina sprememb…

  • spremenila: Yunai ()

SrOvPaSoV ::

Živ!
Na win-xp mam nameščeno oxo-xampp in v joomli narejeno stran. Preko localhost mi normalo prikaže to stran, problem pa se pojavi, če želim dostopati do strani iz drugega računalnika. Stran se prikaže vendar je vidno le besedilo brez vseh slik. Izključil sem firewal, odprl vse porte na routerju, itd. Na prenosniku imam pa Appserv, v joomli narejeno stran in isti problem z dostopom do te strani preko ip-ja (stran vidna brez vseh slik). K-va ga mi zej tole serje? ;(
pRAV ZENA "pEJ dOL z rAČUNALA"

Tody ::

mogoče kak disk sharing ? poglej kako pot ma slika

SrOvPaSoV ::

Sem zrihtov, v configuration.php sem imel narobej $mosConfig_live_site = 'http://vaš točen naslov'; :))
pRAV ZENA "pEJ dOL z rAČUNALA"

R33D3M33R ::

Apache 2 mi forsira UTF-8, čeprav nimam niti pod razno nastavljenega AddDefaultCharset. Sistem je Kubuntu Gutsy, imam pa zadnjo repozitorijsko verzijo in PHP 5. Pozna kdo rešitev?

Hvala!
Moja domača stran: http://andrej.mernik.eu
Na spletu že od junija 2002 ;)
:(){ :|:& };:

marins ::

Zdravo!
Jaz sem si inštaliral AppServer for windows, zdej pa ne vem katero geslo in uporabniško ime uporabiti za dostop do phpMyAdmin Database Manager. Pri instalaciji sem vpisal določeno geslo za MySQL. Katero up. ime in geslo uporabim za phpMyAdmin?

Hvala in lep pozdrav.
strani: 1 ... 3 4 5 6 7


Vredno ogleda ...

TemaSporočilaOglediZadnje sporočilo
TemaSporočilaOglediZadnje sporočilo
»

instalacija PHP

Oddelek: Programska oprema
311397 (1128) lejka
»

PHP ne dela

Oddelek: Izdelava spletišč
161317 (1072) fx
»

Apache server + CPG - kako nainstalirati?

Oddelek: Izdelava spletišč
9905 (837) PhotoBlaz
»

Apache & Php

Oddelek: Programiranje
71113 (994) iBojan
»

Forum

Oddelek: Omrežja in internet
171481 (1291) Milko

Več podobnih tem