» »

Linux RH7.1 newbie help!

Linux RH7.1 newbie help!

lordgreg ::

stvar je sledeča:

0. rh7.1
1. imam bootable cd (narejen iz isota)
2. v bios: bootable cd-rom: on
3. zazna,... super,.. vpraša za inštalacijo, dam default oz. grafično inštalacijo
4. pol pa po vrsti jezik/tipkovnica...
5. naslednje vprašanje je, kje imam linux lociran, pa mam na izbiro cdrom ali hdd, pa dam cdrom pa mi on pravi, da ne najde in fertik...

prosim za pomoč, pa pazite, sem newbie

hvala

G[e]c ::

Dej pa cdrom v cdr takrat k ti zamori da ga ne najde k pri instalaciji ponavad zmeri poisce prvi cdrom.

lordgreg ::

erm... mam vkloplen samo en cd-rom,.. zaradi drugih potreb. in v tem je linux cd!!!

krucymucy ::

men je isto delal - sploh ni hotel!!!
Pol pa sem pogruntu, da zaradi prevec navitga sistema 8-O

lordgreg ::

krucymucy: kaj si ti res tako zelo nor ali se samo delaš? si bil morda danes predolgo v koruzi? runkl pipo?

trot ::

a se lahko logiraš na kako konzolo pa pogledaš, če je cd sploh mountan, in če je, kje je, pol pa to spremeniš
Ampak verjetno samo cdrom ni mountan, tako da probaj mountat-saj to znaš, ne :)
mala verjetnost, ampak vseeno, da je cd zanič

lordgreg ::

trot: prvič si inštaliram linux na mojo mašino. na faksu je linux že gor, doma pa ne, tako da je to prva inštalacija. to pomeni, da pojma nimam kaj naj. vendar vse dela, vse prepozna le preko tega ne morem.

prosim za odgovore,

hvala

dr.J ::

Kakšna je konfiguracija tvojega računalnika? Mislim na ploščo (model), disk kontrolerji (a je IDE RAID), katere enote imaš (ZIP,CD,DVD,etc.).
Če je ide disk priklopljen na raid kontroler, potem ne bo šlo.

krucymucy ::

SE eno tako prbi:!!! Kako si naj drugace razlagam , da pri 133x7,5 ne morem instalirat, ker ne najde CD-roma8-O
Pri 133x7 pa vse lepo dela - pa sploh ni vazno kaj instaliram ali Winse ali Linux!!!

lordgreg ::

krucy: daj ne teži

okej..., zadeva je sledeča.. imam samo(?) 1 CD rh7.1. pač sem si zato nabavil, ker mi ni delal, več drugih distribucij: turbo, suse,.. pa sem probal obedve... sedaj pa poslušajte sledečo finto:

1. imam amd duron 700, 128mbram, kinetiz mb IN WIN2K. s sošolcem sva probala oboje.. tukaj zadeva mrkne drugje. vse okej, naredim vse možne načine bootanja, ali na primary disk lilo ali pa z floppy-jem. v vseh primerih, ko se rač. resetira namesto, da bi mi vrglo menu, z izbiro sistema, mi začne izpisovat ničle in enice???? kako to??? potem sva probala inštalirat na drug disk in izključila primarnega (kjer je win2k) pa ni nič boljše.

prosim pomočč...

AlienRex ::

Sicer nisem strucko za Linux:
- si preveril ce je tvoj HW kompatibilen z distibucijo (CDROM, disk, vodilo, ...)

Za zacetnike je najbolj priporocljiva ditribucija Mandrake (je Redhat in se malo zraven) Link je tukaj pa se HW compatibility list za Mandrake

lordgreg ::

hja... glede na to, da smo zadevo sprobali na dveh (kolikor je možno) mašinah, kjer so nameščeni win2k, na enem je to delalo, ko ni bilo tam w2k-jev me malo čudi.

je pa še ena stvar, ki sem pravkar ugotovil. disk, na katerega poskušam naložiti linux ima bad sectorje. je morda to vzrok za neinštalacijo in zajebancijo?

lordgreg ::

pa še nekaj. hotel sem namestiti tudi mandrake iz neke zgoščenke, ki je bila zraven software power revije. ampak kako, ko pa na cdju ni nič drugega, kot fileti s končnico RPM?????

AlienRex ::

WIN 2k nalozeni na disku? FAT32 ali NTFS? Mas kaj prostora na disku (po navadi rabis dve particiji ena za swap, eno za sistem).

RPM bi naj blo Redhat Package Manager. Zadeve so razdeljene po paketih (RPM), ko npr da bi za WIN ime EXE za nalozit DIAL-up, drug za Notepad, tretji za TCPIP in podobno.
Kot receno nisem strucko, preberi si malo na lugos.si ali linux.com (ali kaj podobnega).
Tole pa se posebej navodila za instalacijo

lordgreg ::

hja.. imam dva diska po 4gb

1. disk je zaznamovan kot C in D (2 part.), na katerem je win2k in je fat32.

2. je trenutno prazen in ima bad sectorje. ne glede na to, ali je 1. disk vključen mi po katerikoli inštalaciji linuxa na 2. disk po rebootanju piše ničle in enice...

je morda to zaradi bad sectorjev???

PaJo ::

Hm. zaradi bad sektoraj ti nebi smel komplicirat:(

Sicer pa sem jaz linux instaliral na masino, ker sem prej mel gor ze win2k in winxp, pa se zraven sem na eno particijo pritisnil linux in je stvar spila cisto ok, pa imam v masini 3 cdrome, pa disk pripan na RAID kontroler. Sicer pa sem opazil da iz tistega cd-roma iz katerega bootas iz tistega moras potem instalirat, ce pa gre kaj narobe, pa je lahko kriv cd-rom da slabo bere ali pa da masina ni dovolj stabilna;( Probaj za foro masini malo deklokat, mogoce bo potle slo:\

Drugace pa tisti bad block nebi smel bit blem, ker tebi se ustavi instalacija tam kjer ti zacne instalacijske fajle iz cd-ja dol brat.
Ne se preveč sekirat, rajši uživat:)

lordgreg ::

pajo.. že res.. vse lepo in prav... kako deklokat, kako to misliš? poglej, finta je tudi sledeča:

sošolec na svoji mašini ni nikoli imel win2k, pa mu je vedno šlon vredu linux katerekoli distr. gor dat. ko pa je dal win2k gor, nato pa na ta disk, z bad sec. probal dat linux, je inšatalacija stekla (turbo, suse) popolnoma tako kot mora, ko pa se računalniik prvič reboota, takrat tudi njemu meče ničle in enice

dr.J ::

Čudno se obnaša tvoj comp. Za tako težavo še nisem slišal. Mogoče je nekaj na tem, da imaš dva diska in da ne inštaliraš na prvega. Preberi si naslednje:
http://www.mail-archive.com/lugos-list%...
http://www.linuxdoc.org/HOWTO/mini/LILO...

RedHat 7.1 obsega dva Inštalacijska CDja; večina stvari je na prvem. ISO datoteke dobiš na arnesovem ftp strežniku.
Linux particije / in swap vedno ustvari na novo in jih predhodno formatiraj. Čigava pa je tista kinetiz plata? Točno kateri model? QDI? :\

PaJo ::

Se parvi da mu pri zagonu ven vrze nicel in enice??

Ja tu pa ni blem linuxa, tu pa moras lilo prav nastavit, se pravi da ni lilo loader vredu ustiman, se pravi ali da mas prevelik disk(vec kod 8GB) ali pa niso prav kazalci nastvljeni kje se nahaja jedro. Se pravi da ti za zacetek priporocam da si namesto na disk naredisl boot disketo in iz nje zaganjas sitem namesto iz diska, ker ko instaliras vso stvar polek win2k moras malo zmodificirat lilo da ti dela, samo to pa niso vec zacetniske lahke naloge, zato priporocam da raje naredis boot disketo, kod pa da instaliras lilo loadar na disk. Drugace pa odsurfaj na www.linuxdoc.org in si preberi par HowTo-jev:D
Ne se preveč sekirat, rajši uživat:)

lordgreg ::

lilo ne more bit narobe zmodificiran. tudi če disk, kjer je win2k popolnoma izključim, tako da imam samo prazen disk, meče nule in enke. tudi če naredim boot iz diskete vrže nule in enke. včeraj sem hotel formatirat ta disk, na katerem želim linux in kaj je bilo: pride do 70% dalje pa ne. je možno to kako odpraviti?

hvala

DeViCeD ::

Poglej kam imas priklopljen disk ... pomoje je pac LILO conf zjeb*n ... verjetno kaze na /dev/hda, ti mas pa disk na sekundarnem IDE-ju al karkoli imas, in je potem kernel na recimo /dev/hdb ali celo /dev/hdc ... SlackWare (Mogoce tudi drugi ...) ma dobro funkcijo, das notri bootable CD, in mu poves kje je root (nevem sintaxe napamet) in lepo prebere kernel in dela. Potem pa popravis LILO. Jest sem mel s tem probleme pri SlackWare 7.x ko sem dajal na sekundarni disk ... pac, LILO-tu ni potegnil .. .:-)
Drugac je pa lahko problem pac z Win2k, ker imajo tud svoj loader na MBR ... fdisk /MBR (pazi! :-))
LP,
Dejan
So, if I press C, E and G I play C?

dr.J ::

V Lilo howtoju vse piše
.
Sicer pa daj W2k disk ven, pa naj bo trenutno drugi disk edini in poskusi inštalirati znova.

lordgreg ::

zaj pa ne vem.. najbolje, da še vsi enkrat preberete moja sporočila v tej temi, saj sem lepo napisal, katere metode sem že poskusil in kaj delajo...

dr J: tudi to sem poskusil in rezultat je enak prejšnjim poskusom, kar pomeni, da ne zafrkava LILO, ni tako?

sedaj pa mi naj resnično kdo pove, kako sformatirati disk, saj sem poskusil iz winsov in dosa pa se ustavi na cca 70% in ne gre dalje. jaz bi rekel da tiči zajec tukaj. ne vem, zakaj vsi napeljujete na nekompatibilnost in lilota? ko bi le imel še kak drug disk, na katerem bi lahko to posksil...

dr.J ::

LORDGreg, tudi ti ne bereš postov. Dvakrat sem te vprašal po TOČNEM opisu HWja, zlasti osnovne plošče in disk kontrolerjev na njej , pa nič. In potem bi rad takoj imel pravilen odgovor.

Če ti disk sformatira do 70%, pač naredi manjše particije, npr. 1.5 GB za / in vsaj toliko MB za swap kot imaš RAMa v sistemu. Tako da bo badblock na neuporabljenem delu diska.

lordgreg ::

moje hw specifikacije so take (J, sorry):

amd duron700
128mbram
mb qdi kinetiz 7b

2 diska,
1. nevemčigav (w2k) običen 4gb, vem samo da so prenosi dma (sem prav rekel, nisem namreč tak hardware freak),
2. quantum bigfoot (željen linuxa) 4gb, 5.25 inčni..

druga nimam v kišti nič takega, da se linux ne bi mogel sporazumeti z opremo. vse laufa, vse špila.

torej, J, kako naj si razporedim particije? običajno si samo dve naredim, 1. ima 3.8gb, druga pa 200mb

hvala še enkrat

dr.J ::

No, a je bilo težko? Hmm, nič nenavadnega ni s tvojo plato. Če se prav spomnim, so nekje v kernelu 2.4.3 odpravili neke težave z VIA ATA-100 disk kontrolerjem. Jaz bi na tvojem mestu vzel eno linux distribucijo, ki ima 2.4.3 kernel ali novejši. To je npr. mandrake 8.0, SuSE 7.2, redhat 7.2beta oziroma modificiran RH7.1 s strani SGIja. Zloži si ISO datoteko s tegale naslova: http://oss.sgi.com/projects/xfs/1.0_ins...
, narediš boot disk in to je to. Zraven rabiš še RH7.1 CDje.

Na tvojem mestu bi iz mašine fizično vzel ven prvi disk in na njegovo mesto priklopil quantuma (pazi na master/slave jumperje) ter znova poskusil inštalirati linux.

lordgreg ::

vsem kar si rekel sem naredil.

- vzel fizično 1. disk ven,
- hotel gor-dat mandrake 8 in suse 7,
- proč vreči disk (pa se mi je zasmilil)

to je to.. nič ne pomaga... nič... ueeueueueue

dr.J ::

Zdaj pa nimam več idej. Lahko je disk fuč, lahko je plata fuč. Kaj pa BIOS? Sem gledal po googlu, pa se nihče ne pritožuje nad to ploščo. Sposodi si en disk, da vidiš, če je to vzrok.

lordgreg ::

haljo folx..

pravkar sem odkril kaj je bil vzrok!!! DISK in njegovi bad sectorji.

zadeva je bila taka, da se je dalo ok sformatirat do 61%, dalje ni šlo. zato sem naredil particije.. aja.. bad sector je pa tako zjebal disk, da je v bistvu 3gb oz natančneje 2.6gb vredu. jebat ga.. sedaj veste kaj je narobe, če vam začne izpisovati ničle in enice.

hvala vsem, ki ste mi pomagali, hvala drJ, da si mi priporočal sparticionirati disk tako, da je ena particija bad sectorjev.. bolje ni moglo bit :)... nekaj pa vseeno je..

še enkrat hvala vsem!!!

rabbit_zek ::

Ne skrbi Lord boma se potrudila da bo to delovalo ... sicer ne vem še kdaj ampak kmalu Čuj na disk sem vredi naložil W98 deluje super in ker so win prani presenetljivo hitro in stabilno noja... glede TV tunerja pa ($//#$()#/"$()/#")$/#") NULAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAtak, ali ti ga je oni guzi vničo ali pa to samo meni ne dela ali pa nevem inštalirat!!! N oja odgovor mi pošlji n mail Ali pa se itak čujema jutri kak češ nekje do 00.00 še sem gor tako da pohiti!!!!;((
THE MORE I STUDY, THE MORE I KNOW!
THE MORE I KNOW, THE MORE I FORGET!
THE MORE I FORGET, THE LESS I KNOW!
                 SO WHY STUDY???
                --:[ Rabbit-zek ]:--

lordgreg ::

erm... prepozno :( ;)

lordgreg ::

okej... hvala bogu, nič več enic in ničel. sedaj je finta drugje.

potem, ko uspešno inštaliram linux in bi mi moralo pokazati, kateri sistem želim uporabljati, tega ne naredi, računalnik malček zahrešči, nakar se spet takoj vključijo okna (win2k)...

ve kdo, zakaj tole?

krucymucy ::

A si dal LiLO-ta na MBR (master boot record) oz. na c:\

lordgreg ::

dal sem ga na MBR in floppy. vse sem probal,.. resnično vse

Ales ::

Če ti po eni sekundi izbere win2000, je to čisto normalno... LILO po defaultu ne pokaže izbire med obstoječimi sistemi temveč tistega pod default izbere kar sam in gre dalje. In izbere ga *zelo* hitro.

Fora je v tem, da si nastaviš za default linux oziroma vsakič ustaviš LILO ob pravem času in izbereš kateri sistem hočeš...

lp,
Aleš

lordgreg ::

ja kdaj in kako? če si naredim lilo oz boot disketo je v oknih sploh ne prebere, kot da je pokvarjena, če pa kaj na disk dam pa ne najdem,.. torej,.. kje to urediti oz kaj sploh urediti?

simon ::

V redhatovem kontrol panelu imas gui program za nastavljanje lilota. lahko pa na roke popravis datoteko /etc/lilo.conf. Tam si najprej povecaj timeout. potem napises v ukazni: lilo -v
Domnevam da lahko dvignes sistem z diskete? Ce ne bootaj s instalacijskega cd-ja in natipkaj linux rescue

lordgreg ::

ampak še vedno ne razumem, zakaj? nikjer se nihče ne pritožuje nad tem, vse bi moralo bit lepo naštimano, ne pa, da mi jebe... grrrr... kako sovražim to..

Ales ::

Tvoj problem je v tem, da se ti je na kup spravlo enih par težav, ki se medsebojno zapletajo. Zato ti zgleda, kot da nič ne dela...

- najvažneje: točno opiši, kaj si imel v računalniku za eno diskovje/winse ko si inštaliral linux. V tem je namreč fora, da ti LILO ne dela prav.

Si imel disk z win2000 v računalniku ali ne? Skratka, si mel med inštalacijo kakokoli drugače poštiman vrstni red diskov oz. operacijkih sistemov, kot ga imaš zdaj?

- ne prebere ti linux boot disketo: ja, kaj pa maš nastavljeno v BIOSu kot vrstni red bootanja? Če je 1. flopica, potem nekaj z disketo, oz LILOm na njej, ni v redu. Boot namreč nima veze z windowsi, z linux diskete se ti mora bootat tudi če maš na disku DOS 3.3

lp,
Aleš

lordgreg ::

moja specifikacija pred inštalacijo je bila naslednja:

2 diska, 1. ne vem firme, 4gb 2particiji prva part. win2k, druga razno programje,.. to je torej 1. disk.
2. disk je quantum bigfoot 5.25palčni, ta ima v sredini bad sector, zaradi česar je metalo prej nule in enke. sedaj temu več ni tako. naredil sem 3 particije. 1=2.5gb okej, 2=5mb bad sector, 3=1gb okej.

spet sem inštaliral linux. enkrat sem dal za oni lilo na floppy disk (v biosu spremetal vse), drugič na MBR.. v obeh primerih ko se računalnik zboota, najprej malček (1 sekunda) počaka, nato spet kar skoči na win2k, brez da bi kaj pokazalo možnost izbiranja sistema.

pa še to: 1. disk z w2k-jem je primary master, drugi pa primary slave... tudi tu sem že vse kable zamenjal,.. tudi prvi disk (win2k) sem ven vzel ko sem bootal iz diskete ali kakorkoli... no,.. v nobenem primeru ni delalo.

kaj pa sedaj?


Vredno ogleda ...

TemaSporočilaOglediZadnje sporočilo
TemaSporočilaOglediZadnje sporočilo
»

winXP in Linux (najboljsi nacin za zdruzitev?)

Oddelek: Operacijski sistemi
231521 (1249) dr.J
»

mount ntfs ?? (win2k particija v linuxu)

Oddelek: Operacijski sistemi
201275 (983) tico
»

LINUX HELP!!!!

Oddelek: Pomoč in nasveti
161064 (928) G[e]c
»

HOW TO: Poleg WIN2k se RedHat?

Oddelek: Operacijski sistemi
201644 (1470) twosocks
»

Particije in Linux

Oddelek: Operacijski sistemi
191454 (1256) kuntek

Več podobnih tem