» »

[Suse 9.2] Prosim za pomoč pri inštalaciji GAIM

[Suse 9.2] Prosim za pomoč pri inštalaciji GAIM

Jst ::

Torej, iz gaim.sourceforge.net sem si dl gaim-1.1.1.tar.bz2. Odpakiral v eno mapo. Nato zagnal "configure". In mi javi 2 errorja:


checking for pkg-config... (cached) no
checking for GLIB - version >= 2.0.0... no
*** A new enough version of pkg-config was not found.
*** See http://www.freedesktop.org/software/pkg...
configure: error:
*** GLib 2.0 is required to build Gaim; please make sure you have the GLib
*** development headers installed. The latest version of GLib is
*** always available at http://www.gtk.org/.


1.
pkg-config. Kaj je to. Zakaj se uporablja.

Odprem YAST, vpišem pkg, nato mi najde na CD4. Jaz pustim YAST-u da inštalira. (sam itak najbrž ne bi znal:). Zaženem še enkrat:


checking for GLIB - version >= 2.0.0... no
*** Could not run GLIB test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GLIB is incorrectly installed.
configure: error:
*** GLib 2.0 is required to build Gaim; please make sure you have the GLib
*** development headers installed. The latest version of GLib is
*** always available at http://www.gtk.org/


2.
GLIB. Spet odprem YAST, vpišem GLIB in mi najde, da tole zadevo že imam inštalirano. In sicer 2.4.6-5.


Prosim za pomoč.
Islam is not about "I'm right, you're wrong," but "I'm right, you're dead!"
-Wole Soyinka, Literature Nobelist
|-|-|-|-|Proton decay is a tax on existence.|-|-|-|-|

Jst ::

Najbrž mi manjkajo environment spremenljivke oz. path.

Kje in kako uporabljati tole v linuxu oz. v Suse, če so kakšne posebnosti.
Islam is not about "I'm right, you're wrong," but "I'm right, you're dead!"
-Wole Soyinka, Literature Nobelist
|-|-|-|-|Proton decay is a tax on existence.|-|-|-|-|

HriBB ::

Zakaj ga pa ne namestiš z YaST ali apt-get??
jaja

Jst ::

Read again.

To imam nameščeno. Najbrž že pri inštalaciji sistema. Vsaj tako pravi YAST.

Mene pa zanima, kaj moram naredili, da bi GAIM confugre skapiral, da jaz to imam. Oziroma kje imam.
Islam is not about "I'm right, you're wrong," but "I'm right, you're dead!"
-Wole Soyinka, Literature Nobelist
|-|-|-|-|Proton decay is a tax on existence.|-|-|-|-|

HriBB ::

Drugač maš na cdju 2 gaim-0.82.1-3.i586.rpm ki ga lahko namestiš prek yast -> install and remove software -> išči "gaim" -> obkljukaj -> accept (verjetno ti bo še dodaten software namestilo).

Če hočeš kompajlat najprej prever za glib2+ in pkgconfig
> rpmquery -a | grep glib
glib2-devel-2.4.6-5
glibc-2.3.3-118
glib2-2.4.6-5
glibc-locale-2.3.3-118
glib-1.2.10-589
glibc-devel-2.3.3-118
taglib-1.3-4
> rpmquery -a | grep pkgconfig
pkgconfig-0.15.0-199

Potem bi mogu ./configure delat razen če ti še kej ne manjka. Predlagam ti da probaš source .rpm namestit.
jaja

kyuuzou ::

pkg-config se uporablja za podajanja poti include/lib poti, npr za glib:
pkg-config --cflags --libs glib

Pomoje je narobe oziroma moraš reinštalirat glib2, ker si pkg-config namestil kasneje. Pa potem poizkusi namestit gaim. Ker ni kreiran v /usr/lib/pkgconfig .pc filet za glib za pkg-config in ta neve za glib (lahko bi ga tudi sam naredil, več v man pkg-config). Ali pa mogoče res nimaš nameščenga glib2 (ti praviš da ga imaš).

lp

Zgodovina sprememb…

  • spremenilo: kyuuzou ()

Ferplay ::

Zdravo

Pejt v YAST izberi dodaj/odstrani programe v iskanje vpiši GAIM in ti bo vrglo ven en rezultat od gaim in to je to.

Lahko pa greš tudi gledat po paketkih nahaja pa se v

Produkcija/Omrežja/AOLInstantMessenger

Ko ti bo vse namestilo poženi posodobitev. Če bo našlo novo verzijo potem je to to in jo namestiš če pa je najde pač je ta trenutna najboljša ki dela na SuSe -tu. Verzije ki so čisto nove in jih SuSe ne namesti oz. jih ni na voljo za posodobitev lahko delajo ali pa tudi ne.

Lp
--------------------------------------------------------------------------
Človeško se je motiti, neumno pa je vztrajati v napaki

Jst ::

Edini, ki je kaj pametnega povedal, je kyuuzou. Bom probal.

Ostali pa, ali ne berete dovolj pozorno, ali pa samo nabijate poste.
Islam is not about "I'm right, you're wrong," but "I'm right, you're dead!"
-Wole Soyinka, Literature Nobelist
|-|-|-|-|Proton decay is a tax on existence.|-|-|-|-|


Vredno ogleda ...

TemaSporočilaOglediZadnje sporočilo
TemaSporočilaOglediZadnje sporočilo
»

Izšel GIMP 2.8 (strani: 1 2 )

Oddelek: Novice / Pisarniški paketi
7114063 (9778) LuiIII
»

Linux - gtk/gtk.h

Oddelek: Operacijski sistemi
5975 (821) bibbos
»

Neukrotljivi PKG_CONFIG_PATH

Oddelek: Operacijski sistemi
5786 (716) G-man
»

Gentoo Linux & nov KDE problem!

Oddelek: Pomoč in nasveti
10964 (904) Tarzan
»

Problem z instalacijo fontconfig v Linux-u

Oddelek: Operacijski sistemi
7735 (685) Poldi112

Več podobnih tem