» »

Gentoo Linux & nov KDE problem!

Gentoo Linux & nov KDE problem!

Tarzan ::

Pozdravljeni Gentoojevci na Slo-Techu!

Poskusil sem posneti KDE 3.3.0, pa se mi vedno ustavi pri kdemultimedia-3.3.0.
Če imam v USE flagih označeno, da uporablja KDE ARTS, potem mi javi naslednjo napako.

xp -pipe -fomit-frame-pointer -fno-exceptions -fno-check-new -fno-common -DQT_CLEAN_NAMESPACE -DQT_NO_ASCII_CAST -DQT_NO_STL -DQT_NO_COMPAT -DQT_NO_TRANSLATION -c -o synth_xfade_impl.lo synth_xfade_impl.cc
synth_xfade_impl.cc:23:30: artsmodulessynth.h: No such file or directory
/bin/sh ../../../libtool --silent --mode=compile --tag=CXX g++ -DHAVE_CONFIG_H -I. -I. -I../../.. -I../../../arts/modules -I../../../arts/modules -I../../../arts/gui/common -I../../../arts/midi -I../../../arts/runtime -I/usr/kde/3.3/include/arts -I/usr/kde/3.3/include/artsc -pthread -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/kde/3.3/include -I/usr/qt/3/include -I/usr/X11R6/include -DQT_THREAD_SUPPORT -D_REENTRANT -DNDEBUG -DNO_DEBUG -O2 -O2 -march=athlon-xp -pipe -fomit-frame-pointer -fno-exceptions -fno-check-new -fno-common -DQT_CLEAN_NAMESPACE -DQT_NO_ASCII_CAST -DQT_NO_STL -DQT_NO_COMPAT -DQT_NO_TRANSLATION -c -o synth_autopanner_impl.lo synth_autopanner_impl.cc
synth_xfade_impl.cc:28: error: parse error before `,' token
synth_xfade_impl.cc:36: error: `samples' was not declared in this scope
synth_xfade_impl.cc:36: error: parse error before `;' token
synth_xfade_impl.cc:36: error: syntax error before `++' token
synth_xfade_impl.cc:40: error: `i' was not declared in this scope
synth_xfade_impl.cc:40: error: ISO C++ forbids declaration of `outvalue' with
no type
synth_xfade_impl.cc:40: error: `invalue1' was not declared in this scope
synth_xfade_impl.cc:40: error: `i' was not declared in this scope
synth_xfade_impl.cc:40: error: `p' was not declared in this scope
synth_xfade_impl.cc:40: error: `invalue2' was not declared in this scope
synth_xfade_impl.cc:40: error: `i' was not declared in this scope
synth_xfade_impl.cc:40: error: `p' was not declared in this scope
synth_xfade_impl.cc:40: error: assignment (not initialization) in declaration
synth_xfade_impl.cc:41: error: parse error before `}' token
synth_xfade_impl.cc: In member function `virtual std::string
Synth_XFADE_impl_Factory::interfaceName()':
synth_xfade_impl.cc:45: error: incomplete type 'Synth_XFADE_impl' cannot be
used to name a scope
synth_xfade_impl.cc: In member function `virtual Arts::Object_skel*
Synth_XFADE_impl_Factory::createInstance()':
synth_xfade_impl.cc:45: error: invalid use of undefined type `class
Synth_XFADE_impl'
synth_xfade_impl.cc:28: error: forward declaration of `class Synth_XFADE_impl'
make[4]: *** [synth_xfade_impl.lo] Error 1
make[4]: *** Waiting for unfinished jobs....
make[4]: Leaving directory `/var/tmp/portage/kdemultimedia-3.3.0/work/kdemultimedia-3.3.0/arts/modules/synth'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/var/tmp/portage/kdemultimedia-3.3.0/work/kdemultimedia-3.3.0/arts/modules'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/kdemultimedia-3.3.0/work/kdemultimedia-3.3.0/arts'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/kdemultimedia-3.3.0/work/kdemultimedia-3.3.0'
make: *** [all] Error 2

!!! ERROR: kde-base/kdemultimedia-3.3.0 failed.
!!! Function kde_src_compile, Line 130, Exitcode 2
!!! died running emake, kde_src_compile:make


Če arts odstranim, potem mi zadevo normalno skompajla, ampak je KDE za v koš, ker mi na vsakih nekaj minut pokaže napako.

Na gentoo forum tega ne morem dati, ker je trenutno nedosegljiv.
Kaj mi je storiti :S

Jure

BigWhale ::

Pokazi se vse druge USE flage..
Morda je kaj drugega problem.. Zelo verjetno ti kak include manjka... Samo bi se moralo emergat vse skupaj...

Tarzan ::

USE="3dnow gphoto2 alsa arts cdr encode gtk2 -ipv6 java kde qt -gnome mmx oggvorbis opengl pdflib samba sse truetype usb X x86 -ldap -cups ooo-kde"

mile ::

danes sem naredu upgrejd s temi flegi

mmx mmx2 3dnow imlib matroska png nls xv truetype cups X qt kde alsa dvd dvdr oggvorbis samba xmms lm_sensors ogg -gnome -gtk2 -gtk gstreamer xine

brez problemov do sedaj

Tarzan ::

Ne, ne pomaga nič. Sem dodal še tiste, ki bi lahko imeli vpliv na to, odstranil sem arts (če dam -arts deluje, vendar FUJ!).

Tarzan ::

Kakšne pa imate nastavitve CFLAGS? Morda imam tu kaj narobe nastavljeno, čeprav se mi zdi, da bi moralo delati BP, ker vse drugo skompajla brez predsodkov.

CFLAGS="-O2 -march=athlon-xp -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"

Barton 2600+ in nForce2 plata, če koga zanima.

BigWhale ::

Hm, jaz imam isto... more or less samo da -O3 ;> Ista tudi konfiguracija...

Naredi reemerge arts serverja....

Tarzan ::

Sem že probal...

Tarzan ::

odstranil sem pa že tudi "-pipe" in "-fomit-frame-pointer" flaga, pa ni pomagalo.
Zdaj bom poskusil še z "-O3", morda bo več sreče. :'(
- no, tudi to ne dela.

Zgodovina sprememb…

  • spremenil: Tarzan ()

BigWhale ::

Gentoo forum kaj pravi na to temo? Ker afaik, je do zdaj se vsem delalo...

Tarzan ::

Saaj to mi je čudno. Nikjer nisem opazil, da bi še kdo imel enak problem. Sem pa dal na gentoo forum. Upam, da bo uspelo, če ne, bom moral nekako nazaj na 3.2


Vredno ogleda ...

TemaSporočilaOglediZadnje sporočilo
TemaSporočilaOglediZadnje sporočilo
»

Pomoč C++

Oddelek: Pomoč in nasveti
71092 (811) samo111
»

[C++ & Linux & G++ prevljalnik]Kako dodati knjižnico?

Oddelek: Programiranje
91026 (1026) balocom
»

[C] MySQL

Oddelek: Programiranje
292531 (1553) Tutankhamun
»

K3B problem

Oddelek: Operacijski sistemi
71098 (976) theD3viL-
»

nVidia nForce2 under Linux

Oddelek: Operacijski sistemi
8937 (857) BigWhale

Več podobnih tem