» »

Pinganje SWITCHa - oz.ali je ta kriv za probleme

Pinganje SWITCHa - oz.ali je ta kriv za probleme

Joze_K ::

Lp,
imam notranjo mrežo na vhodu je Linksys EA4200, po hiši gre nekaj linij, ena tudi do TV omarice, kjer se pa notri skrivajo še SERVER, KODI Android player, STEAM player, itd... Zato sem tole eno linijo v omarici razdelil z switchem TP-LINK 1005D.
Zadeva je delovala normalno - sedaj pa KODI noče predvajati filmov - iz SERVERja preko tega switcha. Zelo počasi naloži, film se premika kot diapozitivi (tudi z minutnimi razmaki).
Če gledam filme preko računualnika mi jih normalno predvaja - torej linija SERVER - SWITCH - ROUTER - PC deluje popolnoma normalno.
Kadar pa predvajam preko znotraj SWITCH mreže pa ne deluje.
Predvidevam da me torej tale zaj...a.

Poskusil sem pingati switch (nisem ravno doma v mrežah) vendar ping IPja switcha ne vrne rezultata (request timed out), kadar pa iz zunanje mreže pingam enega od naprav znotraj switch mreže pa dobim rezultat.

Sklepam torej da pinganje switcha ne deluje.

Kako torej ugotoviti kaj je narobe (je pa tak sistem dolgo deloval povsem brez problemov)?
PS: upam, da sem bil razumljiv....

hvala, J

Joze_K ::

tracert IPja switcha gre preko 30 poskusov - request timed out

tracert SERVERJA ki je izza switcha pa daje manjše 1ms


hm, kako ugotoviti zakaj interno znotraj switch mreže zadeva ne deluje....

Spc ::

Switch-a ne moreš pingat ker je to Layer 2 switch in ne Layer 3.
Povrhu pa je samo 100mbit/s.
Telemach is a land of confusion in Slo-tech je podkupljen iz strani ProPlus-a.
https://tinyurl.com/lr8hydo

Joze_K ::

Kako rešit pol problem nedelovanju znotraj switch kroga?

rokp ::

Ce se s PCjem priklopis na SWITCH, ti tudi deluje pocasi?
Ce imas na KODI Android predvajalniku lokalno shranjeno datoteko (USB kljuc/disk,...), ti dela OK?
Ce oboje dela OK, preveri hitrost (10 Mbps / 100 Mbps) in duplex (full / half) povezave na KODI predvajalniku oziroma ustreznem switch portu (kako to preveris na tvoji konkretni opremi, nimam pojma).

TOP ::

Kaj imaš Switch ali hub malo poglej.

Spc ::

Nariši nam topologijo kako imaš to povezano vseskupaj.
Telemach is a land of confusion in Slo-tech je podkupljen iz strani ProPlus-a.
https://tinyurl.com/lr8hydo

Joze_K ::

 hišna mreža

hišna mreža



predvajanje filmov preko KODI-ja je delovalo BP dosedaj. Sem pa zadnje čase opažal, da po tem ko je server šel v spanje, in sem ga nazaj zbudil se ga ni videlo preko mreže, dokler nisem mrežo resetiral (izklop napajanja pri TP-LINKu pri serverju)...
sedaj pa kot pravim popolnoma zmrzuje.

Predvajanje filmov preko ethernet mreže TVja - nikoli nisem preveč uporabljal (oz. sem imel nameščen PLEX Media server - vendar tza sedaj ni nameščem, je pa nameščena UPNP2 oprema... vendar je nikoli nisem testiral) - tako, da nisem siguren če je tu sploh vse ok nastavljeno

PC gledanje filmov na monitorju PCja deluje popolnoma tekoče

po moje tale mrežni nekaj šteka... kako stestirati oz. popraviti

Zgodovina sprememb…

  • spremenil: Joze_K ()

aerie ::

Dude... zamenjaj switcha z gigabitnima (npr. s takim), pa ne kompliciraj.

darkolord ::

Saj sta giga, sodeč po sliki?

Joze_K ::

aerie je izjavil:

Dude... zamenjaj switcha z gigabitnima (npr. s takim), pa ne kompliciraj.


ja DUDE, oba sta giga switcha... in pa nisi bral... zadeva je že kaki dve leti delovala brez problemov, sedaj se nekaj dogaja...

darkolord ::

Kako je na sliki, iz gleda vse OK. Tej switchi nimajo IP-ja, tako da je OK, da jih ne moreš pingati.

Od kod je povezana zelena linija?

Imaš vse IP-je v istem območju (npr. 192.168.X.Y)?

Lahko iz serverja pingaš KODI?

Joze_K ::

@darklord

zelena linija - napaka - res ne gre iz EA4200 ampak gre iz SIOL modema PROSPERO 632+ (sorry - v glavnem je to IP TV dedicated line) - ampak ta ne vpliva

vsi IP ji so v istem območju - samo zadnja tri mesta (za zadnjo piko) so spremenjena med njimi... imajo celo fiksno nastavljene IPje, da jih DHCP ne zmede...

kako naj iz serverja pingam KODI ? Server je Asustor AS302T - do njega dostopam preko PCja - na IPju serverja se mi zažene program z AS aplikacijami... ne vem kje naj pingam KODI?

Je pa zanimivo, da gre preko SWITCHa tudi promet na PC - in to dela tekoče... preko SWITCHa na KODI pa popolnoma zmrzne (četudi je dolgočasa lepo delalo, ampak kot sem napisal zadnji čas po prihodu iz standby serverja sem moral switch resetirat, da so se spet videli)

madona, kak nimam mrež rad....

Joze_K ::

PRAVA SLIKA
 HIŠNA MREŽA

HIŠNA MREŽA

darkolord ::

Lahko probaš zamenjati kable? Npr. kabel od tiskalnika (ali en, ki sigurno deluje) uporabiš za kodija, pa poskusiš, če je kaj bolje.

Če to ne bo ok, iz switcha izklopi vse razen kodija in serverja in poskusi ponovno.

Spc ::

Joze_K je izjavil:

TP-LINK 1005D


TL 1005D je 100mbit/s:
http://uk.tp-link.com/products/details/...

Imaš sedaj 1GbE ali 100mbit/s ?
Telemach is a land of confusion in Slo-tech je podkupljen iz strani ProPlus-a.
https://tinyurl.com/lr8hydo

darkolord ::

Na sliki je narisan SG1005D

Joze_K ::

SG sta oba... na obeh piše Giga...

@darklord...
zamenjeval kable ... isto
osamil povezavo le na server in kodi... zmrzne...
nastavil povezavo na server in TV (v App našel UPnP2 - mi prikaže server strukturo, izberem direktorij s filmi, ga zaženem, se pokaže predvajalni sistem s kontrolami... potem pa nič)

sedaj ko sem izklapljal in vklapljal kable, mi pa PC ne vidi mreže, vendar ko grem z brskalnikom na IP serverja mi normalno pokaže dostop do serverja, lahko zaženem kontrolo mreže, mi pokaže info:_1000Mb/s, Full-duplex - nato na PCju izberem osveži v raziskovalcu - mi mrežo spet pokaže - in filmi delajo popolnoma tekoče

po moje tale switch nekaj ustvarja... preko njega enostavno ne gre vsebina tako kot bi morala...

kaj za hudiča pa se lahko pri switchu pokvari

Zgodovina sprememb…

  • spremenil: Joze_K ()

Spc ::

Mogoče imaš kakšen loop vmes ? ali pa so IP (DHCP) naslovi zmrdani.
Telemach is a land of confusion in Slo-tech je podkupljen iz strani ProPlus-a.
https://tinyurl.com/lr8hydo

Joze_K ::

mater,.. zdaj sem na server naložil PLEX media ... in sedaj po povezavi TV Ethernet lahko brez problema gledam tudi tole... (očitno uPnP2 ni bil dobro nastavljen)

ne gre pa preko KODIja... kjer pa so fini opisi, slike, previewi....

@spc - pa kako so lahko IPji napačni, če gre tale povezava med serverjem in KODIjem preko tega istega switcha - to je notranja zanka...

sicer je sedaj TVethernet in server tudi notranja zanka... pa deluje...

darkolord ::

osamil povezavo le na server in kodi... zmrzne...
Tole je pa čudno. Poskusi še Kodija direkt povezati s serverjem (brez switcha vmes).

Joze_K ::

hja, sem ju povezal neposredno... vendar mi sedaj KODI player javlja, da nima Ethernet povezave... verjetno se ne da mreža direktno vezati brez routerja ali switcha...
tako, da to je NO GO...

errhec ::

Iz lynksisa si dal kabel v Kodi-ja in ti ne dela???
Potem glej nastavitve v Kodiplayerju pod LAN. Poizkusi brezžično če gre.
dd

Joze_K ::

ne, iz serverja v Kodi-player saj mi je zdaj jasno, da to ne gre...
neposredno v Linksys pa ne morem - fizično, v povsem drugi sobi...

darkolord ::

Če imaš statični IP na obeh (serverju in kodiju), bi moralo delati tudi direkt iz serverja v kodi.

Joze_K ::

statični IP imam nastavljen v Linksys-u za obadva eden ima x.x.x.129, drug x.x.x.149 - v posameznih napravah pa nisem nikjer nič nastavljal... ampak javljata oz. sta dostopna na ta dva IP-ja

Poldi112 ::

Joze_K je izjavil:

hja, sem ju povezal neposredno... vendar mi sedaj KODI player javlja, da nima Ethernet povezave... verjetno se ne da mreža direktno vezati brez routerja ali switcha...
tako, da to je NO GO...


Se da, samo rabiš cross over kabel.
Where all think alike, no one thinks very much.
Walter Lippmann, leta 1922, o predpogoju za demokracijo.

darkolord ::

Crossover kabl leta 2017? Bi moral že praktično vsak device imet Auto MDI-X ...

rokp ::

Glede na to, da je "staticen IP" ocitno rezervacija na DHCP serverju, najbrz res ni potreben crossover kabel...

crniangeo ::

Izklopi kodija in pingaj tisti ip od kodija :)

Spucaj kodijev cache
Convictions are more dangerous foes of truth than lies.

Zgodovina sprememb…

Joze_K ::

tole je pinganje do KODI playerja... ne izgleda, da bi to bil problem...

Pinging x.x.x.149 with 32 bytes of data:
Reply from x.x.x.149: bytes=32 time=2ms TTL=64
Reply from x.x.x.149: bytes=32 time=1ms TTL=64
Reply from x.x.x.149: bytes=32 time=1ms TTL=64
Reply from x.x.x.149: bytes=32 time=1ms TTL=64

Ping statistics for x.x.x.149:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 1ms, Maximum = 2ms, Average = 1ms

Joze_K ::

nadaljevanje:

brisal Kodi cache...

v KODIju spet vse globoko zamrzne

poskusil sem tudi mrežo nastaviti na fiksno - vendar me sprašuje cel kup nekih podatkov, ki jih ne poznam...
imam podatek za IP, prehod, ... ne vem pa kakšen podatek bi bili DOLŽINA PREDPONE OMREŽJA (piše kot npr.24), nato DNS1 in DNS2

crniangeo ::

Nisva se razumela vlede prvega koraka. Pingaj kodijev ip ko je ugasnjen
Convictions are more dangerous foes of truth than lies.

Joze_K ::

crniangeo je izjavil:

Nisva se razumela vlede prvega koraka. Pingaj kodijev ip ko je ugasnjen


ok, a veš.. sem včasih precej trd okoli razumevanja...
ugasnjen aparat

Pinging x.x.x.149 with 32 bytes of data:
Request timed out.
Request timed out.
Reply from x.x.x.144: Destination host unreachable.
Reply from x.x.x.144: Destination host unreachable.

Ping statistics for x.x.x.149:
Packets: Sent = 4, Received = 2, Lost = 2 (50% loss),

ne vem odkod odgovor iz naslova x.x.x.144 ? (že našel 144 je moj PC)

sedaj pingam še player ko je KODI ugasnjen:

Pinging x.x.x.149 with 32 bytes of data:
Reply from x.x.x.149: bytes=32 time manjši 1ms TTL=64
Reply from x.x.x.149: bytes=32 time manjši 1ms TTL=64
Reply from x.x.x.149: bytes=32 time manjši 1ms TTL=64
Reply from x.x.x.149: bytes=32 time manjši 1ms TTL=64

Ping statistics for x.x.x.149:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 0ms, Maximum = 0ms, Average = 0ms

Zgodovina sprememb…

  • spremenil: Joze_K ()

Joze_K ::

hm, naredil sem deinstal in instaliral ponovno Kodi...
pri prvi nastavitvi virov filmov me je vprašal za gesla za dostop do mrežnega diska...
sedaj deluje... (zaenkrat)

pop...diš, koliko dela in muke mi je to naredilo...
največji hec pa je, da se gesla niso spreminjala in da je Kodi lepo deloval leta...
naenkrat je pa očitno pozabil na gesla in ni imel dovoljenja dostopa do mrežnega diska - ampak to nikjer ni javil, ali izpisal ali... samo zaštekal je...

hvala vsem ki ste pomagali...
(jaz pa vesel na delo na ponovno nastavljanje cele "pobrisane" strukture virov

crniangeo ::

lahko da je problem popravek za winse, v kolikor imas share na windows okolju. v tem primeru je treba omeniti, da so ponekod onemogocili smb1 support.
Convictions are more dangerous foes of truth than lies.


Vredno ogleda ...

TemaSporočilaOglediZadnje sporočilo
TemaSporočilaOglediZadnje sporočilo
»

Najboljši routi na optiki

Oddelek: Omrežja in internet
121991 (1550) Bakunin
»

Kako ojačati signal na stacionarnem telefonu(ip telefonija)?

Oddelek: Pomoč in nasveti
111667 (1420) KandazaR
»

Problem na mrež(n)i

Oddelek: Omrežja in internet
61426 (1371) BlueRunner
»

ping

Oddelek: Omrežja in internet
161498 (1162) Tilen
»

Preveliki pingi (strani: 1 2 )

Oddelek: Omrežja in internet
524516 (3923) [L4M3RZ] - TinLaDeN

Več podobnih tem