» »

Pomoč EEG

Pomoč EEG

jaz_123 ::

Pozdravljeni!
Pred približno pol leta sem kupil EEG za domačo uporabo (preko OLIMEXA), nekaj aktivnih in eno aktivno elektrodo. Sedaj se že ves ta čas ukvarjam z inštalacijo softwara, ki bi podatke iz naprave ustrezno uredil in prikazal. Na računalniku imam Windows XP, Debian. Probal sem že z vsemi mogočimi programi Brainbay, OPENvibe, Electric guru, BWview. Downloadov sem izvorno kodo programa jo ustrezno razpakiral in prevedel. Vglavnem naredil vse kar je bilo napisano v navodilih programov. A vedno se mi je nekaj zalomilo. Ne vem, najbrž z mojim znanjem ni mogoče stvari urediti. Vglavnem zanima me če koga to zanima in bi mi rad pomagal (ne le z nasveti, a tudi ti so izjemno zaželeni), za pomoč sem pripravljen tudi plačati. Če ima kdo kakršnekoli izkušnje prosim naj mi pomaga.
Hvala že vnaprej za vaše odgovore. :D

https://www.olimex.com/Products/EEG/Ope...
To je link od strani kjer prodajajo napravo.
  • spremenilo: jaz_123 ()

ducttape ::

Vsekakor zanimiva zadeva.

Sicer ne vem kje tocno se ti ustavi, vendar glede na quick start guide bi zadeva morala biti precej neproblematicna, brez raznih prevajanj.

Potek je nekako tak:
-priklopi EEG na USB
-namesti FTDI driverje
-v izbranem podprtem programu nastavis COM port, baud rate, tip EEGja
-priklopi in namesti elektrode
-zazeni program?

Kje tocno se zalomi?

jaz_123 ::

Probal sem vzpostavit povezavo že na več operacijskih sistemih (Linux Mint, Debian, Windows XP). Na različnih sistemih sem imel različne probleme. Na Mintu sem probal prevest izvorno kodo Bwview-a. Prej sem že inštaliral vse potrebne knjižjice (FFTW, SDL). A potem se je zalomlo pri configuraciji samega BWview-a. Na Windowsu sem probal z Brainbayem. Vse sem lepo nardil sporgramiral z (nevem kako se že teočno reče. Tabelično programiranje). Vglavnem nima veze, ko sem priključil EEG na program, se je program zrušil (izklopil). Na windowsu sem probal še z Electru Gurujem in OPENvibom. Pri obeh EEG-ja nista zaznala. Kljub temu da sem izpolnil korake, ki ste jih navedli zgoraj. Na zadnje sem še poiskusil z Debianom in na njem probal inštalirat OPENvibe. To sem naredil tako, da sem najprej inštaliral vse dependence(knjižnjice, programe), ki so potrebni za delovanje OPENvib-a. Sam mislim da se je zalomlo prav pri tem koraku, saj tiste programe, ki jih ni bilo v synapticu (programskem središču), sem šel ročno prevajat izvorno kodo. Kljub temu, da sem namestil (vsaj jaz tako mislim) vse dependence, jih ko probam inštalirat OPENvibe, sam program ne najde ali pa zazna. Na Debianu sem probal še enkrat z BWview, a zgodba je bila enaka kot na Mintu.

s6c-gEL ::

Za Debian install programa uporabi terminal,
apt-get install XYZ,

apt sam ugotovi/namesti potrebne dependencyje.

Za BWView vidim da imaš že skompilirane datoteke
http://uazu.net/bwview/

jaz_123 ::

Glede (sudo apt-get install), nekaterih dependencijev ni v programskem središču (synapticu). Tako da večino sem jih s terminalom, nekaj pa jih je bilo potrebno ročno downloadat izvorno kodo in jih scompilat.
Nazadnje sem se lotil OPENviba. Vse dependencije sem inštaliral.
Pri zagonu spodnjega ukaza (./linux-build) sem dobil odgovor.


vasja@amd ~/openvibe-0.17.1-src/scripts $ ./linux-build
______________________________________________________________________________

~/openvibe-0.17.1-src/local-tmp/linux-Release ~/openvibe-0.17.1-src/scripts

Creating makefiles...

-- Appending compilation flags...
-- Compilation flags used at source root:
-- COMPILE_DEFINITIONS = ''
-- CMAKE_CXX_FLAGS = ' -Wall'
-- CMAKE_CXX_FLAGS_RELEASE = '-O3 -DNDEBUG'
-- CMAKE_CXX_FLAGS_DEBUG = '-g'
-- Note: Disabling Matlab plugin compilation by default
-- Found boost includes...
-- Found openvibe-common...
-- Found dl...
-- Found pthread...
-- Found OpenViBE...
-- Found OpenViBE...
-- Found openvibe-common...
-- Found OpenViBE module FS...
-- Found OpenViBE module System...
-- Found OpenViBE module XML...
-- FAILED to find GTK+...
-- FAILED to find Ogre3D/OIS...
-- Found boost includes...
-- [FAILED] lib boost_thread-mt
-- Found pthread...
-- Found rt...
-- FAILED to find X11...
-- Found dl...
-- Found pthread...
-- Found openvibe-common...
-- Found openvibe-common...
-- Found openvibe-common...
-- Found openvibe-common...
-- Found OpenViBE module System...
-- Found openvibe-common...
-- Found boost includes...
-- [FAILED] lib boost_Filesystem-mt
-- Found pthread...
-- [FAILED] lib boost_system-mt
-- Found OpenViBE module FS...
-- Found openvibe-common...
-- Found boost includes...
-- FAILED to find expat...
-- Found OpenViBE...
-- Found openvibe-common...
-- Found OpenViBE module XML...
-- Found OpenViBE...
-- Found openvibe-common...
-- Found OpenViBE module EBML...
-- Found OpenViBE module System...
-- Found OpenViBE...
-- Found openvibe-common...
-- Found openvibe-toolkit...
-- Found OpenViBE module EBML...
-- Found OpenViBE module System...
-- FAILED to find VRPN
-- --> Not building openvibe-plugins-vrpn
-- Found OpenViBE...
-- Found openvibe-common...
-- Found openvibe-toolkit...
-- Found OpenViBE module System...
-- Found OpenViBE...
-- Found openvibe-common...
-- Found openvibe-toolkit...
-- Found OpenViBE module EBML...
-- Found OpenViBE module System...
-- Found OpenViBE module XML...
-- Found OpenViBE...
-- Found openvibe-common...
-- Found openvibe-toolkit...
-- Found OpenViBE module EBML...
-- Found OpenViBE module System...
-- Found OpenViBE module XML...
-- FAILED to find BLiFF++
-- FAILED to find it++...
-- FAILED to find eigen3...
-- Found OpenViBE...
-- Found openvibe-common...
-- Found openvibe-toolkit...
-- Found OpenViBE module EBML...
-- Found OpenViBE module System...
-- Found boost includes...
-- FAILED to find eigen3...
-- FAILED to find it++...
-- Found OpenViBE...
-- Found OpenViBE...
-- Found openvibe-common...
-- Found openvibe-toolkit...
-- Found OpenViBE module EBML...
-- Found OpenViBE module System...
-- FAILED to find GTK+...
-- Found OpenViBE...
-- Found openvibe-common...
-- Found openvibe-toolkit...
-- Found OpenViBE module System...
-- Found OpenViBE...
-- Found openvibe-common...
-- Found openvibe-toolkit...
-- Found boost includes...
-- [FAILED] lib boost_system-mt
-- Found OpenViBE...
-- Found openvibe-common...
-- Found openvibe-toolkit...
-- Found OpenViBE module EBML...
-- Found OpenViBE module System...
-- Found OpenViBE module XML...
-- Found boost includes...
-- [FAILED] lib boost_regex-mt
-- Found OpenViBE...
-- Found openvibe-common...
-- Found openvibe-toolkit...
-- Found OpenViBE module EBML...
-- Found OpenViBE module Socket...
-- Found OpenViBE module System...
-- Found OpenViBE...
-- Found openvibe-common...
-- Found openvibe-toolkit...
-- Found OpenViBE module EBML...
-- Found OpenViBE module Automaton...
-- Found OpenViBE module System...
-- FAILED to find GTK+...
CMake Error at /usr/share/cmake-2.8/Modules/FindPackageHandleStandardArgs.cmake:108 (message):
Could NOT find Lua51 (missing: LUA_LIBRARIES LUA_INCLUDE_DIR)
Call Stack (most recent call first):
/usr/share/cmake-2.8/Modules/FindPackageHandleStandardArgs.cmake:315 (_FPHSA_FAILURE_MESSAGE)
/usr/share/cmake-2.8/Modules/FindLua51.cmake:76 (FIND_PACKAGE_HANDLE_STANDARD_ARGS)
cmake-modules/FindThirdPartyLua.cmake:9 (FIND_PACKAGE)
plugins/processing/stimulation/CMakeLists.txt:22 (INCLUDE)


-- Configuring incomplete, errors occurred!
See also "/home/vasja/openvibe-0.17.1-src/local-tmp/linux-Release/CMakeFiles/CMakeOutput.log".
[255]vasja@amd ~/openvibe-0.17.1-src/scripts $


Kot sem sam razbral iz tega. Ne najde nekih knjižnjic kot so GTK+, libboost in ostale. Vse te bi morale biti inštalirane in tudi kaže v synapticu da so. Nevem zakaj jih ne najde.

ducttape ::

Verjetno bi bilo bolje da stvar najprej probas v Windowsih raziskat. Zakaj ti programi ne zaznajo EEGja... Lahko je problem v tem, da ima FTDI COM port visji od 4 (omenjeno v QSG da ima ElecGuru probleme s tem). Oz. ali ti v device manager sploh kaze da je driver namescen?

Ce zelis me kontaktiraj in se zmeniva za kaksen Skype ali Teamviewer, da bo slo hitreje.


Vredno ogleda ...

TemaSporočilaOglediZadnje sporočilo
TemaSporočilaOglediZadnje sporočilo
»

Grafična kartica in Windows7 64bit-ni problem

Oddelek: Strojna oprema
181731 (1232) jizzer
»

Ubuntu 7.04 + Pinnacle PCTV = slika super, zvoka ni - Linux n00b here (strani: 1 2 )

Oddelek: Operacijski sistemi
706586 (4027) poweroff
»

Problem z nvidio

Oddelek: Pomoč in nasveti
171461 (1209) lanicorec
»

Problem z zagonom iger RTCW in MOHAA

Oddelek: Igre
152533 (2217) Flay
»

Wolfenstein in XP???! :o(

Oddelek: Pomoč in nasveti
6892 (794) zrebec

Več podobnih tem