» »

Ubuntu 7.04 + Pinnacle PCTV = slika super, zvoka ni - Linux n00b here

Ubuntu 7.04 + Pinnacle PCTV = slika super, zvoka ni - Linux n00b here

1
2
»

kriko1 ::

Ja, namesti osnovne stvari za prevajanje (če greš že ročno) - gcc, kernel-devel.
Samo na določenih karticah ne dela - da nisi eden izmed srečnežev, pri prijatelju fglrx je kar naprej zamrzoval vse skupaj na r9800 pro (verjetno odvisno od revizije).

iskra ::

Moj je od Sapphire 4153 in vidim, da je kar precej ljudi potozilo, da jim ne-cisto-ati kartice ne delajo pravilno.

Bom poskusil se kernel develop zadevo instalirat in potegnt driverje cez. Hvala za dosedanjo pomoc.
Ajow! 5 metru drow ...
Če bi imel Ronaldinho izvenzakonskega sina, bi se klical Bastardinho.

kriko1 ::

Čudno, ravno sapphire ima prijatelj in tudi ne dela z fglrx.

Zgodovina sprememb…

  • spremenil: kriko1 ()

iskra ::

Ja ne? Nazadnje sem nekaj šaril po paketih in dosegel, da mi fglrxinfo prikaže ATI podatke, sedaj pa je spet tu mesa - ne vem kako. Očitno se bom moral za 3D podporo obrniti na male oglase po "novo" kartico.
Ajow! 5 metru drow ...
Če bi imel Ronaldinho izvenzakonskega sina, bi se klical Bastardinho.

iskra ::

[dri] radeon.o kernel module version is 8.49.7 but version 1.17.0 or newer is needed.
[dri] Disabling DRI.

To sem zasledil v /var/log/Xorg.99.log - to je error report iz Sax2. Se pravi, da me DRI heca. Še bo treba googlat :8)
Ajow! 5 metru drow ...
Če bi imel Ronaldinho izvenzakonskega sina, bi se klical Bastardinho.

kriko1 ::

iskra ::

Mislim, da sem preizkusil čisto vse How-To-je, kar jih je na netu. Vse kar hočem, je igrati FooBillard, pa mi zmrzne škatla, ko ga hočem zagnati. Glxgears pokažejo malo pod 3000 fps, pa še to moram imeti srečo, da zdrži sistem "pokonci" več kot 30 sekund. V Windowsih pa lahko čisto normalno poganjam vse živo, tako da ne more biti grafična kriva.

Še en kolokvij grem pisat, potem pa se spet dam v to zadevšno.
Ajow! 5 metru drow ...
Če bi imel Ronaldinho izvenzakonskega sina, bi se klical Bastardinho.

iskra ::

http://m.domaindlx.com/LinuxHelp/ati/at...

Urejeno :D Po vsej e-literaturi, ki sem jo dal skozi, sem naletel na to zadevo in našel eno zanimivo vrstico. Za igranje iger je potrebno v Xorg.conf odstraniti vrstici
Option "VideoOverlay" "on"
Option "OpenGLOverlay" "off"
in zadeva špila 8-)
Ajow! 5 metru drow ...
Če bi imel Ronaldinho izvenzakonskega sina, bi se klical Bastardinho.

iskra ::

Dodatek: driverje sem namestil po metodi opisani v prej priloženem linku. Med tem sem nadgradil OpenSuse iz 10.3 na 11. fgl_glxgears strelja med 450 in 490 fps.

No, da vidimo kako izgleda compiz na mojem namizju :)

Vseeno pa imam še eno vprašanje: 1024x768 (85 Hz nese moj monitor) mi je malo blesava resolucija, zato sem prešaltal na 1280x1024 (85 Hz), ki pa ni v razmerju s stranicami moje katodne cevi. 1280x960 podpira samo 60 Hz, kar ni ravno zdravo za moj vid. Kako dodati še druge frekvence osveževanja?
Ajow! 5 metru drow ...
Če bi imel Ronaldinho izvenzakonskega sina, bi se klical Bastardinho.

kriko1 ::

1. Lahko v sax2 izbereš drugi monitor (in tako forciraš resolucijo / osveževalno frekvenco), ali ročno popraviš frekvence (ne vem kako se to na pamet dela)
2. ročno v xorg.conf pod metamodes

iskra ::

Xubuntu 8.10 je moj nov sistem. Isti TVTuner. Napaka pa sledeča:

TvTime mi javi, Cannot open capture devicee /dev/video0.
tvtime -v vrže med vrsticami tole: tvtime: Cannot set priority to -10: Permission denied.

lspci -v -nn pravi tole:
00:0c.0 Multimedia video controller [0400]: Brooktree Corporation Bt878 Video Capture [109e:036e] (rev 11)
Subsystem: Pinnacle Systems Inc. Device [11bd:0012]
Flags: medium devsel, IRQ 18
Memory at -unassigned- (32-bit, prefetchable) [disabled]
Capabilities: -access denied-
Kernel modules: bttv

00:0c.1 Multimedia controller [0480]: Brooktree Corporation Bt878 Audio Capture [109e:0878] (rev 11)
Subsystem: Pinnacle Systems Inc. Device [11bd:0012]
Flags: medium devsel
Memory at -unassigned- (32-bit, prefetchable) [disabled]
Capabilities: -access denied-

Je možno, da je šla kartica po gobe ali moram postati doktor googla?
Ajow! 5 metru drow ...
Če bi imel Ronaldinho izvenzakonskega sina, bi se klical Bastardinho.

kriko1 ::

Meni zgleda kot da nimaš pravice za uporabo te naprave, torej verjetno zafrk ubuntuja.
Najbrž se moraš dodat v video skupino ali kaj podobnega...

iskra ::

Dodajanje v skupine je rešilo del problema. Hvala :) Kaj pa sedaj, ko TvTime javi "no signal"?

tvtime-scanner tudi nič ne najde. Signal pa preverjeno je, ker TV v sosednji sobi dela normalno.
Ajow! 5 metru drow ...
Če bi imel Ronaldinho izvenzakonskega sina, bi se klical Bastardinho.

poweroff ::

Poskusi kdetv.
sudo poweroff

iskra ::

Ne pomaga. Meni se zdi, kot da je nekaj "ugrabilo" TV kartico in ne da dostopa sistemu.
Ajow! 5 metru drow ...
Če bi imel Ronaldinho izvenzakonskega sina, bi se klical Bastardinho.

iskra ::

No, sedaj mislim, da sem preizkusil vse TV aplikacije v Synapticu in vse mi povejo isto: /dev/video0 ne obstaja :'(
Ajow! 5 metru drow ...
Če bi imel Ronaldinho izvenzakonskega sina, bi se klical Bastardinho.

kriko1 ::

Kaj pa če poženeš te aplikacije kot root?

zee ::

Kaj pa ce najprej nadgradis na 8.04 (LTS) ali 8.10 ?
zee
Linux: Be Root, Windows: Re Boot
Giant Amazon and Google Compute Cloud in the Sky.

iskra ::

kriko1: sem poskušal, pa ni pomagalo.

zee: par postov višje sem napisal, da sem na zadnji verziji ;)

Kakorkoli že, imam novice za vse, ki ste mi pomagali: včeraj sem se odločil posesati komplet škatlo, odstranil sem vse PCI naprave in ko sem sestavil sistem, sem za zabavo zamenjal ležišča kartic. In slika se je pojavila. Očitno se je kak IRQ al ne vem kaj zabaval z menoj zadnja dva meseca. Mamumu ... 8-O
Ajow! 5 metru drow ...
Če bi imel Ronaldinho izvenzakonskega sina, bi se klical Bastardinho.

poweroff ::

Hmm, po nadgradnji na Ubuntu 8.10 TV tuner ne dela več:
https://bugs.launchpad.net/ubuntu/+sour...

Kakšna ideja?
sudo poweroff

poweroff ::

Trapasta napaka: https://slo-tech.com/forum/t369047/kone...

Torej... v /etc/rc.local je treba imeti:
rmmod bt878
rmmod bttv
modprobe bt878
modprobe bttv card=39 tuner=33


V /etc/modules pa
bt878
bttv card=39 tuner=33

Velja za Jaunty.

Povedano drugače: modprobe bttv card=39 tuner=33 je rešitev problema.
sudo poweroff
1
2
»


Vredno ogleda ...

TemaSporočilaOglediZadnje sporočilo
TemaSporočilaOglediZadnje sporočilo
»

[Ubuntu 7.04] Xorg me po inštalaciji ATI driverjev ne mara več :(

Oddelek: Operacijski sistemi
8806 (677) mile
»

TV tuner v Linuxu - slika je, zvoka ni

Oddelek: Operacijski sistemi
71370 (1260) poweroff
»

[Linux] Pinnaclova kartica

Oddelek: Operacijski sistemi
301493 (1248) christooss
»

TV tuner pod Linux-om

Oddelek: Operacijski sistemi
151473 (1235) Skrat
»

Linux / ATI Radeon / problem z driverji

Oddelek: Operacijski sistemi
131530 (1347) ahac

Več podobnih tem