» »

Eclipse in windows 8

Eclipse in windows 8

mihibo5 ::

Pozdravljeni!

Pravkar sem namestil windows 8. Pokazale so se težave z združljivostjo pri programu Eclipse (in še pri nekaterih drugih). Zanima me, kako te težave odstraniš. Hvala za vse odgovore.

Looooooka ::

Druge kot da na shortcutu nastavis compatibility mode na starejso verzijo winsev, updejtas program ali pa pri windows features dodas hyper-v in ga zazenes v virtualki s starejso verzijo windowsev(kjer bos rabil se eno licenco...) ni.
Ampak tist compatibility mode dela pri vecini programov.

mihibo5 ::

združljivost z windowsam 7 ne deluje...

krneki0001 ::

Kakšne probleme pa imaš? Malo več opiši pa kako slikco ekrana prilimaj. Meni eclipse namreč čisto normalno deluje v windows 8.
Asrock X99 Extreme 4 | Intel E5-2683V4 ES | 64GB DDR4 2400MHz ECC |
Samsung 250GB M.2 | Asus 1070 TI | 850W Antec | LC Tank Buster

hojnikb ::

v katerem jeziku programiraš to ?
ziher obstajajo kake alternativna okolja
#teamred
MediaBox: AMD R5 1600 AF, 16GB DDR4, 256GB SSD, 1060 6GB, B450M-DS3H, W10

mihibo5 ::

@nebivedu: Po vsej verjetnosti ni združljiv. A je isti problem ko zaženem v združljivem načinu.
@gojnikb: Programiram v javi. Zaenkrat se še učim iz youtube vodičov, in tam se uporablja eclipse. Če kdo pozna kakšen dober in podoben program se priporočam.

Program je na windows 7 delal normalno, sedaj, ko sem namestil windows 8 pro pa ne deluje.
Slika napake:
 Eclipse error

Eclipse error

Zgodovina sprememb…

  • spremenil: mihibo5 ()

krneki0001 ::

A imaš 64 biten sistem in 32 biten eclipse? Meni je tudi v win 8 na začetku to delal, ker sem imel 64 biten sistem in 32 biten eclipse.
Asrock X99 Extreme 4 | Intel E5-2683V4 ES | 64GB DDR4 2400MHz ECC |
Samsung 250GB M.2 | Asus 1070 TI | 850W Antec | LC Tank Buster

mihibo5 ::

64 bit, a mislim, da sem eclipse tudi 64 bitno verzijo namestil. Tudi windows 7 je bil 64 biten.

Marat ::

poglej še katero verzijo jave/jdk imaš - 32 ali 64 bit

mihibo5 ::

Tako je z windowsim... Bo treba updatat na 1.7.0_10, vam povem rezultat.
Vir: http://www.oracle.com/technetwork/java/...

Windows Server 2008 x86 (32-bit) SP2 1.7.0
Windows Server 2008 x64 (64-bit) SP2 1.7.0
Windows Server 2008 R2 x64 (64-bit) SP1 1.7.0
Windows Server 2012 x64 (64-bit) 1.7.0_10
Windows Vista x86 (32-bit) SP2 1.7.0
Windows Vista x64 (64-bit) SP2 1.7.0
Windows XP x86 (32-bit) SP3 1.7.0
Windows XP x64 (64-bit) SP2 1.7.0
Windows 7 x86 (32-bit) SP1 1.7.0
Windows 7 x64 (64-bit) SP1 1.7.0
Windows 8 x86 (32-bit) 1.7.0_10 Modern UI (i.e. Metro Mode) is not supported
Windows 8 x64 (64-bit) 1.7.0_10 Modern UI (i.e. Metro Mode) is not supported

win64 ::

Kaj pa piše v logu?

mihibo5 ::

!SESSION 2013-01-25 16:27:08.271 -----------------------------------------------
eclipse.buildId=M20120914-1800
java.version=1.7.0_11
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=sl_SI
Framework arguments: -product org.eclipse.epp.package.java.product
Command-line arguments: -os win32 -ws win32 -arch x86_64 -product org.eclipse.epp.package.java.product

!ENTRY org.eclipse.osgi 4 0 2013-01-25 16:27:10.366
!MESSAGE Startup error
!STACK 1
java.lang.UnsatisfiedLinkError: sun.nio.ch.IOUtil.iovMax()I
at sun.nio.ch.IOUtil.iovMax(Native Method)
at sun.nio.ch.IOUtil. clinit(Unknown Source)
at sun.nio.ch.Util. clinit(Unknown Source)
at sun.nio.ch.FileChannelImpl. clinit (Unknown Source)
at java.io.RandomAccessFile.getChannel(Unknown Source)
at org.eclipse.core.runtime.internal.adaptor.Locker_JavaNio.lock(Locker_JavaNio.java:39)
at org.eclipse.osgi.storagemanager.StorageManager.lock(StorageManager.java:389)
at org.eclipse.osgi.storagemanager.StorageManager.open(StorageManager.java:702)
at org.eclipse.osgi.internal.baseadaptor.BaseStorage.initFileManager(BaseStorage.java:220)
at org.eclipse.osgi.internal.baseadaptor.BaseStorage.initialize(BaseStorage.java:154)
at org.eclipse.osgi.baseadaptor.BaseAdaptor.initializeStorage(BaseAdaptor.java:123)
at org.eclipse.osgi.framework.internal.core.Framework. init(Framework.java:192)
at org.eclipse.core.runtime.adaptor.EclipseStarter.startup(EclipseStarter.java:262)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:176)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:629)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:584)
at org.eclipse.equinox.launcher.Main.run(Main.java:1438)
at org.eclipse.equinox.launcher.Main.main(Main.java:1414)

Pri java downloadu piše: Downloading and installing Java will only work in Desktop mode on Windows 8. See the Java on Windows 8 FAQ for more detailed information.

Kaj to pomeni?

Zgodovina sprememb…

  • spremenil: mihibo5 ()

mihibo5 ::

Deluje. Problem ni bil v združljivosti, ampak v updatu JDK (java development kit). Še link če bo kdo imel podobne težave: http://www.oracle.com/technetwork/java/...


Vredno ogleda ...

TemaSporočilaOglediZadnje sporočilo
TemaSporočilaOglediZadnje sporočilo
»

edavki ubuntu 13 chrome

Oddelek: Omrežja in internet
183251 (906) harvey
»

Ne zazna R.class -android

Oddelek: Programiranje
17833 (671) Marat
»

[Android]Vprasanje glede GUI ter pripadajoce XML datoteke

Oddelek: Programiranje
102039 (1925) KernelPanic
»

tomcat in datasource

Oddelek: Programiranje
131292 (1049) infiniteLoop
»

E-davki in oddaja dohodnike (bliža se dan) (strani: 1 2 )

Oddelek: Loža
866933 (4896) kriko1

Več podobnih tem