» »

Mikrotik T-2 IPTV IGMP Proxy

Mikrotik T-2 IPTV IGMP Proxy

]Trix[ ::

Na Mikrotiku 751G probavam usposobit IPTV od T-2 pa mi nekako ne uspe po navodilih od http://virtua-it.si/2012/01/igmp-proxy-...... A ma kdo tukaj kake izkusnje s temle in Mikrotikom?
Conscience is what hurts when everything else feels so good.

NoName ::

morda vrstni red pravil požarnega zidu ni okej. preveri... prav tako priporočam, da za alternativne subnete pri igmp proxyju vpišeš 0.0.0.0/0, ter firewall rule malce popraviš, da bo dst-address 224.0.0.0/4 namesto src-address 172.0.0.0/12

recimo, da je ether1-gateway tvoj WAN, bridge-local pa LAN...

preveriš, če je nameščen multicast paket:
/system package print from=[find name=multicast]

pa bi moralo izpisat, da imaš multicast, ga vključiš, če je onemogočen, ali namestiš...

ko je paket nameščen in aktiviran pa nadaljuješ takole...
najprej igmp proxy
/routing igmp-proxy interface
 add alternative-subnets=0.0.0.0/0 disabled=no interface=ether1-gateway threshold=1 upstream=yes
 add disabled=no interface=bridge-local threshold=1 upstream=no


nato pa še politika požarnega zidu
/ip firewall filter
 add action=accept chain=input comment="Allow Broadcast Traffic" disabled=no dst-address-type=broadcast place-before=0
 add action=accept chain=input comment="Allow IGMP" disabled=no protocol=igmp place-before=0
 add action=accept chain=input comment="Allow T-2 IPtv" disabled=no protocol=udp dst-address=224.0.0.0/4 place-before=0


upam da nisem kje zamuckal vmes...
I can see dumb people...They're all around us... Look, they're even on this forum!

]Trix[ ::

Super. Thanks a lot. Stvar deluje na racunalniku ... A na STBju še ne :( Kake ideje kako bi to usposobu?
Conscience is what hurts when everything else feels so good.

NoName ::

STB se trenutno ne more nahajati za usmerjevalnikom, temveč mora biti priključen neposredno na modem/switch. Eventuelno lahko riskiraš en port (ether3-5) na samem mikrotiku pa ga pobridgeaš z ether1-gateway namesto, da je v switch modeu kot slave ether2...
I can see dumb people...They're all around us... Look, they're even on this forum!

]Trix[ ::

OK zdej morm sam zastekat logiko kako to narest še :) Trenuntno sm dal vn ether5-slave-local iz slave moda, k je po defaultu master ether2.... Ko nardim bridge-wan in pod njega dam oba mi neha delat internet... Torej dat moram pa pol ether1-gateway in ether5-iptv (ether5-slave-local) v bridge... Niso mi še čist jasne tele stvari...
Conscience is what hurts when everything else feels so good.

NoName ::

torej. koraki bi bili naslednji - predpostavljam pa, da se povezuješ iz bridge-lan preko winbox/ssh ali kaj podobnega
1. ether5-slave daš ven is slave modea v switchu
2. ustvariš nov bridge, npr bridge-wan
3. dodaš ether5 v bridge-wan
4. dodaš ether1-gateway v bridge-wan
potem pa...
... če imaš statiko
5a. zamenjaš interface iz ether1-gateway v bridge-wan v ip addresses
... če imaš dinamiko
5b. zamenjaš interface iz ether1-gateway v bridge-wan za dhcp client v ip dhcp client
6. korak je pa spet enak, ne glede na statiko ali dinamiko pri operaterju - v ip firewall nat spremeniš interface za maškarado iz ether1-gaetway v bridge-wan

brez zadnjega koraka ti bo deloval internet le na samem usmerjevalniku, ne pa tudi na lokalni mreži
I can see dumb people...They're all around us... Look, they're even on this forum!

]Trix[ ::

Najlepsa ti dala :)
Conscience is what hurts when everything else feels so good.

Lucio ::

Po the nastavitvah nastavil svojega mikrotika, pa mi TV ne deluje.
Preizkusil sem tako na prenosniku preko WIFI kot na RPi2 - OpenElec (IP TV Simple client).
V port 1 na routerju sem probal z obema kagloma iz T-2 naprave (NET in IP TV port), pa v nobenem primeru ne deluje.
Ima kdo kakšen nasvet kaj lahko še preizkusim?

Narkotik ::

Živjo, tudi meni ne uspe po zgornjih navodilih.
Je tu kak uporabnik ki mu na Mikrotiku še vedno deluje T-2 preko IGMP Proxy? (Je T-2 vmes zamenjal kake subnete za multicast promet?)

OmegaBlue ::

Odvisno kak tip priključka imaš, sistemsko se ni nič bistveno spreminjalo.

Če si pa slučajno na BRO potem to ne dela.
Never attribute to malice that which can be adequately explained by stupidity.

svejk ::

ali je kdo našel pravo rešitev za tole....obujam temo ;)

Po teh navodilih T2 TV deluje

Zgodovina sprememb…

  • spremenilo: svejk ()

svejk ::

svejk je izjavil:

ali je kdo našel pravo rešitev za tole....obujam temo ;)

Po teh navodilih T2 TV deluje

http://matjaz.repnik.eu/2016/11/14/t2-t...

steev ::

Obujam staro temo. STB bi rad imel priključen na drugi lokaciji. Na obeh je mikrotik. S čim naj naredim link med mikrotikoma? PPTP, openVPN ali kaj drugega?
:|

Zgodovina sprememb…

  • spremenil: steev ()

čuhalev ::

L2TP jasno

khartahk ::

NoName je izjavil:


/ip firewall filter
add action=accept chain=input comment="Allow T-2 IPtv" disabled=no protocol=udp dst-address=224.0.0.0/4 place-before=0



Ne vem zakaj a poleg zgornjega rule-a na input chain-u moram jaz dodati še na forward:
/ip firewall filter
 add action=accept chain=forward comment="Allow T-2 IPtv" disabled=no protocol=udp dst-address=224.0.0.0/4 place-before=0


Mi morda lahko kdo to obrazloži?

Hvala.

tombs ::

še enkrat obujam temo :/

stvar "nekako" deluje, ampak mi "defconf: drop all from WAN not DSTNATed" pravilo v firewall-u blokira promet. kje sem zafrknu?

mzakelj ::

Finta t-2 tv-ja je v tem da moraš VLAN 2000 pripeljati iz WAN-a na port.

Sam sem tako naredil da sem ustvaril vlan2000 na ETH1 ( wan ) in dal grupo v kateri imam porte na katerih so tv-ji in še ta vlan2000 not. Tako bo delal iptv preko vmesnika b.p.

tombs ::

hvala za super hiter odgovor!

mzakelj ::

steev je izjavil:

Obujam staro temo. STB bi rad imel priključen na drugi lokaciji. Na obeh je mikrotik. S čim naj naredim link med mikrotikoma? PPTP, openVPN ali kaj drugega?


Eoip uporabi. Brez problemov bo šlo na obe lokaciji, pa ni tako zahteven za nastavit.

Daniel ::

Imaš kakšen enostaven vodič za EoIP? Znanec se že kar dolgo muči z postavljanjem enega Mikrotika kot L2TP Client drugemu Mikrotiku, pa zadeva kar ne gre in ne gre. Če se povežeš z Androidom internet normalno dela, če se poveže z Mikrotikom pa internet ne dela.

Urajmal ::

Daniel ::

EOIP je super zadeva, pride marsikje prav. Je pa dobro, da Mikrotik na katerem ga postavljaš podpira hardwerski IPSEC, drugače je zadeva razmeroma počasna.

Edit: sedaj vidim, da si to meni odgovarjal :) Smo vmes že uredili, dela super.

Zgodovina sprememb…

  • spremenil: Daniel ()


Vredno ogleda ...

TemaSporočilaOglediZadnje sporočilo
TemaSporočilaOglediZadnje sporočilo
»

Mikrotik nastavitve

Oddelek: Omrežja in internet
261449 (849) Poldi112
»

SIOL TV in IGMP Proxy

Oddelek: Zvok in slika
53206 (2725) Luka321
»

SSH forwarding na Mikrotiku

Oddelek: Omrežja in internet
101067 (807) miki133
»

mikrotik pomoc

Oddelek: Pomoč in nasveti
373991 (2237) kronik
»

pppoe+mikrotik

Oddelek: Omrežja in internet
172619 (2197) Senitel

Več podobnih tem