» »

iSCSI autostart

iSCSI autostart

poweroff ::

Na Ubuntu strežniku ne uspem vzpostavit iSCSI seje avtomatsko po zagonu.

Torej.. upoabim programski paket open-iscsi.

V /etc/iscsi/initiatorname.iscsi vnesem
InitiatorName=iqn.*******:storage.disk1

V /etc/iscsi/iscsid.conf vnesem "credentials". Nato rečem:
service open-iscsi restart
iscsiadm -m discovery -t sendtargets -p ****.***.si
iscsiadm -m node -l

In sem gor.

Potem imam na tem iSCSI targetu LVM2 (/dev/****_iSCSI/iSCSI_backup). Na tem LVMju pa Cryptsetup LUKS enkripcijo (/dev/mapper/cryptoiscsi), potem pa gor ext4.

Zadevo lahko brez težav ročno mountam. Po rebootu pa se mašina ustavi in pravi, da se ne more povezati na iSCSI target - in potem moram pritisnit (S) za skip, da se normalno zboota do konca (in potem lahko iSCSI priklopim ročno).

Stvar je pa v tem, da sem v /etc/iscsi/iscsid.conf v razdelku “Startup settings” dal notri tole:
node.startup = automatic

Kakšna ideja kje bi bila napaka?
sudo poweroff

Daedalus ::

Mogoče kaka napaka v vrstnem redu init skript, pa se zadeva butne pokonci prej ko se network zbudi? Ne bi bilo prvič... kako maš pa mrežne nastavitve vnešene?

Pa daj node.startup nazaj na default - manual. Pa poskusi še enkrat.
Man is condemned to be free; because once thrown into the world,
he is responsible for everything he does.
[J.P.Sartre]

poweroff ::

Sem poskusil tudi pod manual - isto.

Bi pa rekel, da je problem v networku, da.

Mrežne so v /etc/network/interfaces
auto eth0
iface eth0 inet static
address ***
netmask ***
network ***
broadcast ***
gateway ***
# dns-* options are implemented by the resolvconf package, if installed
dns-nameservers *** ***

Kako pa vrstni red zbujanja servisov vidim / spremenim?
sudo poweroff

Zgodovina sprememb…

  • spremenilo: poweroff ()

Daedalus ::

update-rc.d ukaz si poglej. Če je to init skripta, upstarta ne poznam tako dobro.
Man is condemned to be free; because once thrown into the world,
he is responsible for everything he does.
[J.P.Sartre]

poweroff ::

Huh, zdaj sem naredil tole:

update-rc.d -f open-iscsi remove
Removing any system startup links for /etc/init.d/open-iscsi ...
/etc/rc0.d/S41open-iscsi
/etc/rc1.d/S41open-iscsi
/etc/rc6.d/S41open-iscsi
/etc/rcS.d/S25open-iscsi


No, po rebootu je isto kot prej. V bistvu sem šel pa v (M) manual recovery in ja, networking je. Tudi iSCSI je discoveran, ni pa aktivne seje...

Pravi pa error message takole:
The disk drive for /media/iSCSItarget is not ready yet or not present.


BTW, "unremove" teh skript sem naredil z apt-get install --reinstall open-iscsi, ki je sicer javil:
update-rc.d: warning: open-iscsi stop runlevel arguments (0 1 6) do not match LSB Default-Stop values (0 6)

Ampak skripte so sedaj tam, kjer bi morale biti:
/etc/rc0.d/S41open-iscsi
/etc/rc1.d/S41open-iscsi
/etc/rc6.d/S41open-iscsi
/etc/rcS.d/S25open-iscsi
sudo poweroff

dëych ::

http://www.debianadmin.com/step-by-step...

poglej tisti del o networkingu.


Vredno ogleda ...

TemaSporočilaOglediZadnje sporočilo
TemaSporočilaOglediZadnje sporočilo
»

Oddaljeni šifriran datotečni sistem v Linuxu

Oddelek: Operacijski sistemi
8813 (617) poweroff
»

Gradnja/sestava diskovnega polja (strani: 1 2 3 4 )

Oddelek: Strojna oprema
15316827 (13159) levaky
»

PXE boot Windows 7

Oddelek: Omrežja in internet
171202 (896) andrej02
»

Rack ohišje za diskovno polje

Oddelek: Strojna oprema
112306 (2182) levaky
»

Ekipa Sambe dosegla dogovor z Microsoftom (strani: 1 2 )

Oddelek: Novice / Brskalniki
538201 (5600) poweroff

Več podobnih tem