» »

Arduino Mega + esp8266

Arduino Mega + esp8266

zila90 ::

Pozdravljeni,
sestaviti si želim sistem za merjenje vlage v zemlji, izmerjene podatke pa želim prikazovati na Thingspeaku.
Sistem bi poganjal Arduino Mega v povezavi z ESP8266-01. Komponente sem povezal in napisal kodo. Senzor za vlago mi lepo bere merjene podatke. Vendar se je pojavila težava z ESP-jem, saj nikakor ne morem poslati podatkov na Thingspeak. Ker bi naj ESP deloval na 3,3V sem uporabil tudi regulator napetosti LD1117, vendar mi ESP nikakor ne deluje. Sveti samo rdeča luč. Nato sem poskusil ESP povezati na 5V (brez regulatorja). Pri tej povezavi mi modra led na ESP-ju utripa vendar se modul še vseeno ne poveže v internet. Mogoče kdo ve kaj bi lahko bila težava in kako preveriti ali ESP sploh dela pravilno?

Če sem poskusil z ukazom AT, mi ESP ni odogovoril nič. Tudi Baudrate sem nastavljal že vse možno, vendar nikakor zadeva ne deluje.

Moja vezava je podobna temu:
  • spremenil: zila90 ()

int47 ::

Kateri FW imaš na ESP-ju?
Uporabi 3.3V USB->TTL pretvornik in nastvi 74880 baudrate. Kaj izpiše?

zila90 je izjavil:

Nato sem poskusil ESP povezati na 5V (brez regulatorja).

Verjetno rabiš nov ESP.
Nivo razprav in moderiranja v razdelku Elektrotehnika in elektronika
na tem forumu, je žal prevečkrat močno pod nivojem.

d4vid ::

Čist tako bi ti predlagal, da si kupiš raje ESP8266 razvojno ploščico:



Na njo naložiš pravi firmware in potem jo lahko programiraš preko arduino softwera (zelo podobno kodo naložiš kot na arduino, le da moraš tukaj vpisat še ime wifija in geslo ter nekaj sprememb kode). Google ve veliko.

Meni deluje ESP8266 kot Mysensors gateway in deluje super.

PS: Vendar pazi, zadeva je 3,3V in ne 5. Nisem niti prepričan če na GPIO pinih tolerira 5V, boš pomoje rabil kak pretvornik če misliš 5V gor prilopit na vhod (ali pa vsaj uporovni delilnik).
Laptop:Akoya E4214|Pentium N3540|4 GB RAM|120 GB SSD|Ubuntu Budgie
NAS: Intel Atom D2550|2 GB RAM|3 TB HDD
.: d4vid.info :.

Zgodovina sprememb…

  • spremenil: d4vid ()

xardas ::

Kar je rekel @d4vid. Dobiš jih tudi pod imenom NodeMCU. Kmalu izide druga različica, ki bo podpirala, poleg WiFi, tudi protokol Bluetooth. Programiraš lahko v Cju ali Lui.

zila90 ::

int47 je izjavil:


Verjetno rabiš nov ESP.


Verjetno sem ga že skuril pri nalaganju novega FW-ja ker sem na TTL-ju pozabil menjat na 3,3V :/

Še eno vprašanje...je vezava z LD1117 drugače v redu in bi delovala (če ne bi naredil takšne začetniške neumnosti)?

d4vid ::

Meni se zdi škoda toliko komplicirat za en senzor, sploh ne vem zakaj pretiravaš s Mega, ko pa bi lahko to vezal direktno na ESP8266. Pa še na ebayu jih dobiš za slabe 4 dolarje, nekaj centov dražje kot kakšen nano, tako da se niti arduinota ne splača več kupit, tudi če ne rabiš wifija. Pa še procesorsko je zmogljivejši (80/160 MHz proti 8/16 MHz), pravtako ma več RAM-a in ROM-a.
Laptop:Akoya E4214|Pentium N3540|4 GB RAM|120 GB SSD|Ubuntu Budgie
NAS: Intel Atom D2550|2 GB RAM|3 TB HDD
.: d4vid.info :.

zila90 ::

d4vid je izjavil:

Meni se zdi škoda toliko komplicirat za en senzor, sploh ne vem zakaj pretiravaš s Mega, ko pa bi lahko to vezal direktno na ESP8266. Pa še na ebayu jih dobiš za slabe 4 dolarje, nekaj centov dražje kot kakšen nano, tako da se niti arduinota ne splača več kupit, tudi če ne rabiš wifija. Pa še procesorsko je zmogljivejši (80/160 MHz proti 8/16 MHz), pravtako ma več RAM-a in ROM-a.


Arduino Mega sem vzel zaradi tega, ker bom morda v prihodnje nanj priključil še kakšen dodaten senzor in vodno črpalko, ki bo direktno zalivala zemljo, ko bo presuho. Drugače vem, da bi lahko za ta senzor enostavno uporabil samo ESP. Kaj pa praviš na vezavo, je ok?

d4vid ::

Hja vezava je najbrž OK, lahko da si pomešal RX/TX - namreč enkrat gre RX na RX, enkrat pa na TX. Pokvarit ne moreš, samo delovalo ne bo.

Ampak še vedno predlagam NodeMCU, vodna črpalka se tako ali tako veže na releje, ki pa jih lahko vežeš na NodeMCU ali pa na arduino. Senzorji pa tudi vsi delujejo na NodeMCU.
Laptop:Akoya E4214|Pentium N3540|4 GB RAM|120 GB SSD|Ubuntu Budgie
NAS: Intel Atom D2550|2 GB RAM|3 TB HDD
.: d4vid.info :.

int47 ::

zila90 je izjavil:

Še eno vprašanje...je vezava z LD1117 drugače v redu in bi delovala
Glede na PDF ti manjkata dva kondenzatorja (Figure 4: Application Circuit
(FOR OTHER FIXED OUTPUT VOLTAGES)).
Povezave med stabilizatorjem, blokirnimi kondenzatorji in ESP modulom naj bodo čim krajše.

Zelene ploščice ne poznam. Če je level converter, je verjetno potrebno povezat 3,3V napajanje.

Kljub vsemu je možno, da je ESP modul še živ. Poveži ga na PC, nastavi terminalski program na 74880 8 N 1, resetiraj modul in poglej, kaj se izpiše.
Lahko poskusiš še enkrat naložiti FW. Če uspe, je ESP še živ.
Nivo razprav in moderiranja v razdelku Elektrotehnika in elektronika
na tem forumu, je žal prevečkrat močno pod nivojem.

zila90 ::

Zelene ploščice ne poznam. Če je level converter, je verjetno potrebno povezat 3,3V napajanje.


Ja to je level converter, ki ga imam na napajanju.

Kljub vsemu je možno, da je ESP modul še živ. Poveži ga na PC, nastavi terminalski program na 74880 8 N 1, resetiraj modul in poglej, kaj se izpiše.
Lahko poskusiš še enkrat naložiti FW. Če uspe, je ESP še živ.


Sem ga resetiral in na terminalskem programu mi izpiše:

ets Jan 8 2013, rst cause:2, boot mode:(1, 7)

Zgodovina sprememb…

  • spremenil: zila90 ()

FX6300B ::

probaj dati en pull-up upor na gpio0 in 3,3V 10Kohm bo ok, potem poročaj, esp ti deluje le ne prižge se ti v "program" oz firmware

+ ne rabiš dajat 3,3V na rst pin

glede tega da ti ne deluje na 3,3V z reg pa si poglej za ta regulator kakšne simple sheme, ponavadi rabijo še kondenzatorje za delovanje...
May the force be with you!

Zgodovina sprememb…

  • spremenil: FX6300B ()

FX6300B ::



evo poročaj potem če kaj še rabiš mi lahko tudi napišeš v zs, sicer trenutno nimam ravno veliko časa ampak vseeno
May the force be with you!

zila90 ::

FX6300B je izjavil:


evo poročaj potem če kaj še rabiš mi lahko tudi napišeš v zs, sicer trenutno nimam ravno veliko časa ampak vseeno


Najlepša Hvala za pomoč, bom poizkusil tako.
Sicer sem meril napetost na ESP-ju in mi je konstantno kazala 3,3V.

Tukaj sta še dve vezavi podobni moji:
https://wiki.aalto.fi/download/attachme...

Zgodovina sprememb…

  • spremenil: zila90 ()

zila90 ::

Danes sem ponovno naložil firmware, vendar se ESP na AT ukaze nikakor ne odziva. Je ESP še sploh živ?
Sem pogledal v realtermu (terminalski program) in opazil, da se pin RXD sploh ne odziva na AT ukaze...

FX6300B ::

kateri firmware pa si naložil gor?, niso vsi firmwari z at komandami, lahko da deluje na drugih bitrate-ih....
predlagam ti da narediš kar takole:

https://github.com/esp8266/Arduino tole si vključi v arduino ide, da boš lahko tam tudi esp kar sprogramiral,
spiši simple program(npr da ti na gpio1 utripa ledica, programiraš ga isto kot arduino), daj gpio0 pin na gnd, priključi na usb-serial vmesnik, naloži in brez da bi resetiral bi se moral program zagnati, (samo prvič potem ko ugasneš in prižgeš mora imeti gpio0 stanje HIGH sepravi 3,3V)

bo NA ok kot non avaliable
May the force be with you!

Zgodovina sprememb…

  • spremenil: FX6300B ()


Vredno ogleda ...

TemaSporočilaOglediZadnje sporočilo
TemaSporočilaOglediZadnje sporočilo
»

Avtomatika za sončni kolektor (strani: 1 2 )

Oddelek: Elektrotehnika in elektronika
556897 (3061) FX6300B
»

napajanje arduinota/ESP8266 direktno iz žic hišne napeljave

Oddelek: Elektrotehnika in elektronika
10998 (623) FX6300B
»

Arduino(slave) + ESP8266(master) preko I2Cja

Oddelek: Elektrotehnika in elektronika
10641 (494) teoo
»

Nakup WiFi senzorja vlažnosti.

Oddelek: Kaj kupiti
162016 (1195)          
»

Arduino na baterije 16850

Oddelek: Elektrotehnika in elektronika
111336 (990)          

Več podobnih tem