» »

block ip, linux, centos

block ip, linux, centos

BRBR ::

-A INPUT -s 212.113.35.162 -p tcp --destination-port 80 -j DROP


tole sem dal v iptables file, restart iptables service, nič ne zaleže, spammer še kar nabija.
Never underestimate the power of idiots in large groups.

OmegaBlue ::

Rukni to vrstico nad ACCEPT za port 80.
Never attribute to malice that which can be adequately explained by stupidity.

BRBR ::

zaenkrat ne zgleda da bi pomagalo...., mal počakam ...
Never underestimate the power of idiots in large groups.

BRBR ::

Al je tvoj recept zalegel, al pa se je naveličal, bomo videli naslednjič.

Hvala.
Never underestimate the power of idiots in large groups.

KoMar- ::

Probal bi lahko svoj IP ;)

BRBR ::

Super ideja, enkrat sem si kliknil 'Lock firewall' na firestarterju in sem zmagal



Uglavnem, kakor mam zdaj zgleda da mi iptables po defaultu sploh ne laufa, mam pa na startupu firestarter.
In ta zgleda zažene samo en del firewala al kaj ? Če zaženem še iptables mi npr ne dela filezila, v eventih na firestarerju se izpisujejo eni porti z mojega home compa, ki jih blokira, zato zaenkrat iptables servisa rajš ne bi poganjal.

Če pa ga zaženem, in pol rečem stop, pa od treh stvari 2 ustavi, tretje pa ne ker jo drži firestarter.
Never underestimate the power of idiots in large groups.

techfreak :) ::

FTP port imaš odprt? Drugače pa lahko preko filezille dostopaš tudi do SFTPja.

denial ::

iptables laufa by default na RH based sistemih (check if currently running: lsmod | grep ip_tables + list current rules: iptables -L -n).

Tole bi bila rešitev za prvo vprašanje (na CentOS5):
# iptables -I INPUT -s 212.113.35.162 -p tcp --destination-port 80 -j DROP
# service iptables save
# service iptables restart
# iptables -L -n
Chain INPUT (policy ACCEPT)
target     prot opt source               destination         
DROP       tcp  --  212.113.35.162       0.0.0.0/0           tcp dpt:80
........


Potem je nastala zmeda :P
SELECT finger FROM hand WHERE id=3;

BRBR ::

[root@localhost ~]# iptables -I INPUT -s 212.113.35.162 -p tcp --destination-port 80 -j DROP
[root@localhost ~]# service iptables save
Saving firewall rules to /etc/sysconfig/iptables:          [  OK  ]
[root@localhost ~]# service iptables restart
Flushing firewall rules:                                   [  OK  ]
Setting chains to policy ACCEPT: mangle filter             [  OK  ]
Unloading iptables modules:                                [FAILED]
Applying iptables firewall rules:                          [  OK  ]
Loading additional iptables modules: ip_conntrack_netbios_n[  OK  ]

tistile failed je zato ker firestarter laufa.


# iptables -L -n
Chain INPUT (policy ACCEPT)
target prot opt source destination
DROP tcp -- 212.113.35.162 0.0.0.0/0 tcp dpt:80


tole se vseeno prikaže, tako da po moje zdaj bo.

Sam, čudno , če pogledam prek KDE-ja, tam iptables service ni obkljukan, da bi se zagnal na startup.
Never underestimate the power of idiots in large groups.

Zgodovina sprememb…

  • spremenil: BRBR ()


Vredno ogleda ...

TemaSporočilaOglediZadnje sporočilo
TemaSporočilaOglediZadnje sporočilo
»

Linux CentOS - block ip range

Oddelek: Omrežja in internet
6563 (451) Bakunin
»

iptables restart

Oddelek: Omrežja in internet
71634 (1457) BRBR
»

ProtFtp Passive mode in iptables

Oddelek: Programska oprema
252123 (1945) SasoS
»

iptables problem z SSH

Oddelek: Omrežja in internet
121805 (1659) sverde21
»

iptables + forward

Oddelek: Operacijski sistemi
332265 (1840) tx-z

Več podobnih tem