» »

LTSP (Linux Terminal Server Project) težave

LTSP (Linux Terminal Server Project) težave

|Luka| ::

Odločil sem se da "zaposlim" mojo staro škatlo z čem uporabnim in na netu sem našel tole http://www.ltsp.org/. Zanima me, če je kdo to že uporabljal, ker imam težave in na "hostu" nikakor ne naloži kernela tako kot bi moral? Preveril sem vse IPje, zagnal vse potrebne servise in nič...sporočilo je KERNEL PANIC - TRYING TO KILL INIT!!!!

Za vse tiste ki se vam ne da brat linka - z LTSPjem lahko narediš "diskless, floppyless" delovno postajo, ki bo pač imela možnost poganjanja programov, ki so na serverju, s tem da je lahko delovna postaja tudi kakšna 486.

LP Luka

Phoebus ::

trying to kill init? Koliko pa imajo rama te tvoje 486ke?

|Luka| ::

RAM: 64MB

Tu pa je output napak (pred tem napak ni oz. se normalno "boota"):

*****
eth0: RealTek RTL8139 Fast Ethernet at 0xc3007000, 00:30:4f:2b:57:47, IRQ 9
Running dhclient
eth0: Setting 100mbps full-duplex based on auto-negotiated partner

ability 41e1.
Mounting root filesystem: /opt/ltsp/i386/ from 192.168.0.254
(null)mount: nfsmount failed: Bad file number
NFS: mount program didn't pass remote address!
mount: Mounting 192.168.0.254:/opt/ltsp/i386 on /mnt failed: Invalid argument

ERROR! Failed to mount the root filesystem via NFS!
Possible reasons include:

1) NFS services may not be running on the server
2) Workstation IP does not map to a hostname, either
in /etc/hosts, or in NFS
3) Wrong address for NFS server in the DHCP config file
4) Wrong pathname for root directory in the DHCP config file


Kernel panic: Attempted to kill init!
*****

LP Luka

atlet ::

Imam isti problem, morda ve kdo rešitev?
Enostaven program za fakturiranje -> www.quibi.net

|Luka| ::

Takole zgledajo moje conf datoteke:
#########################################################################
dhcpd.conf

ddns-update-style none;

default-lease-time 21600;
max-lease-time 21600;

option subnet-mask 255.255.255.0;
option broadcast-address 192.168.0.255;
option routers 192.168.0.255;
option domain-name-servers 192.168.0.255;
option domain-name "ltsp";
option root-path "192.168.0.254:/opt/ltsp/i386/";

option option-128 code 128 = string;
option option-129 code 129 = text;

shared-network ltsp {
subnet 192.168.0.0 netmask 255.255.255.0 {
}
}

group {
use-host-decl-names on;
option log-servers 192.168.0.254;

host ws001 {
hardware ethernet 00:30:4F:2B:57:47;
fixed-address 192.168.0.1;
filename "/lts/vmlinuz-2.4.21-ltsp-1";
}
}
#########################################################################
exports

/opt/ltsp/i386/root 192.168.0.254/255.255.255.0(rw,no_root_squash,sync)
/opt/ltsp/i386/oldroot 192.168.0.254/255.255.255.0(rw,no_root_squash,sync)
/opt/ltsp/i386 192.168.0.254/255.255.255.0(rw,no_root_squash,sync)
/var/opt/ltsp/swapfiles 192.168.0.254/255.255.255.0(rw,no_root_squash,async)
/tftpboot/lts 192.168.0.254/255.255.255.0(rw,no_root_squash,sync)

#
# The following entries need to be uncommented if you want
# Local App support in ltsp
#
/home 192.168.0.254/255.255.255.0(rw,no_root_squash,sync)

#########################################################################
hosts.allow

#

bootpd: 0.0.0.0
in.tftpd: 192.168.0.1
portmap: 192.168.0.1

## LTS-end ##
#########################################################################
lts.conf

#
# Config file for the Linux Terminal Server Project (www.ltsp.org)
#
#
#[Default]
SERVER = 192.168.0.254
XSERVER = auto
X_MOUSE_PROTOCOL = "microsoft"
X_MOUSE_DEVICE = "/dev/ttyS0"
X_MOUSE_RESOLUTION = 400
X_MOUSE_BUTTONS = 2
USE_XFS = Y
LOCAL_APPS = Y
RUNLEVEL = 5

#------------------------------------------------------------------------------
#
# Example of specifying X settings for a workstation
#
[ws001]
XSERVER = auto
LOCAL_APPS = Y
USE_NFS_SWAP = Y
SWAPFILE_SIZE = 48m
RUNLEVEL = 6
#
#[ws001]
# XSERVER = XF86_SVGA
# LOCAL_APPS = N
# USE_NFS_SWAP = N
# SWAPFILE_SIZE = 64m
# RUNLEVEL = 3
#
#
# ws004 is my virtual workstation running in a VMware session
#
#[ws004]
# DNS_SERVER = 192.168.0.254
# XSERVER = auto
# X4_BUSID = "PCI:0:15:0"
# X_MODE_0 = 800x600
# LOCAL_APPS = N
# USE_NFS_SWAP = N
# SWAPFILE_SIZE = 64m
# RUNLEVEL = 5

#------------------------------------------------------------------------------
#
# Example of a workstation configured to load some modules
#
#[ws001]
# MODULE_01 = agpgart.o # This is for i810 video
# MODULE_02 = uart401.o
# MODULE_03 = sb.o io=0x220 irq=5 dma=1
# MODULE_04 = opl3.o

#------------------------------------------------------------------------------
#
# Example of ws001 configured for local apps
#
#[ws001]
LOCAL_APPS = Y
LOCAL_WM = Y
NIS_DOMAIN = ltsp
NIS_SERVER = 192.168.0.254

#------------------------------------------------------------------------------
#
# Example of a serial printer attached to /dev/ttyS1 on workstation ws001
#
#[ws001]
# PRINTER_0_DEVICE = /dev/ttyS1
# PRINTER_0_TYPE = S # P-Parallel, S-Serial
# PRINTER_0_PORT = 9100 # tcp/ip port: defaults to 9100
# PRINTER_0_SPEED = 9600 # baud rate: defaults to 9600
# PRINTER_0_FLOWCTRL = S # Flow control: S-Software (XON/XOFF),
# # H-Hardware (CTS/RTS)
# PRINTER_0_PARITY = N # Parity: N-None, E-Even, O-Odd
# # (defaults to 'N')
# PRINTER_0_DATABITS = 8 # Databits: 5,6,7,8 (defaults to 8)

########################################################################

Oprostite za malo daljši post, ampak tako se najbolje vidi kje so težave:
v dhcpd.conf moraš paziti na broadcast-address in na root path!!

V mojem primeru sem to težavo rešil, sedaj pa pride do
Doing pivot_root in se ne premakne :'(

LP Luka

Zgodovina sprememb…

  • spremenil: |Luka| ()

atlet ::

Požarni zid imaš nameščen?
Enostaven program za fakturiranje -> www.quibi.net

|Luka| ::

Firewalla ni, routerjev pa tudi ne.

LP Luka

atlet ::

Mislil sem, če ga imaš nameščenega na mašini, kjer poganjaš terminal server...
Enostaven program za fakturiranje -> www.quibi.net

Zgodovina sprememb…

  • spremenil: atlet ()

miki133 ::

v dhcp.conf :
option routers 192.168.0.255;
option domain-name-servers 192.168.0.255;
na broadcast address ?
morda še tole v dhcp.conf :
next-server 192.168.0.254 ;
(naslov tftp serverja)

|Luka| ::

Saj to sem mislil, na server mašini ni ne firewall ne routerja.
Uspel pa sem uzadevo rešit in sedaj se dokaj normalno boota. Ustavi pa se spet pri naslednjem koraku, to je ko bi moral mountat root, oldroot pa umountat (Doing pivot_root). napiše mi še da nfs server is not responding....still trying, ampak meni nfs teče normalno.
Help anyone?

LP Luka

atlet ::

Katero distribucijo imas?
Enostaven program za fakturiranje -> www.quibi.net

|Luka| ::

RH 9 in zadnja 3.x.x verzija ltspja

atlet ::

Kateri security level imas? Ker jst sem dau brez in mi stvarca lepo deluje, ce pa je security level na normal al pa vc, pa ne dela...verjetno zaradi firewalla!
Enostaven program za fakturiranje -> www.quibi.net

|Luka| ::

Security level imam "izklopljen".

Torej si uspel bootat klient mašino in ti deluje normalno?

Ktere mrežne kartice pa imaš; vedno bolj se mi zdi da problem tiči v strojni opremi ;((

LP Luka

Zgodovina sprememb…

  • spremenil: |Luka| ()

atlet ::

Imam sisove mrezne. Ja, doma mi je uspelo botat, v soli pa nese! :( Bom cetrtek se v soli poizkusil.
Enostaven program za fakturiranje -> www.quibi.net

r5r ::

Zanima me, zakaj mi odjemalci v fast-user-switching-applet ne prikazujejo istih izbir kot na strežniku. Namreč imam samo možnosti Log Off ter Lock screen, rad bi pa še Switch user in Disconnect (seja ostane aktivna na strežniku, medtem ko se odjemalec ugasne).
And it makes me wonder.


Vredno ogleda ...

TemaSporočilaOglediZadnje sporočilo
TemaSporočilaOglediZadnje sporočilo
»

ubuntu + network sharing

Oddelek: Pomoč in nasveti
221189 (1053) NeMeTko
»

Win2003 server ent + ICS (ADSL)

Oddelek: Omrežja in internet
61767 (1675) PaJo
»

Pomoč pri pripravi LAN party-ja

Oddelek: Omrežja in internet
61254 (1018) SasoS
»

Skupna raba datotek & tiskalnikov

Oddelek: Operacijski sistemi
211091 (932) rok86
»

freesco

Oddelek: Omrežja in internet
71739 (1565) mile

Več podobnih tem