» »

nadgradnja PHP

nadgradnja PHP

Kunte ::

Spletno stran imam narejeno v Joomli takrat je bila v uporabi PHP 5.4. Pri poskusu nadgradnje na novejšo Joomla se mi spletna stran ne prikaže. V joomla nadzorni plošči mi piše da je php 5.4 ni več podprt. V control panelu spletne strani lahko z orodjem select PHP version izberem katero verzijo PHP ja bo spletna stran uporabljala. Poskusil sem z najvišjo verzijo , ki mi jo ponudi 7.0. vendar se mi potem spletna stran ne prikaže. Kaj moram narediti , da bi prešel na novejši PHP? Spletna stran je bila narejena že pred 4-5 leti in zdaj dodajam samo slike in nekaj texta.
LP Kunte

krho ::

Poizkusi s 5.5 in 5.6 verzijama..
si.Mail odprto-kodni odjemalec elektronske pošte. - http://www.simail.si
Uredite si svojo zbirko filmov, serij in iger - http://xcollect.sf.net

Kunte ::

Uspelo mi je preiti na php 5.6 vendar ko naredim update joomle se mi spletna stran ne prikaže. Kaj pomenijo vse te opcije v PHP Selector | extensions ? Katere morajo biti aktivirane in katere ne?
 php

php

LP Kunte

Zgodovina sprememb…

  • spremenil: Kunte ()

krho ::

Od teh skoraj zagotovo lahko preč daš zend_guard... ostalo mi zgleda ok.. za bolj natančno raziskavo boš moral pogledat error loge in od tam naprej googlati.
P.S. Ne vem katero verzijo joomle si sedaj dal gor.. ampak če imaš 3.5 bi morala delati tudi na php 7, vsaj tako pravi spletna stran
si.Mail odprto-kodni odjemalec elektronske pošte. - http://www.simail.si
Uredite si svojo zbirko filmov, serij in iger - http://xcollect.sf.net

Zgodovina sprememb…

  • spremenil: krho ()

Kunte ::

Sedaj imam joomlo 3.4.8
LP Kunte

Ales ::

Joomla 3.x potrebuje minimalno PHP 5.3.10. Že s PHP 5.4 bi morala delati, vzrok težavam je nekje drugje. Kaj imaš v log datotekah za eno napako?

Kunte ::

Katero error datoteko bi moral pregledati? Na serverju je okoli 20 datotek error.
LP Kunte

Miha 333 ::

Ne spreglej tudi življenjskega cikla PHP verzij: http://php.net/supported-versions.php

Vse verzije PHP, starejše od 5.5 niso več podprte, to pomeni, da tudi varnostnih posodobitev ni več. 10.7.2016 pa bo tudi za 5.5 konec življenjske dobe in s tem posodobitev.

Tudi joomla ima veliko varnostnih lukenj, tako da jo je treba redno nadgrajevati.

Glede error log datotek pa, glede na to, da je cPanel strežnik, /usr/local/apache/logs/error_log ali pa error_log nekje v (pod)imeniku same joomle, mislim, da ima joomla po defaultu svoj log.

Zgodovina sprememb…

  • spremenilo: Miha 333 ()

Ales ::

Miha 333 je izjavil:

Ne spreglej tudi življenjskega cikla PHP verzij: http://php.net/supported-versions.php

Vse verzije PHP, starejše od 5.5 niso več podprte, to pomeni, da tudi varnostnih posodobitev ni več. 10.7.2016 pa bo tudi za 5.5 konec življenjske dobe in s tem posodobitev.
...

Uh, ne. To za resne linux distribucije, kot je npr. Red Hat in posledično CentOS ali Scientific Linux, ne drži. V teh distribucijah se ne uporablja stock PHP, pač pa različice z backportanimi popravki. Samo laiku na videz zgleda, da je različica "stara", v resnici pa ni.

Še PHP 5.1.6 je lepo podprt, še vedno. In bo še do konca leta 2020. Ampak v resnici je pri Red Hatu to v tem trenutku php-5.1.6-45.el5_11 in ne navaden php-5.1.6.

Miha 333 ::

Ales je izjavil:

Miha 333 je izjavil:

Ne spreglej tudi življenjskega cikla PHP verzij: http://php.net/supported-versions.php

Vse verzije PHP, starejše od 5.5 niso več podprte, to pomeni, da tudi varnostnih posodobitev ni več. 10.7.2016 pa bo tudi za 5.5 konec življenjske dobe in s tem posodobitev.
...

Uh, ne. To za resne linux distribucije, kot je npr. Red Hat in posledično CentOS ali Scientific Linux, ne drži. V teh distribucijah se ne uporablja stock PHP, pač pa različice z backportanimi popravki. Samo laiku na videz zgleda, da je različica "stara", v resnici pa ni.

Še PHP 5.1.6 je lepo podprt, še vedno. In bo še do konca leta 2020. Ampak v resnici je pri Red Hatu to v tem trenutku php-5.1.6-45.el5_11 in ne navaden php-5.1.6.

Do konca marca 2017, če smo natančni. Drži, RHEL/CentOS, pa tudi Debian in nekateri derivati imajo tak sistem (backport popravkov). Odgovor sem podal v kontekstu postavljenega vprašanja, kjer se na sliki vidi, da gre za cpanel strežnik. V tem primeru se nikoli ne uporablja distribucijski PHP, tudi če je OS CentOS, ampak kar lepo uraden clean PHP z vsemi pripadajočimi luknjami.

Ales ::

Miha 333 je izjavil:

Do konca marca 2017, če smo natančni.

Imaš prav, pomešal sem datume z Red Hat 6.

Drži, RHEL/CentOS, pa tudi Debian in nekateri derivati imajo tak sistem (backport popravkov). Odgovor sem podal v kontekstu postavljenega vprašanja, kjer se na sliki vidi, da gre za cpanel strežnik. V tem primeru se nikoli ne uporablja distribucijski PHP, tudi če je OS CentOS, ampak kar lepo uraden clean PHP z vsemi pripadajočimi luknjami.

Uh. EasyApache še vedno? No ja, če jim do sedaj ni potegnilo...

c3p0 ::

Ta server uporablja CL, kot je vidno iz slike.

Kunte ::

c3p0 je izjavil:

Ta server uporablja CL, kot je vidno iz slike.

Kaj to pomeni?
LP Kunte

c3p0 ::

Da razne verzije PHP že dobi kot RPM na sistem in niso buildani preko EA (razen native opcije v PHP selektorju), čeprav se tudi to da.


Vredno ogleda ...

TemaSporočilaOglediZadnje sporočilo
TemaSporočilaOglediZadnje sporočilo
»

kateri Linux za server

Oddelek: Omrežja in internet
172002 (1691) residual
»

Plesk [php] in interbase

Oddelek: Izdelava spletišč
121250 (1015) c3p0
»

Poraba RAM na HTTP in SMTP strežniku

Oddelek: Operacijski sistemi
7654 (616) PaX_MaN
»

[php] method="post"

Oddelek: Izdelava spletišč
191235 (937) slovencl
»

problem z phpjem

Oddelek: Izdelava spletišč
303068 (2481) snow

Več podobnih tem