» »

wwan kartica DOA?

wwan kartica DOA?

lopov ::

Hoj!

Preko Ebay sem kupil WWAN kartico Ericsson F5521gw. Kartica po 14 dneh "srečno" prispela in na moje razočarenje je med transportom "padla" iz zaščitne plastite in je vidno poškodovana.




Vseeno sem jo vtaknil v laptop in upal na najbooljše, kar se na žalost ni uresničilo.

Laptop je starejši Thinkpad T500, na katerem kartica uradno ni podprta, a imam "popravljen" bios tako da sprejme tudi uradno nepodprte zadeve :)

V Win7 se kartica pojavi v Device manager:



Žal noben od drajverjev ne "prime" in javi, da ne najde gonilnika:



Poskusil sem s "prisilno" namestitvijo in sem v trenutku pričaral blue screen ;((

Preklopil sem v Ubuntu 12.04 in na prvi pogled v dmesg nisem zasledil naprave, a se pojavi nekje vmes:

[    7.732512] cdc_acm 2-4:1.1: ttyACM0: USB ACM device
[    7.733252] cdc_acm 2-4:1.3: ttyACM1: USB ACM device
[    7.739349] cdc_acm 2-4:1.9: ttyACM2: USB ACM device
[    7.747402] usbcore: registered new interface driver cdc_acm
[    7.747405] cdc_acm: USB Abstract Control Model driver for USB modems and ISDN adapters
[    7.747787] cdc_wdm 2-4:1.5: cdc-wdm0: USB WDM device
[    7.747834] cdc_wdm 2-4:1.8: cdc-wdm1: USB WDM device
[    7.747848] usbcore: registered new interface driver cdc_wdm
[    7.816957] cdc_ncm: 04-Aug-2011
[    7.831902] usb 2-4: MAC-Address: 0x02:0x80:0x37:0xec:0x02:0x00
[    7.832378] cdc_ncm 2-4:1.6: usb0: register 'cdc_ncm' at usb-0000:00:1d.7-4, CDC NCM, 02:80:37:ec:02:00

usb-list mi jo tudi zazna, a vmes javi nekaj napak:

T:  Bus=02 Lev=01 Prnt=01 Port=03 Cnt=01 Dev#=  2 Spd=480 MxCh= 0
D:  Ver= 2.00 Cls=02(commc) Sub=00 Prot=00 MxPS=64 #Cfgs=  3
P:  Vendor=0bdb ProdID=190d Rev=00.00
S:  Manufacturer=Ericsson
S:  Product=F5521gw
S:  SerialNumber=4F4804FC286A3B50
C:  #Ifs=11 Cfg#= 1 Atr=e0 MxPwr=0mA
I:  If#= 0 Alt= 0 #EPs= 0 Cls=02(commc) Sub=08 Prot=00 Driver=(none)
I:  If#= 1 Alt= 0 #EPs= 1 Cls=02(commc) Sub=02 Prot=01 Driver=cdc_acm
/usr/bin/usb-devices: line 79: printf: 0a: invalid number
I:  If#= 0 Alt= 0 #EPs= 2 Cls=0a(data ) Sub=00 Prot=00 Driver=cdc_acm
I:  If#= 2 Alt= 0 #EPs= 2 Cls=0a(data ) Sub=00 Prot=00 Driver=cdc_acm
I:  If#= 3 Alt= 0 #EPs= 1 Cls=02(commc) Sub=02 Prot=01 Driver=cdc_acm
I:  If#= 4 Alt= 0 #EPs= 2 Cls=0a(data ) Sub=00 Prot=00 Driver=cdc_acm
I:  If#= 5 Alt= 0 #EPs= 1 Cls=02(commc) Sub=09 Prot=01 Driver=cdc_wdm
I:  If#= 6 Alt= 0 #EPs= 1 Cls=02(commc) Sub=0d Prot=00 Driver=cdc_ncm
I:  If#= 7 Alt= 1 #EPs= 2 Cls=0a(data ) Sub=00 Prot=01 Driver=cdc_ncm
/usr/bin/usb-devices: line 79: printf: 08: invalid octal number
I:  If#= 0 Alt= 0 #EPs= 1 Cls=02(commc) Sub=09 Prot=01 Driver=cdc_wdm
/usr/bin/usb-devices: line 79: printf: 09: invalid octal number
I:  If#= 0 Alt= 0 #EPs= 1 Cls=02(commc) Sub=02 Prot=01 Driver=cdc_acm


in potem mam še nek TP power management kjer mi tudi zlista USB napravo:

Bus 002 Device 002 ID 0bdb:190d control = auto, autosuspend_delay_ms =  2000 -- Ericsson Business Mobile Networks BV  (cdc_acm, cdc_wdm, cdc_ncm)


Modem/GPS naj bi bil v Ubuntu podport "out-of-the-box", a se mi v network managerju ne pojavi.

Še kakšen predlog kako usposobiti zadevo al naj se sprijaznim, da sem dejanko dobil "pokvarjeno" napravo? Ima kdo kakšne izkušnje oz. nasvet glede vračanja kitajcem?

Thx,
b.
  • spremenil: lopov ()

jukoz ::

Meni mi iste napake javi (sicer Ubuntu 10.04, 32-bit):

T: Bus=01 Lev=01 Prnt=01 Port=04 Cnt=01 Dev#= 6 Spd=480 MxCh= 0
D: Ver= 2.00 Cls=02(commc) Sub=00 Prot=00 MxPS=64 #Cfgs= 2
P: Vendor=0bdb ProdID=1900 Rev=00.00
S: Manufacturer=Ericsson
S: Product=Ericsson F3507g Mobile Broadband Minicard Composite Device
S: SerialNumber=0115650009471830
C: #Ifs=11 Cfg#= 1 Atr=e0 MxPwr=20mA
I: If#= 0 Alt= 0 #EPs= 0 Cls=02(commc) Sub=08 Prot=00 Driver=(none)
I: If#= 1 Alt= 0 #EPs= 1 Cls=02(commc) Sub=02 Prot=01 Driver=cdc_acm
/usr/bin/usb-devices: line 79: printf: 0a: invalid number
I: If#= 0 Alt= 0 #EPs= 2 Cls=0a(data ) Sub=00 Prot=00 Driver=cdc_acm
I: If#= 2 Alt= 0 #EPs= 2 Cls=0a(data ) Sub=00 Prot=00 Driver=cdc_acm
I: If#= 3 Alt= 0 #EPs= 1 Cls=02(commc) Sub=02 Prot=01 Driver=cdc_acm
I: If#= 4 Alt= 0 #EPs= 2 Cls=0a(data ) Sub=00 Prot=00 Driver=cdc_acm
I: If#= 5 Alt= 0 #EPs= 1 Cls=02(commc) Sub=09 Prot=01 Driver=cdc_wdm
I: If#= 6 Alt= 0 #EPs= 1 Cls=02(commc) Sub=09 Prot=01 Driver=cdc_wdm
I: If#= 7 Alt= 0 #EPs= 1 Cls=02(commc) Sub=0a Prot=00 Driver=cdc_ether
/usr/bin/usb-devices: line 79: printf: 08: invalid octal number
I: If#= 0 Alt= 1 #EPs= 2 Cls=0a(data ) Sub=00 Prot=00 Driver=cdc_ether
/usr/bin/usb-devices: line 79: printf: 09: invalid octal number
I: If#= 0 Alt= 0 #EPs= 1 Cls=02(commc) Sub=02 Prot=01 Driver=cdc_acm


Če se ti ne pojavi mal migaj z vklopom/izklopom "wifi" gumba, + preveri da ga v biosu res lahko vklopiš. Sem mel kar resne težave z enim TP (eden od prvih ki jih je mobitel prodajal z umts modemom), ker nikakor nisem uspel zbudit wireless naprav dokler nisem v biosu preklopil teh opcij parkrat. Potem je čudežno začelo delat.

Pa tist pleh je samo zaščita, zaradi tega ne bi smel bit problem.

lopov ::

Hvala za odgovor, preverim bios a na prvi pogled nisem našel nobene konkretne opcije za vklop :/ Glede pleha sem tudi jaz upal da je "kozmetičen" problem :)

SplitCookie ::

Resetiraj bios
Load bios defaults, shrani, in šele potem nastavi vse še enkrat.

HP prenosnik dela isto sranje, se je odločil da tipka za wifi ne bo več delala, pa jo je to porihtalo.

Tisti pleh lahko vzameš dol, pazi da ni kaj v stiku, poravnaj ga in ga daj nazaj gor
SplitCookie> Prevoziš RDEČO ! jype> Ja? A to je kaj posebnega?
Ramon dekers> Ječa je lahko naravno okolje potem ko se adaptiraš.
jype> CPP ne spoštujem _NIKOLI_

Zgodovina sprememb…

lopov ::

Heh, tole s plehom presega moje znanje, se raje ne bom dotikal :P Poskusim še z resetom biosa. Se mi zdi da je nenako ne prepozna 100%.

Malo sem še brskal in na XDA forumu omenjajo, da z generično kartico ni 100% da dela (sicer je govora o tablicah a najbrž ni veliko razlike):
Got same problem as you. From what i read at lenovo community forum, only lenovo branded f5521gw will work. Generic one is not guaranteed. So far i've read that one guy use his dell branded f5521gw module and tpt cannot detect it.


In ja, kartica ni Lenovo branded pač pa generična:
Ericsson F5521gw
USB\VID_0BDB&PID_1911 <- Lenovo Card
USB\VID_0BDB&PID_190D <- Generic Card


Morda je tu problem ;((

Bios reset ni pomagal, brez sprememb :/

Zgodovina sprememb…

  • spremenil: lopov ()

lopov ::

Hoi!

Po branju tujih forumov sem ugotovil, da je v večini primerov problem le v "definiciji" zapisa v INF fajlih pa sem si rekel da nič ne zgubim, če skušam na roke "popravit" :) Predpogoj je "whitelisted" bios, dodat ustrezne vrstice pa pis-a-kejk ker samo kopiraš obstoječe vrstice in popraviš ID. Še sam ne morem verjet, da je bilo res tko lahko in 100% nisem edini, ki je našel tako rešitev tko da mi je malo sumljivo, da nikjer nisem našel te informacije.

Zadevca deluje, v Device manager nimam več neznanih naprav, le glede GPS moram še pogruntat kako usposobit Lenovo SW. Tu javi napako da ne zazna naprave, čeprav mi Windows v CP pod Location sensors napravo zazna in da v uporabo.



Vredno ogleda ...

TemaSporočilaOglediZadnje sporočilo
TemaSporočilaOglediZadnje sporočilo
»

Windows 7 ne namesti potrebnih driverjev

Oddelek: Pomoč in nasveti
14926 (747) WinXP
»

HP Pavilion dv7 reboot problem

Oddelek: Pomoč in nasveti
91397 (1330) Yacked2
»

Kako dati tiskalnik v skupno rabo preko routerja.Router Asus rt n16 + tiskalnik Canon (strani: 1 2 3 )

Oddelek: Omrežja in internet
11012447 (11019) novuporabnik
»

Lag pri filmčkih v špilih

Oddelek: Igre
101617 (1479) Matev
»

Optični čitalec deluje samo za root

Oddelek: Operacijski sistemi
6749 (671) atomant

Več podobnih tem