» »

pppoe+mikrotik

pppoe+mikrotik

crystal ::

Imam modem ---> router mikrotik rb750g ---> switch --->uporabniki
trenutno povezava dela, ko bi pa rad izklopil router na modemu(Ganymade) ne dela več. torej izklopim pppoe na moedemu in vklopim na mikrotiku dobim status:connected. NAT nastavim na pppoe, internet ne dela, prav tako ping 88.88 ne dela.
[img]
b]
[img]
a]

a


a






ali bi moral dodati še kaj od naštetega

  • zavaroval slike: OmegaBlue ()

fr0sty ::

Imaš pod IP > firewall > NAT kot zadnje pravilo nastavljen masquerade?

/ip firewall nat add chain=srcnat action=masquerade src-address=10.0.24.0/24

Zamenjaj 10.0.24.0/24 s svojim LAN subnetom.

crystal ::

ja mam masquerade sem dodal še tale src adress- 192.168.88.0/24 pa tud ne dela. :/
A ima še kdo prek siola mikrotik?

tony1 ::

PEBKAC, RTFM. Žal.

Daedalus ::

Glede na (sicer obupno majhne) screenshote, nisi enajblal pppoe interfejsa. Prvo to naredi... pol pa zna začet delat. Sicer pa iz moje ex silol povezave:


> interface pppoe-client print 
Flags: X - disabled, R - running 
 0 X  ;;; Siol PPPOE link name="silol" max-mtu=1480 max-mru=1480 mrru=disabled interface=ether1-gateway user="username" password="password" profile=default service-name="" ac-name="" add-default-route=yes dial-on-demand=no use-peer-dns=yes allow=pap,chap,mschap1,mschap2

> ip firewall filter print

12 X ;;; Allow established on SIOL
     chain=input action=accept connection-state=established in-interface=silol 

13 X ;;; Allow related on SIOL
     chain=input action=accept connection-state=related in-interface=silol

17 X ;;; Default input drop on SIOL
     chain=input action=drop in-interface=silol

 > ip firewall nat print
 3   ;;; default configuration
     chain=srcnat action=masquerade out-interface=silol


Načeloma pa najprej nastaviš ppoe, potem dovoliš related/established povezave na interfesju, nato default in drop, dodaš masquerade na ppoe out, interno pa dhcp in ostale malenkosti. Zgoraj maš izpis konfiguracije.... index cifre so malo off, ker je kup ostalih pravil poleg/vmes, pa X-e ignoriraj, ko siola ne uporabljam več:)
Man is condemned to be free; because once thrown into the world,
he is responsible for everything he does.
[J.P.Sartre]

crystal ::

aha ja screenshots nevem zakaj neki shrani.si matra... seveda da enablam pppoe =)
mislim da mi tole manjka chain=input action=accept connection-state=established in-interface=silol

crystal ::

3   
;;; default configuration
     chain=input action=drop tcp-flags=syn protocol=tcp 
     in-interface=ether1-gateway src-port=1025-65535 connection-limit=10,32 

 4 X chain=forward action=drop p2p=all-p2p 

 5 X chain=input action=accept connection-state=established in-interface=siol 

 6 X chain=input action=drop in-interface=siol

Flags: X - disabled, I - invalid, D - dynamic 

 0   ;;; default configuration
     chain=srcnat action=masquerade out-interface=siol 
Flags: D - dynamic, X - disabled, R - running, S - slave 
 #     NAME                                          TYPE             MTU   L2MTU
 0  R  ether1-gateway                                ether            1500  1524 
 1  R  ether2-local-master                           ether            1500  1524 
 2     ether3-local-slave                            ether            1500  1524 
 3     ether4-local-slave                            ether            1500  1524 
 4     ether5-local-slave                            ether            1500  1524 
 5  X  bridge-interface                              bridge           1500 
 6  X  siol                                          pppoe-out       
------- zdaj mam disablan pppoe da lahko pišem na forum =)

Flags: X - disabled, R - running 
 0 X  name="siol" max-mtu=1480 max-mru=1480 mrru=disabled 
      interface=ether1-gateway user="antono85" password="ganedam=)" 
      profile=default service-name="" ac-name="" add-default-route=yes 
      dial-on-demand=no use-peer-dns=yes allow=pap,chap,mschap1,mschap2 

[admin@MikroTik] > ip firewall mangle print 
Flags: X - disabled, I - invalid, D - dynamic 
 0 X chain=prerouting action=mark-packet new-packet-mark=all passthrough=no 

 1 X chain=prerouting action=mark-packet new-packet-mark=all passthrough=no 

 2   ;;; QoS_1
     chain=prerouting action=mark-packet new-packet-mark=QoS_1_In passthrough=no protocol=tcp 
     in-interface=ether1-gateway src-port=80,53,443,3074,1863 

 3   chain=postrouting action=mark-packet new-packet-mark=QoS_1_Out passthrough=no protocol=tcp 
     out-interface=ether1-gateway dst-port=80,53,443,3074,1863 

 4   chain=prerouting action=mark-packet new-packet-mark=QoS_1_In passthrough=no protocol=udp 
     in-interface=ether1-gateway src-port=53,88,3074,1863 

 5   chain=postrouting action=mark-packet new-packet-mark=QoS_1_Out passthrough=no protocol=udp 
     out-interface=ether1-gateway dst-port=53,88,3074,1863 

 6   chain=prerouting action=mark-packet new-packet-mark=QoS_1_In passthrough=no protocol=icmp 
     in-interface=ether1-gateway 

 7   chain=postrouting action=mark-packet new-packet-mark=QoS_1_Out passthrough=no protocol=icmp 
     out-interface=ether1-gateway 

 8   ;;; QoS_2
     chain=prerouting action=mark-packet new-packet-mark=QoS_2_In passthrough=no protocol=tcp 
     in-interface=ether1-gateway src-port=110,25,995,465,587,21,113 

 9   chain=postrouting action=mark-packet new-packet-mark=QoS_2_Out passthrough=no protocol=tcp 
     out-interface=ether1-gateway dst-port=110,25,995,465,587,21,113 

10   chain=prerouting action=mark-packet new-packet-mark=QoS_2_In passthrough=no protocol=udp 
     in-interface=ether1-gateway src-port=123,113 

11   chain=postrouting action=mark-packet new-packet-mark=QoS_2_Out passthrough=no protocol=udp 
     out-interface=ether1-gateway dst-port=123,113 


12   ;;; QoS_7
     chain=prerouting action=mark-packet new-packet-mark=QoS_7_In passthrough=no protocol=tcp 
     in-interface=ether1-gateway 

13   chain=postrouting action=mark-packet new-packet-mark=QoS_7_Out passthrough=no protocol=tcp 
     out-interface=ether1-gateway 

14   chain=prerouting action=mark-packet new-packet-mark=QoS_7_In passthrough=no protocol=udp 
     in-interface=ether1-gateway 

15   chain=postrouting action=mark-packet new-packet-mark=QoS_7_Out passthrough=no protocol=udp 
     out-interface=ether1-gateway 

16   chain=prerouting action=mark-packet new-packet-mark=QoS_7_In passthrough=no 
     in-interface=ether1-gateway 

17   chain=postrouting action=mark-packet new-packet-mark=QoS_7_Out passthrough=no 
     out-interface=ether1-gateway 

18   ;;; QoS_8
     chain=prerouting action=mark-packet new-packet-mark=QoS_8_In passthrough=no p2p=all-p2p 

19   chain=postrouting action=mark-packet new-packet-mark=QoS_8_Out passthrough=no p2p=all-p2p

[admin@MikroTik] > ip dns print 
                servers: 193.189.160.13,193.189.160.23
  allow-remote-requests: yes
    max-udp-packet-size: 512
             cache-size: 2048KiB
          cache-max-ttl: 1w
             cache-used: 10KiB




prosim za pomoč ker še vedno ne dela..
A je kriv mogoče mangle ker je na ether-1 interface?

Zgodovina sprememb…

  • spremenil: crystal ()

Daedalus ::

Huh, bom zvečer pogledal, zdajle ne utegnem. Bi ti pa svetoval, da narediš backup trenutne konfiguracije, potem počistiš vse in od začetka najprej vzpostaviš delujočo povezavo. Pol pa naprej dodajaj ostala pravila.
Man is condemned to be free; because once thrown into the world,
he is responsible for everything he does.
[J.P.Sartre]

crystal ::

ok neki sm uštimal
ampak mi zadeva crkuje... kar naenkrat imaš prenos 0/0 (status: waiting for packets) pol moram disablat počakat 10 sec in pol spet eneblat in dela...

mislm da je problem kr je dinamičen ip ki se menjuje, pppoe pa se ne.
a bi znal kdo spisat skripto ki zazna ko je pppoe = 0/0 in da je status: waiting for packets, da disabla za 10 sec in pol spet enabla

al ste imeli vi dinamične ipje in niste imeli tega problema?

Senitel ::

Jaz nisem imel takih problemov... Lahko postaš pravila, ki jih imaš trenutno?

crystal ::

[admin@MikroTik] > interface pppoe-client print detail
Flags: X - disabled, R - running
0 R name="pppoe-out1" max-mtu=1492 max-mru=1492 mrru=disabled
interface=ether1-gateway user="xxxxxx" password="xxxxxx"
profile=default service-name="" ac-name="" add-default-route=yes
dial-on-demand=no use-peer-dns=yes allow=pap,chap,mschap1,mschap2

tu so vse nastavitve http://dl.dropbox.com/u/26591320/settin...

torej je možno da je napaka na siolu?

trenutno imam modem ki ima pppoe vzpostavljen in skrati tudi tale moj router. bojim se da zadeva crkne(kot to dela sedaj), pol pa tu folk ne zna nazaj vklop pppoe ko mene ni...

vrjetno res ni napaka glede ipja ker enkrat je zdržalo 4 dni. čeprav skripta bi zadevo sigurno rešila

Senitel ::

Na hitro preletel tole... Rukni ven:
/ip dhcp-client
add add-default-route=yes comment="default configuration" \
default-route-distance=1 disabled=no interface=ether1-gateway \
use-peer-dns=yes use-peer-ntp=yes

Oziroma če hočeš dostopat do modema čez router vsaj rukni stran add-default-route in use-peer-dns. Tko da zgleda nekako takole:
add comment="Modem" interface=ether1-gateway
in ročno dodaj route na 192.168.2.0/24 v route delu.

crystal ::

kje ročno dodam route?


drgač moj modem ma 192.168.1.0 omrežje torej dodam nekje 192.168.1.0./24 ?


še neki zanimivega. ko crkne, če resetiram modem začne delat

Zgodovina sprememb…

  • spremenil: crystal ()

Senitel ::

IP->Routes

crystal ::


uno modro sem sedaj dodal, a enako sem že imel po defaoultu, modema še vedno ne dosežem. bi bilo pa ful hudo če ga bi

Senitel ::

Ok sem zabluzil. Route je že by default prav. Moraš pa še masquerade popravit, ker ga imaš samo za PPPoE interface. Lahko pobrišeš trenuten rule in daš "add action=masquerade chain=srcnat src-address=192.168.88.0/24", ali pa dodaš še en rule za ether1 interface.

crystal ::

waw ful hvala, zj dela

še neki me moti..



čeprav imam nat na mikrotiku kako je lahko neki folka še vedno na modem priklopljenih?

skrati so tudi na seznamu mikrotik_>dhcp server->leases

Zgodovina sprememb…

  • spremenil: crystal ()

Senitel ::

Modem jih še ni pozabil. Bodo šli stran čez dan, dva, tri,... Reboot modema jih bo pa instant spravil stran.


Vredno ogleda ...

TemaSporočilaOglediZadnje sporočilo
TemaSporočilaOglediZadnje sporočilo
»

Mikrotik T-2 IPTV IGMP Proxy

Oddelek: Omrežja in internet
219547 (1189) Daniel
»

Mikrotik nastavitve

Oddelek: Omrežja in internet
262204 (1604) Poldi112
»

SSH forwarding na Mikrotiku

Oddelek: Omrežja in internet
101341 (1081) miki133
»

Mikrotik RB2011UiAS-2HnD-IN na Amisu, bizarno počasen internet. (strani: 1 2 )

Oddelek: Omrežja in internet
909672 (6952) Invictus
»

mikrotik pomoc

Oddelek: Pomoč in nasveti
374389 (2635) kronik

Več podobnih tem