» »

Win server 2003 in Win XP - file sharing oz. skupna raba

Win server 2003 in Win XP - file sharing oz. skupna raba

Mitja.GTI ::

Pozdravljeni!

V windows server 2003 bi rad dal določene datoteke v skupno rabo. Do njih se bo dostopalo preko računalnikov z operacijskimi sistemi Win XP.
Ne gre za preprosto skupno rabo, ampak bodo do podatkov dostopali samo določeni uporabniki oz. določena grupa... (kar pomeni da odpade "guest" in "everyone" ipd.)

Skratka...!
V Win server 2003 sem dodal uporabniška imena in gesla pod katerimi se uporabniki logirajo na svoje računalnike. To sem naredil preko "computer management - local users and groups"... vnešeni podatki se ujemajo s podatki na uporabniških mašinah (win xp).
Določeno mapo sem dal v skupno rabo in določil uporabniške pravice, ampak ne dela! Dela edino če dodam "everyone", kar pa ni sprejemljivo!

Poizkusil sem že 1000 in 1 varianto, ampak nikakor ne dela... Pred časom sem to zadevo že porihtal med operacijskimi sistemi Win xp - Win xp.
Pojma nimam kje je "fora" za win server, prosim za pomoč....

jan01 ::

Če sem prav razumel, moraš dati na authenticated users
Kje si dal everyone(pod sharing ali pod security zavihku)?
A hočeš vsakemu userju, da ima na severju svojo mapo?

Zgodovina sprememb…

  • spremenilo: jan01 ()

Mitja.GTI ::

ubistvu vem kaj bi moral naredit oz. sem naredil, pa ne deluje.
Probal sem z grupami in posamezno, pa ne dela.

Ne, nočem da ima vsak user svojo mapo, ampak da do ene mape dostopajo samo določeni userji.
Ubistvu vem kako se zadevi streže in kaj je potrebno naredit (v osnovi). In tudi 100x sem že to zadevo naredil. Samo sedaj imam probleme na Win server 2003 ker nikakor ne dela.
In ne vem, a je v Win server 2003 kakšna "fora" al zakaj noče delat?
Tud po netu sem isku kakšne variante, pa nisem nič pametnega najdu, samo tista navodila za "telebane" po katerih pa tako ali tako ne dela... :)

uglavnem, če jst prav zastopim je tako, da dodaš vse userje na mašino, kjer sheraš folder. Potem odstranič everyone ipd. in dodaš samo userje ali pa grupe, katere želiš da dostopajo (ja, takrat recimo dodaš v security authenticated users in v permission določiš pravice).
Ma ubistvu sem probal tudi druge variante, pa nič ne dela.

Imam občutek, kot da mi Win Server 2003 ne prepozna uporabnika.
Probal sem tudi preko map network drive in na roke vpisal userja in password, pa vseeno ne prime.
Dela samo če dam dostop vsem, se pravi pod security everyone...

Zgodovina sprememb…

Cveto ::

Najprej vprašanje: imaš server nastavljen tako, da se uporabniki prijavljajo v domeno? Ker tisti uporabniki ki si jih nastavil v "local users and goups" so tisti ki so prijavljeni na server.

Mitja.GTI ::

Ne. Workgroup je.
Ubistvu ni nihče prijavljen (logiran) na serverju oz. samo administrator.

jan01 ::

Izberi lastnosti fajla->security tab in iz seznama pobriši nazaželjene(ne pozabi na users skupino) in dodaj točno tiste uporabnike, ki hočeš, da imajo dostop. Pod sharing daš kar skupino authenticated users...

Zgodovina sprememb…

  • spremenilo: jan01 ()

Mitja.GTI ::

jan01
probal, ne dela...

Mitja.GTI ::

kot pravim, mislim da je problem, da mi Win Server 2003 ne prepozna uporabnikov kateri se želijo logirat in jih obravnava kot guest oz. kaj jst vem kaj. A se da to kje preveriti?

Cveto ::

Izberi lastnosti fajla->security tab in iz seznama pobriši nazaželjene(ne pozabi na users skupino) in dodaj točno tiste uporabnike, ki hočeš, da imajo dostop. Pod sharing daš kar skupino authenticated users...


Ne vem pče bo šlo...

Authenticated so na serverju tisti ki so prijavljeni vanj, bodisi direktno, preko remo desktopa ali domene.

Userje si nastavil kot lokalne (server/xxxx)? Kako pa na XP mašinah? Če nimaš domene so verjetno pijavljeni kot IME-RACUNALNIKA/UPORABNIK? In takim userjem nato daš pravice pri sharingu. Kako je s tem na serverju ki dela samo v workgroupu niti ne vem, ker imamo domeno že od začetka. Pri doajanju uporabnikov v permissions pri sharingi jih probaj izbrskati iz "network" skupine in ne lokalne userje...

Moj predlog ej vsekakor uporaba domene, kjer so te stvari jasno definirane in imaš lepo nadzor nad tem kaj dko lahko in kaj ne.

Mitja.GTI ::

ja sej tud jst vem da bi bla domena zakon, sam tko pač je, niti ne sprašuj naprej :) :) :)

Ja sej... jst tud mislm da so prijavljeni kot IMERAČUNALNIKA/USER. In to je tist problem, zato pa ne dela.
hm... network skupine? To misliš da naj dodam lokalne userje in jih dam v grupo network... al kako?

danielka84 ::

fora je verjetno v NTFS.
Ko klikneš z desno na mapo daš lastnosti in imaš potem "network sharing" ter "security". Načeloma za boljšo varnost in preglednost nastavljaš pravice samo v "security" ... torej pod "network sharing" dodaj "everyone" in mu daj pravice.. potem pa pod "security" dodajaj poljubne userje in jim nastavi posamezne pravice.
ni-da-ni

Mitja.GTI ::

danielka...
mislm da če daš everyone, potem lahko vsi dostopajo in nisi s tem nič naredil ;)
je pa res da te ne razumem najbolje in grem preverjat....

Mitja.GTI ::

Misliš "sharing" in "security"?
Se pravi da bi pod security dal "everyone" in pod "sharing - permissions" dodal userje?
Uglavnem, vseeno ne dela :)

99% sem, da je težava v tem, da uporabnike logira kot guest ali pa nekaj drugega...
samo tud če nardim enga xyžblj userja in se connectam preko map network drive in izberem "prijavi se pod drugim uporabniškim imenom in geslom" in tam vpišem ta xyžblj userja in njegov pass, vseeno ne dela :(

Mitja.GTI ::

A je mogoče treba resetirat server ko dodaš userja?
A je se je treba najprej na serverju fizično prijavit in odjavit, da dojame da je nov user?
A je možno da je to problem? Sej se sliš neumno, sam... windowsi?? :) :)

lopov ::

Mislim da ni krivda na tvoji strani, ker imam tudi jaz podobne probleme.

Na vseh uporabniskih racunalih izklopi "simple file sharing" da forsiras klasicni login na drugo rqacunalo z imenom in geslom. Prav tako naj imajo uorabniki ustvarjena gesla, ne le uporabniska imena (ampak kolikor razumem ze imas tako).

Pa se potem ne garantiram da bo delalo. Jaz imam problem z XP Home verzijo katero ima kolega na laptopu -- edini je ki se nikakor ne more povezati na tak share; zanj mora biti vse odklenjeno ...

Veliko srece in obvescaj ce ti uspe :)

Mitja.GTI ::

:) tnx, ja vsekakor bom tole rešil, pa tudi če traja 1 mesec :)
bom poizkusil tvoj predlog, ampak mislim da je simple file sharing že izklopljen ;)

Mitja.GTI ::

Userje si nastavil kot lokalne (server/xxxx)?

tako je.

Kako pa na XP mašinah? Če nimaš domene so verjetno pijavljeni kot IME-RACUNALNIKA/UPORABNIK?

Pojma nimam kako se prijavljajo v drug računalnik preko mreže...
Na lokalni mašini pa, recimo g. Janez Novak ima username JNovak, ime računalnika pa Janez.

Kakor je meni znano, če imaš na lokalni mašini (to je tista s katere dostopaš) userja z imenom "user1" in geslom "pass1"
in
dodaš na oddaljeni mašini (to je tista na kateri nastaviš share) istega userja z imenom "user1" in geslom "pass1"
potem
se logiraš na lokalno mašino pod imenom "user1", greš na my network places... itd. zadeva deluje če imaš poštimane dostope tako kot mora bit... in vedno mi je delalo, sedaj pa ko share-am na windows server pa kr ne dela... res... ne razumem...

Zgodovina sprememb…

lopov ::

Okej, se ena varianta da scekiras.

Naredil si uporabnike in ce jih nisi dodal v eno od obstojeceh grup, ki imajo dovoljenje za dostop do racunalnika preko mreze po defaultu, bo moral to narediti.

te default grupe so: administrators, backup operators, everyone, power users, users

howto:
start--> run --> gpedit.msc
computer configuration --> windows settings --> security settings
--> local policies --> user rights assignemnt

Desno se odprejo moznosti in prva je "access this computer from network".
Tu dodaj svoje grupe z remote uporabniki (2x klik, imas nastete grupe in spodaj gumb,, kjer dodas svoje).

lopov ::

Pa nasel sem tole: http://iwrconsultancy.co.uk/mylogon/

Ce ti kaj pomaga, jaz nisem probal :)

EDIT: sry, je cist off-topic

Zgodovina sprememb…

  • spremenil: lopov ()

Mitja.GTI ::

Pa nasel sem tole: http://iwrconsultancy.co.uk/mylogon/

Ce ti kaj pomaga, jaz nisem probal :)

EDIT: sry, je cist off-topic


am... če prav razumem, je ta opcija že na voljo v windowsih. Se pravi da dodaš uporabniška imena in gesla za prijavo v network...
Se pravi pri "Uporabniški računi" izbereš račun in imaš na levi strani "Upravljanje mojih omrežnih gesel"

Bom probal tisto tvojo prvo varianto in sporočim kaj in kako...

Mitja.GTI ::

Okej, se ena varianta da scekiras.

Naredil si uporabnike in ce jih nisi dodal v eno od obstojeceh grup, ki imajo dovoljenje za dostop do racunalnika preko mreze po defaultu, bo moral to narediti.

te default grupe so: administrators, backup operators, everyone, power users, users

howto:
start--> run --> gpedit.msc
computer configuration --> windows settings --> security settings
--> local policies --> user rights assignemnt

Desno se odprejo moznosti in prva je "access this computer from network".
Tu dodaj svoje grupe z remote uporabniki (2x klik, imas nastete grupe in spodaj gumb,, kjer dodas svoje).


Ne, ne dela :(

Ampak, itak mi po defaultu da userje v grupo "users", katera že ima dostop preko mreže. Tud če jih dam v grupo "Administrators" ne dela... In načeloma bi moralo delat...

Pojma nimam kaj je narobe, ampak vem da bom počas zgubu živce :) :) :) :)

danielka84 ::

v win2003 server je izklopljen simple file sharing..
Politika je nekak tak, da prvo preveri userja v pri sharing, potem pa ce ga spusti skoz, če bi dal npr. everyone pa full control, potem pa še preveri pravice pod security tabom.. torej moraš tu not tud met nastavljene pravice(za posameznega uporabnika)
v win2003 server je vse bolj varno nastavljeno in pol tud zajebava uporabnike ki pridejo iz xp...

In če se na RACUNALNIK1 (ki ima account User1) povezujes z uporabniškim imenom RACUNALNIK2/User1 in če imasta oba računalnika nastavljen isti password, greš brez pproblema not.
ni-da-ni

Mitja.GTI ::

v win2003 server je izklopljen simple file sharing..
Politika je nekak tak, da prvo preveri userja v pri sharing, potem pa ce ga spusti skoz, če bi dal npr. everyone pa full control, potem pa še preveri pravice pod security tabom.. torej moraš tu not tud met nastavljene pravice(za posameznega uporabnika)
v win2003 server je vse bolj varno nastavljeno in pol tud zajebava uporabnike ki pridejo iz xp...

ubistvu kar se tega tiče sem probal vse možne variante, pa noče...

In če se na RACUNALNIK1 (ki ima account User1) povezujes z uporabniškim imenom RACUNALNIK2/User1 in če imasta oba računalnika nastavljen isti password, greš brez pproblema not.

točno tako je mišljeno in narejeno, ampak *?!"*?$? noče :)


Vredno ogleda ...

TemaSporočilaOglediZadnje sporočilo
TemaSporočilaOglediZadnje sporočilo
»

win srv 2003 - file sharing

Oddelek: Operacijski sistemi
192150 (1315) Eureka
»

Windows Server 2008 network sharing

Oddelek: Operacijski sistemi
192369 (2070) mazupan
»

kako imeti na mrezi 3 racunalnike, da od tega 1 nima dostopa do drugih dveh

Oddelek: Omrežja in internet
243244 (2666) Pyr0Beast
»

(LAN) Moj racunalnik zahteva geslo za seznam sheranih map

Oddelek: Operacijski sistemi
331645 (1305) jlpktnst
»

WinXP pravice uporabnikov

Oddelek: Pomoč in nasveti
232544 (2121) ToniT

Več podobnih tem