» »

T-2 in Linux

T-2 in Linux

nekdo123 ::

Imam problem. In sicer, T-2 VDSL mi v Winsih dela brez problema, v Linuxu pa zaboga ne! Nastavil sem DHCP, udhcpd pošlje zahtevo, nazaj pa ne dobi (vsaj IPja, netmaska in ostalih reči ne nastavi).

V bistvu imam to router na disketi, preskusil sem dva, floppyfw ter coyotelinux, pa noben ne špila?

Ima kdo kakšno idejo?

ADSL je lepo delal, samo ta je šel preko PPPoE, za VDSL sem pa nastavil DHCP.

Hvala.

petrusko ::

Sicer nimam izkušenj s postavitvijo takšnega routerja, vendar menim na ni težava ne v izbranem paketu (floppyfw ter coyotelinux) ampak v tem da nisi dovolj dobro nastavil nastavitev.

Kaj bi naredil jaz na tvojem mestu:
- v winsih bi pogledal kak ip imam (če ga dobiš prek DHCP-ja potem bo ostal nekaj časa nespremenjen - dokler traja zakup)
- potem pa bi v routerju nastavil isti IP fiksni - in ne prek dhcp-ja, gateway, netmask,...
-potem pa pretaknil kablovje,

po moje bi moralo špilat.

No tako boš stestiral, če zadeva deluje potem pa mislim da ne bo več težko naprej.

LPP

SasoS ::

Meni je delalo bp z dhcpcd. To sem uporabljal že prej na kablu na amisu, za T-2 niso bile potrebne nobene druge nastavitve. Zdaj imam statiko in direktno vpisan IP.

Dark Angel ::

En problemcek:
Namestil sem si Suse10 na prenosnika. Imam router (Linksys54GS). Pod WinXP dela vse brez problema. Pod linuxom pa očitno nimam nastavitev pravilno poštimanih in lahko dostopam samo do routerja ter pingam lahko samo DNS od T2 (84.255.209.77). IP mi dodeli router pravilno. Pod gateway od eth0 (mrežna) sem vpisal IP od routerja (sprobal sem tudi T2 DNS).

Ne morem pa dostopati do interneta nasplošno (www, ftp, itd...). Kaj sem spregledal???

POPRAVEK:
Lahko dostopam do strani če vpišem IP adreso... Če vpišem pa ime (npr. www.arnes.si) pa ne najde...

Zgodovina sprememb…

volkec ::

v /etc/resolv.conf si nastav DNS streznike :))

SiOL:

nameserver 193.189.160.11
nameserver 193.189.160.12

ti si boš vrjetn hotu t-2-jeve nastavt

Racko ::

No TUKAJLE imate clanek, za vzpostavitev VDSLa na dveh operacijskih sistemih.

DennisDee ::

Racko, jst sm sou ze parkrat po temu vodicu, pa mi se kr ne dela na linuxu.... Moj interfaces izgleda takole


# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth0
iface eth0 inet static
address x.x.x.x (moj staticni IP)
netmask 255.255.192.0
gateway 84.255.192.1
# dns-* options are implemented by the resolvconf package, if installed
dns-nameservers 84.255.209.77 84.255.210.77
dns-search slowebhost.com

up /etc/init.d/firewall
# please do not modify the following line
pre-up /sbin/ifconfig eth0 up # line maintained by pppoeconf


Je kje tuki napaka al kaj? Ce kdo ni opazil, imam staticni IP

roscha ::

netmask 255.255.192.0
gateway 84.255.192.1


tole dvoje je 100% v kurtzu. + DNSe vpiši v /etc/resolv.conf, tukaj pa jih briši ali zahashaj, zihr je zihr.
Zadnje vrstice tudi ne rabiš.


gw je verjetno 84.255.0.1 (ne vem, imam 89.212.xxx.xxx. trenutno, tam je gw 89.212.0.1)
maska? tale bo taprava: 255.255.0.0



Še iz radovednosti. Kako hudiča si prišel do zgornjih številk? S pomočjo šloganja?


Edit:typo

Zgodovina sprememb…

  • spremenil: roscha ()

b ::

roscha: NImas prav. Pri kolegu na T2 (uporablja DHCP):

lease {
interface "eth0";
fixed-address 84.255.206.xxx;
option subnet-mask 255.255.192.0;
option routers 84.255.192.1;
option domain-name-servers 84.255.209.77,84.255.210.77;
option domain-name "t-2.net";
option dhcp-lease-time 86400;
option dhcp-message-type 5;
option dhcp-server-identifier 172.18.2.2;
renew 0 2006/1/29 07:00:03;
rebind 0 2006/1/29 16:00:03;
expire 0 2006/1/29 19:00:03;
}

Netmask je torej pravi, prav tako router. Tale IP range je 84.255.192.0/18.

Ce uporablja Debian (ali kaksno izpeljanko), potem so DNS-i v interfaces datoteki OK. V primeru, da je nalozen paket resolvconf, namrec ta sam paca po /etc/resolv.conf, in prepise tvoje spremembe. V tem primeru bi po tvojem nasvetu cez nekaj casa stvar nehala delat, pa bi bil spet problem :)

roscha ::

@ b

Preberi moj prejšnji post še 1x. Sem napisal da predvidevam, ker imam drug IP pool in nisem gotov.

lease {
interface "eth1";
fixed-address 89.212.xxx.xxx;
option subnet-mask 255.255.0.0;
option routers 89.212.0.1;
option domain-name-servers 84.255.209.77,84.255.210.77;
option domain-name "t-2.net";
option dhcp-lease-time 3600;
option dhcp-message-type 5;
option dhcp-server-identifier 172.18.2.2;

Okrog resolv.conf pa.. ja imaš prav. my bad. :(

DennisDee ::

Rocha uprasal si me kako sem prisel do stevilk...
Ce se dobro spomnim, preko vodica, ki ga je postal Racko... Ja, preveril sem se enkrat in sem cifre dobil preko tega linka od Racko-ta. Grem zdej probat se enkrat net na Debianu ce dela.

DennisDee ::

Evo sem probal se s temi ciframi zagateway in subnet mask, pa ne dela. S tem da sam sebe ne morem pingat (lokalno - 192.168.1.1), windowse lahko pingam (192.168.1.2). Niti svojega IP naslova ne morem pingat (89.212.xxx.xxx). To zna biti nekaj ne uredu, kokr jst vem :O!
No zdej moj interfaces izgleda takole:

auto lo
iface lo inet loopback

# The primary network interface
auto eth0
iface eth0 inet static
address 89.212.xxx.xxx
netmask 255.255.0.0
gateway 89.212.0.1
# dns-* options are implemented by the resolvconf package, if installed
dns-nameservers 84.255.209.77 84.255.210.77
dns-search slowebhost.com

up /etc/init.d/firewall

roscha ::

Počasi.

Od kod ti STATIČNI IP? Si ga na T-2 naročil? Imaš njihov dopis s tem IPjem?

Ker kot kaze se malo zmišljuješ in vpisuješ IPje tko iz glave.


Če ti T-2 ni uradno dodelil statičnega IPja ga nehaj srat in vpiši samo

auto eth0
iface eth0 inet static

potem dns sekcijo

za test pa daj zahashaj

# up /etc/init.d/firewall

To naj bi bilo vse.

ifdown, ifup.

Daedalus ::

Ah foo, sem slabo bral.

Enivej, če maš static IP...kaj pol tole:

# please do not modify the following line
pre-up /sbin/ifconfig eth0 up # line maintained by pppoeconf

dela not?
Man is condemned to be free; because once thrown into the world,
he is responsible for everything he does.
[J.P.Sartre]

Zgodovina sprememb…

  • spremenilo: Daedalus ()

roscha ::

Pi*da kakšne pa JAZ klatim. Eno klofuto zaslužim.

Torej še 1x PRAVILEN vnos za DHCP, prejšnji post je khmm... mal napačen. Okrog /etc/network/interfaces.
Ostalo velja.


evo:

auto lo
iface lo inet loopback

# The primary network interface
auto eth0
iface eth0 inet dhcp
# dns-* options are implemented by the resolvconf package, if installed
dns-nameservers 84.255.209.77 84.255.210.77
#dns-search slowebhost.com --- kaj vraga se to rab?

#up /etc/init.d/firewall --- možno da imaš zanič FW skripto, zato poizkusimo brez nje.


Vredno ogleda ...

TemaSporočilaOglediZadnje sporočilo
TemaSporočilaOglediZadnje sporočilo
»

vista in dve mrežni kartici - problem

Oddelek: Omrežja in internet
62401 (2227) sosko1
»

debian statični ip

Oddelek: Omrežja in internet
6957 (879) asgard2.0
»

Linux CC kot router... problem

Oddelek: Operacijski sistemi
141680 (1432) kitarist
»

VDSL in Debian - problem

Oddelek: Omrežja in internet
131536 (1283) HAM
»

"apt-get install xy" težave (Debian)

Oddelek: Operacijski sistemi
71374 (1275) B-D_

Več podobnih tem