» »

mysql 5.0.16 gentoo

mysql 5.0.16 gentoo

yimi ::

Na gentoo linuxu želim z emerge namestiti mysql 5.0.16, vendar dobim sledečo napako

!!! ERROR: dev-db/mysql-5.0.16-r3 failed.
!!! Function econf, Line 488, Exitcode 1
!!! no configure script found
!!! If you need support, post the topmost build error, NOT this status message.

any ideas??
emerge --info
Portage 2.0.51.19 (default-linux/x86, gcc-3.3.3, glibc-2.3.3.20040420-r1, 2.6.7-gentoo-r11 i686)
=================================================================
System uname: 2.6.7-gentoo-r11 i686 Pentium III (Coppermine)
Gentoo Base System version 1.4.16
Python: dev-lang/python-2.3.3-r1 [2.3.3 (#1, Aug 4 2004, 22:09:27)]
dev-lang/python: 2.3.3-r1
sys-apps/sandbox: [Not Present]
sys-devel/autoconf: 2.59-r6, 2.13
sys-devel/automake: 1.5, 1.6.3, 1.4_p6, 1.8.5-r3, 1.7.9-r1, 1.9.6-r1
sys-devel/binutils: 2.16.1
sys-devel/libtool: 1.4.3-r4
virtual/os-headers: 2.4.21-r1
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CFLAGS="-O2 -march=pentium3 -fomit-frame-pointer -falign-functions=4 -funroll-loops -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config /usr/kde/3.2/share/config /usr/kde/3/share/config /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -march=pentium3 -fomit-frame-pointer -falign-functions=4 -funroll-loops -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs autoconfig ccache distlocks sandbox sfperms strict"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/Linux/dis...
LINGUAS="sl"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 X adns aim alsa apache2 arts audiofile avi berkdb bitmap-fonts bzip2 cdr crypt cups curl dvb dvd emacs expat fam flash foo fortran gd gdbm gif gphoto2 gpm gtk gtk2 icq innodb ipv6 java jpeg kde lcms libwww mad mhash ming mmx mng motif mozilla mpeg msn mysql ncurses nls ogg oggvorbis opengl pam pcre pdflib perl png postgres python qt quicktime readline skey slang ssl tcpd tiff truetype truetype-fonts type1-fonts unicode usb vorbis wmf xml xml2 zlib linguas_sl userland_GNU kernel_linux elibc_glibc"
Unset: ASFLAGS, CBUILD, CTARGET, LANG, LC_ALL, LDFLAGS, PORTDIR_OVERLAY

NoOrdinary ::

Take stvari je sicer bol sprašvat na Gentoo forumu. Glede na to da je ta verzija mysqla še v ~arch tud ni nujno da bi ti sploh mogla delat, poglej bug reporte in če ni napiš novga. Mogoče probej še z gccjem 3.4, ki je zdej že privzet gcc v Gentoo, mogoče kakšne gluposti okrog sourca.
brez ideje sem za podpis

BigWhale ::

Najprej je potrebno vsaj priblizno prebrati sporocilo o napaki:

> !!! ERROR: dev-db/mysql-5.0.16-r3 failed.
> !!! Function econf, Line 488, Exitcode 1
> !!! no configure script found
> !!! If you need support, post the topmost build error, NOT this
> status message.

Se enkrat preberi zadnjo vrstico s klicaji... Pa jo razumi...

yimi ::

Kaj pa je za razumet iz zadnje vrstice? emerge potegne dol, razpakira in puf napaka da ne najde conf datoteke, kar piše v errorju.

mile ::

hehe, mas zgleda res probleme z branjem....


zadnja vrstica z KLICAJI sporoca tole

!!! If you need support, post the topmost build error, NOT this

se pravi , pejstas 2 zaslona texta pred tem sporocilom, ne pa tole, ki se genericno izpise ob vsaki napaki

yimi ::

Mislim da ti ne razumeš. Pravim ti da ne izpiše nobene napake prej. Napiše da je uspešno razpakiru za tem pa puf ta error v katerem piše da ne najde konfiguracijske datoteke...kot veš jo rabš pred make...

No sedaj nameščam novejši gcc ipd.

mile ::

ti iz principa ne pomagam naprej :)

zee ::

meni pri takih problemih pomaga, da naredim prej en "emerge sync"
zee
Linux: Be Root, Windows: Re Boot
Giant Amazon and Google Compute Cloud in the Sky.

BigWhale ::

glede na to, da ti emerge ne najde configure, pomeni, da je ali narobe razpakiral ali pa ni razpakiral zadeve. torej, kaj se izpise pred tem? Pred tistimi klicaji.

Brane2 ::

Tale package je nestabilen.

Sem glih prej ga zkeywordal in poskusil emergeat. Dela. je pa res, da imam jaz Amd64...

Samo kot je iz napake videt, ji ni všeč configure script.

Ni videt, da bi bilo z ebuildom kaj narobe, sicer md5 vsote ne bi klapale.

Preden narediš kaj drugega, poskusi emerge --sync ,kot je že nekdo rekel...
On the journey of life, I chose the psycho path.

yimi ::

BigWhale, saj to je bila fora! Nobenega errorja prej, samo napis, da je razpakiru in error.

No sicer sm odpravu napako s tem, da sem nadgradil sistemsko programje. Pomoč pri točno tej napaki http://forums.gentoo.org/viewtopic-t-406518.html

revdep-rebuild, emerge --sync,... so mi poznane te zadeve -> pregledal handbook po čez in po dolgem :\

Zgodovina sprememb…

  • spremenilo: yimi ()


Vredno ogleda ...

TemaSporočilaOglediZadnje sporočilo
TemaSporočilaOglediZadnje sporočilo
»

K3B problem

Oddelek: Operacijski sistemi
71099 (977) theD3viL-
»

Gentoo kaj se dogaja?

Oddelek: Operacijski sistemi
461996 (1284) Pithlit
»

openoffice slovenski za gentoo

Oddelek: Programska oprema
211075 (962) KoKi
»

Gentoo Xorg.conf LCD - sistem se obesi

Oddelek: Operacijski sistemi
361453 (1246) Mr.B
»

unmergal sem gcc

Oddelek: Operacijski sistemi
421603 (1349) borchi

Več podobnih tem