» »

Predolgo nalaganje kernela

Predolgo nalaganje kernela

Senzacionale ::

Mogoče je to kdo že spraševal sam nisem nikjker našel.

Kernel (vmlinuz) nalag predolgo, išče diske, najde takoj wd, maxtor, rekorder, dvd, toda potem se ustavi na hde in hd f ter tu išče pet minut ter nič ne najde, ker tudi ni nič priklopljeno gor. Kako naj naredim da ne bo tega tako dolgo iskali. Treba prekompajlat kernel ali je se kaka moznost.

Hvala

jlpktnst ::

Toliko se res ne spoznam na kernel, da bi ti lahko kar tako odgovoril, pa tudi prvič slišim za kaj takega. Če znaš kompajlat kernel, lahko pogledaš ali je kakšna napačna zadeva izbrana/nastavljena.

moj_nick ::

Ne vem, zakaj bi bilo tu kaj s kernelom narobe - kak devFS, udev ali nekaj funkcionalno podobnega.
110111001001010001010000

babylon9 ::

lahko je to sam ce mas sata disk, ce bi to jaz prej vedu bi ubodu ata100 al pa ata133 ker se prej nalozita na drugi masini.
Tole s sato je mal nateg folka, vse skupi ..

Senzacionale ::

ne diska nista sata ampak sta ata 133, ceprav plata pa ma priklope za sata. mam epox 8rda3+ plato ce kej pomaga.

Ne vidm drugega kot problem z kernelom oz. lahko se motim, zato rabim pomoc.

BigWhale ::

Ko se ti racunalnik zboota, napisi

# dmesg

in vse to kar ti zadeva vrne, poslji sem.

Nasa kristalna krogla je trenutno na servisu.

Hvala.

Senzacionale ::

ne nimam sata, ceprav sona plati priklopi za sata. Plata je epox 8rda3+ ce kaj pomaga.

Po mojem je kernel, ker prej na slackware jeb blo isto in ko sem dal nov kernel gor iz 2.4.22 na 2.6.5 tega ni vec delalo, sedaj sem sel probat fedora 2, ki ze ima 2.6.5 kernel zato nima veze da ba bi ga dal na nov gor istega. Sam zanima me ce se da to se kako drugace odpravit da ne bi tako dolgo trajalo. Dal sem tud update kernela na 2.6.6 sam isti smorn.

Hvala

Senzacionale ::

[root@localhost root]# # dmesg
[root@localhost root]# #dmesg
[root@localhost root]#


nic ne vrne :(

bmen ::

napiši samo dmesg (brez #)
... B ...

Senzacionale ::

[root@localhost root]# dmesg
Linux version 2.6.6-1.435 (bhcompile@tweety.build.redhat.com) (gcc version 3.3.3 20040412 (Red Hat Linux 3.3.3-7)) #1 Mon Jun 14 09:09:07 EDT 2004
BIOS-provided physical RAM map:
BIOS-e820: 0000000000000000 - 000000000009fc00 (usable)
BIOS-e820: 000000000009fc00 - 00000000000a0000 (reserved)
BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
BIOS-e820: 0000000000100000 - 000000001fff0000 (usable)
BIOS-e820: 000000001fff0000 - 000000001fff3000 (ACPI NVS)
BIOS-e820: 000000001fff3000 - 0000000020000000 (ACPI data)
BIOS-e820: 00000000fec00000 - 00000000fec01000 (reserved)
BIOS-e820: 00000000fee00000 - 00000000fee01000 (reserved)
BIOS-e820: 00000000ffff0000 - 0000000100000000 (reserved)
0MB HIGHMEM available.
511MB LOWMEM available.
zapping low mappings.
On node 0 totalpages: 131056
DMA zone: 4096 pages, LIFO batch:1
Normal zone: 126960 pages, LIFO batch:16
HighMem zone: 0 pages, LIFO batch:1
DMI 2.2 present.
ACPI: RSDP (v000 Nvidia ) @ 0x000f74b0
ACPI: RSDT (v001 Nvidia AWRDACPI 0x42302e31 AWRD 0x00000000) @ 0x1fff3000
ACPI: FADT (v001 Nvidia AWRDACPI 0x42302e31 AWRD 0x00000000) @ 0x1fff3040
ACPI: MADT (v001 Nvidia AWRDACPI 0x42302e31 AWRD 0x00000000) @ 0x1fff7e00
ACPI: DSDT (v001 NVIDIA AWRDACPI 0x00001000 MSFT 0x0100000e) @ 0x00000000
ACPI: PM-Timer IO Port: 0x4008
Built 1 zonelists
Kernel command line: ro root=LABEL=/ rhgb quiet
mapped 4G/4G trampoline to ffff3000.
Initializing CPU#0
CPU 0 irqstacks, hard=02346000 soft=02345000
PID hash table entries: 2048 (order 11: 16384 bytes)
Detected 1403.430 MHz processor.
Using tsc for high-res timesource
Console: colour VGA+ 80x25
Memory: 516448k/524224k available (1552k kernel code, 7008k reserved, 603k data, 144k init, 0k highmem)
Calibrating delay loop... 2760.70 BogoMIPS
Security Scaffold v1.0.0 initialized
SELinux: Initializing.
SELinux: Starting in permissive mode
There is already a security framework initialized, register_security failed.
selinux_register_security: Registering secondary module capability
Capability LSM initialized as secondary
Dentry cache hash table entries: 32768 (order: 5, 131072 bytes)
Inode-cache hash table entries: 32768 (order: 5, 131072 bytes)
Mount-cache hash table entries: 512 (order: 0, 4096 bytes)
CPU: After generic identify, caps: 0383fbff c1cbfbff 00000000 00000000
CPU: After vendor identify, caps: 0383fbff c1cbfbff 00000000 00000000
CPU: L1 I Cache: 64K (64 bytes/line), D cache 64K (64 bytes/line)
CPU: L2 Cache: 256K (64 bytes/line)
CPU: After all inits, caps: 0383f3ff c1cbfbff 00000000 00000020
Intel machine check architecture supported.
Intel machine check reporting enabled on CPU#0.
CPU: AMD Athlon(tm) XP 1600+ stepping 02
Enabling fast FPU save and restore... done.
Enabling unmasked SIMD FPU exception support... done.
Checking 'hlt' instruction... OK.
checking if image is initramfs...it isn't (no cpio magic); looks like an initrd
Freeing initrd memory: 184k freed
NET: Registered protocol family 16
PCI: PCI BIOS revision 2.10 entry at 0xfb4c0, last bus=2
PCI: Using configuration type 1
mtrr: v2.0 (20020519)
ACPI: Subsystem revision 20040326
ACPI: IRQ9 SCI: Edge set to Level Trigger.
ACPI: Interpreter enabled
ACPI: Using PIC for interrupt routing
ACPI: PCI Root Bridge [PCI0] (00:00)
PCI: Probing PCI hardware (bus 00)
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0._PRT]
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.HUB0._PRT]
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.AGPB._PRT]
ACPI: PCI Interrupt Link [LNK1] (IRQs 3 4 5 6 7 10 *11 12 14 15)
ACPI: PCI Interrupt Link [LNK2] (IRQs 3 4 5 6 7 10 *11 12 14 15)
ACPI: PCI Interrupt Link [LNK3] (IRQs 3 4 5 6 7 10 11 12 14 15) *0, disabled.
ACPI: PCI Interrupt Link [LNK4] (IRQs 3 4 *5 6 7 10 11 12 14 15)
ACPI: PCI Interrupt Link [LNK5] (IRQs 3 4 5 6 7 10 11 12 14 15) *0, disabled.
ACPI: PCI Interrupt Link [LUBA] (IRQs 3 4 *5 6 7 10 11 12 14 15)
ACPI: PCI Interrupt Link [LUBB] (IRQs 3 4 5 6 7 10 *11 12 14 15)
ACPI: PCI Interrupt Link [LMAC] (IRQs 3 4 5 6 7 10 *11 12 14 15)
ACPI: PCI Interrupt Link [LAPU] (IRQs 3 4 5 6 7 10 11 12 14 15) *0, disabled.
ACPI: PCI Interrupt Link [LACI] (IRQs 3 4 *5 6 7 10 11 12 14 15)
ACPI: PCI Interrupt Link [LMCI] (IRQs 3 4 5 6 7 10 11 12 14 15) *0, disabled.
ACPI: PCI Interrupt Link [LSMB] (IRQs 3 4 5 6 7 10 11 12 14 15) *0, disabled.
ACPI: PCI Interrupt Link [LUB2] (IRQs 3 4 *5 6 7 10 11 12 14 15)
ACPI: PCI Interrupt Link [LFIR] (IRQs 3 4 5 6 7 10 11 12 14 15) *0, disabled.
ACPI: PCI Interrupt Link [L3CM] (IRQs 3 4 5 6 7 10 11 12 14 15) *0, disabled.
ACPI: PCI Interrupt Link [LIDE] (IRQs 3 4 5 6 7 10 11 12 14 15) *0, disabled.
ACPI: PCI Interrupt Link [APC1] (IRQs *16)
ACPI: PCI Interrupt Link [APC2] (IRQs *17)
ACPI: PCI Interrupt Link [APC3] (IRQs *18), disabled.
ACPI: PCI Interrupt Link [APC4] (IRQs *19)
ACPI: PCI Interrupt Link [APC5] (IRQs *16), disabled.
ACPI: PCI Interrupt Link [APCF] (IRQs 20 21 22) *0
ACPI: PCI Interrupt Link [APCG] (IRQs 20 21 22) *0
ACPI: PCI Interrupt Link [APCH] (IRQs 20 21 22) *0
ACPI: PCI Interrupt Link [APCI] (IRQs 20 21 22) *0, disabled.
ACPI: PCI Interrupt Link [APCJ] (IRQs 20 21 22) *0
ACPI: PCI Interrupt Link [APCK] (IRQs 20 21 22) *0, disabled.
ACPI: PCI Interrupt Link [APCS] (IRQs *23), disabled.
ACPI: PCI Interrupt Link [APCL] (IRQs 20 21 22) *0
ACPI: PCI Interrupt Link [APCM] (IRQs 20 21 22) *0, disabled.
ACPI: PCI Interrupt Link [AP3C] (IRQs 20 21 22) *0, disabled.
ACPI: PCI Interrupt Link [APCZ] (IRQs 20 21 22) *0, disabled.
Linux Plug and Play Support v0.97 (c) Adam Belay
usbcore: registered new driver usbfs
usbcore: registered new driver hub
ACPI: PCI Interrupt Link [LSMB] enabled at IRQ 11
ACPI: PCI Interrupt Link [LUBA] enabled at IRQ 5
ACPI: PCI Interrupt Link [LUBB] enabled at IRQ 11
ACPI: PCI Interrupt Link [LUB2] enabled at IRQ 5
ACPI: PCI Interrupt Link [LMAC] enabled at IRQ 11
ACPI: PCI Interrupt Link [LACI] enabled at IRQ 5
ACPI: PCI Interrupt Link [LNK4] enabled at IRQ 5
ACPI: PCI Interrupt Link [LNK1] enabled at IRQ 11
ACPI: PCI Interrupt Link [LNK2] enabled at IRQ 11
PCI: Using ACPI for IRQ routing
vesafb: probe of vesafb0 failed with error -6
apm: BIOS version 1.2 Flags 0x07 (Driver version 1.16ac)
apm: overridden by ACPI.
audit: initializing netlink socket (disabled)
audit(1087681963.197:0): initialized
Total HugeTLB memory allocated, 0
VFS: Disk quotas dquot_6.5.1
Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)
SELinux: Registering netfilter hooks
Initializing Cryptographic API
pci_hotplug: PCI Hot Plug PCI Core version: 0.5
ACPI: Fan [FAN] (on)
ACPI: Processor [CPU0] (supports C1)
ACPI: Thermal Zone [THRM] (48 C)
isapnp: Scanning for PnP cards...
isapnp: No Plug & Play device found
Real Time Clock Driver v1.12
Linux agpgart interface v0.100 (c) Dave Jones
agpgart: Detected NVIDIA nForce2 chipset
agpgart: Maximum main memory to use for agp memory: 439M
agpgart: AGP aperture is 64M @ 0xe0000000
Serial: 8250/16550 driver $Revision: 1.90 $ 8 ports, IRQ sharing enabled
ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
ttyS1 at I/O 0x2f8 (irq = 3) is a 16550A
RAMDISK driver initialized: 16 RAM disks of 16384K size 1024 blocksize
divert: not allocating divert_blk for non-ethernet device lo
Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
NFORCE2: IDE controller at PCI slot 0000:00:09.0
NFORCE2: chipset revision 162
NFORCE2: not 100% native mode: will probe irqs later
NFORCE2: BIOS didn't set cable bits correctly. Enabling workaround.
NFORCE2: 0000:00:09.0 (rev a2) UDMA133 controller
ide0: BM-DMA at 0xf000-0xf007, BIOS settings: hda:DMA, hdb:DMA
ide1: BM-DMA at 0xf008-0xf00f, BIOS settings: hdc:DMA, hdd:DMA
hda: WDC WD800JB-00ETA0, ATA DISK drive
hdb: Maxtor 6Y080P0, ATA DISK drive
Using cfq io scheduler
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
hdc: SONY DVD-ROM DDU1612, ATAPI CD/DVD-ROM drive
hdd: ASUS CRW-4816A, ATAPI CD/DVD-ROM drive
ide1 at 0x170-0x177,0x376 on irq 15
SiI3112 Serial ATA: IDE controller at PCI slot 0000:01:0c.0
SiI3112 Serial ATA: chipset revision 2
SiI3112 Serial ATA: 100% native mode on irq 11
ide2: MMIO-DMA , BIOS settings: hde:pio, hdf:pio
ide3: MMIO-DMA , BIOS settings: hdg:pio, hdh:pio
hde: no response (status = 0xfe)
hdg: no response (status = 0xfe)
hde: no response (status = 0xfe), resetting drive
hde: no response (status = 0xfe)
hdg: no response (status = 0xfe), resetting drive
hdg: no response (status = 0xfe)
hda: max request size: 1024KiB
hda: 156301488 sectors (80026 MB) w/8192KiB Cache, CHS=16383/255/63, UDMA(100)
hda: hda1 hda2 < hda5 >
hdb: max request size: 128KiB
hdb: 160086528 sectors (81964 MB) w/7936KiB Cache, CHS=65535/16/63, UDMA(133)
hdb: hdb1 < hdb5 hdb6 >
hdc: ATAPI 40X DVD-ROM drive, 512kB Cache, UDMA(33)
Uniform CD-ROM driver Revision: 3.20
hdd: ATAPI 48X CD-ROM CD-R/RW CD-MRW drive, 2048kB Cache, UDMA(33)
ide-floppy driver 0.99.newide
usbcore: registered new driver hiddev
usbcore: registered new driver usbhid
drivers/usb/input/hid-core.c: v2.0:USB HID core driver
mice: PS/2 mouse device common for all mice
serio: i8042 AUX port at 0x60,0x64 irq 12
input: ImPS/2 Generic Wheel Mouse on isa0060/serio1
serio: i8042 KBD port at 0x60,0x64 irq 1
input: AT Translated Set 2 keyboard on isa0060/serio0
md: md driver 0.90.0 MAX_MD_DEVS=256, MD_SB_DISKS=27
NET: Registered protocol family 2
IP: routing cache hash table of 4096 buckets, 32Kbytes
TCP: Hash tables configured (established 32768 bind 65536)
Initializing IPsec netlink socket
NET: Registered protocol family 1
NET: Registered protocol family 17
ACPI: (supports S0 S1 S4 S5)
md: Autodetecting RAID arrays.
md: autorun ...
md: ... autorun DONE.
RAMDISK: Compressed image found at block 0
VFS: Mounted root (ext2 filesystem).
SCSI subsystem initialized
libata version 1.02 loaded.
Freeing unused kernel memory: 144k freed
SELinux: Disabled at runtime.
SELinux: Unregistering netfilter hooks
NET: Registered protocol family 10
Disabled Privacy Extensions on device 022deac0(lo)
IPv6 over IPv4 tunneling driver
divert: not allocating divert_blk for non-ethernet device sit0
ACPI: Power Button (FF) [PWRF]
ehci_hcd 0000:00:02.2: EHCI Host Controller
PCI: Setting latency timer of device 0000:00:02.2 to 64
ehci_hcd 0000:00:02.2: irq 5, pci mem 22886000
ehci_hcd 0000:00:02.2: new USB bus registered, assigned bus number 1
PCI: cache line size of 64 is not supported by device 0000:00:02.2
ehci_hcd 0000:00:02.2: USB 2.0 enabled, EHCI 1.00, driver 2004-May-10
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 6 ports detected
ohci_hcd: 2004 Feb 02 USB 1.1 'Open' Host Controller (OHCI) Driver (PCI)
ohci_hcd: block sizes: ed 64 td 64
ohci_hcd 0000:00:02.0: OHCI Host Controller
PCI: Setting latency timer of device 0000:00:02.0 to 64
ohci_hcd 0000:00:02.0: irq 5, pci mem 22888000
ohci_hcd 0000:00:02.0: new USB bus registered, assigned bus number 2
hub 2-0:1.0: USB hub found
hub 2-0:1.0: 3 ports detected
ohci_hcd 0000:00:02.1: OHCI Host Controller
PCI: Setting latency timer of device 0000:00:02.1 to 64
ohci_hcd 0000:00:02.1: irq 11, pci mem 22892000
ohci_hcd 0000:00:02.1: new USB bus registered, assigned bus number 3
hub 3-0:1.0: USB hub found
hub 3-0:1.0: 3 ports detected
device-mapper: 4.1.0-ioctl (2003-12-10) initialised: dm@uk.sistina.com
cdrom: open failed.
cdrom: open failed.
Adding 1177808k swap on /dev/hdb6. Priority:-1 extents:1
parport0: PC-style at 0x378 [PCSPP,TRISTATE]
parport0: Legacy device
inserting floppy driver for 2.6.6-1.435
Floppy drive(s): fd0 is 1.44M
FDC 0 is a post-1991 82077
ohci1394: $Rev: 1203
ohci1394: fw-host0: Unexpected PCI resource length of 1000!
ohci1394: fw-host0: OHCI-1394 1.0 (PCI): IRQ=[11] MMIO=[e5082000-e50827ff] Max Packet=[2048]
8139too Fast Ethernet driver 0.9.27
divert: allocating divert_blk for eth0
eth0: RealTek RTL8139 at 0xa000, 00:04:61:4a:de:6f, IRQ 5
eth0: Identified 8139 chip type 'RTL-8101'
forcedeth.c: Reverse Engineered nForce ethernet driver. Version 0.25.
PCI: Setting latency timer of device 0000:00:04.0 to 64
divert: allocating divert_blk for eth1
eth1: forcedeth.c: subsystem: 01695:1000 bound to 0000:00:04.0
divert: freeing divert_blk for eth0
divert: freeing divert_blk for eth1
ip_tables: © 2000-2002 Netfilter core team
ip_conntrack version 2.1 (4095 buckets, 32760 max) - 296 bytes per conntrack
forcedeth.c: Reverse Engineered nForce ethernet driver. Version 0.25.
PCI: Setting latency timer of device 0000:00:04.0 to 64
divert: allocating divert_blk for eth0
eth0: forcedeth.c: subsystem: 01695:1000 bound to 0000:00:04.0
CSLIP: code copyright 1989 Regents of the University of California
PPP generic driver version 2.4.2
divert: not allocating divert_blk for non-ethernet device ppp0
eth0: no IPv6 routers present
Bluetooth: Core ver 2.5
NET: Registered protocol family 31
Bluetooth: HCI device and connection manager initialized
Bluetooth: HCI socket layer initialized
Bluetooth: L2CAP ver 2.2
Bluetooth: L2CAP socket layer initialized
Bluetooth: RFCOMM ver 1.3
Bluetooth: RFCOMM socket layer initialized
Bluetooth: RFCOMM TTY layer initialized
parport0: PC-style at 0x378 [PCSPP,TRISTATE]
parport0: Legacy device
lp0: using parport0 (polling).
lp0: console ready
PCI: Setting latency timer of device 0000:00:06.0 to 64
intel8x0_measure_ac97_clock: measured 49184 usecs
intel8x0: clocking to 47375

SasoS ::

Če nimaš na SATA nič disejblaj u biosu. Samo mi je pa čudno da išče diske če jih ni gor...

Brane2 ::

Če uprabljaš LVM, kot je razbrati iz loga, kje rse ti oglaša device mapper, zna to biti izvor zakasnitev. Ta ob bootu poskuša najti LVM particiijo na vseh naprevah, ki jih najde. Ker je naprav v dev mapi lahko velikko, mu je treba omejiti iskanje.

Če LVMa ne uporabljaš, ga pač diseblaj. To je za vsako distribucijo drugače, tako da ti tu težko pomagam.

Če drugače ne bo šlo, lahko ukažeš izklop LVM modulov v kernelu z opcijskim paramterov (domnevam) ali celo znova skokmpajlaš kernel brez LVMa.

Če ne veš kaj je LVM, to je zadeva, ki it omogoča stvaritev logičnihh particij namesto fizičnih. Logična particija se npr. lahko razteza preko večih driveov in ko ti zamnjka placa, jo lahko podaljšaš z dodajanjem novih fizičnih particij in driveov.

To je vse domneva. Lahko, da te bremza kaj drugega. Lahko te jebe recimo udev (če ga uporabljaš, seveda) ali kaj tretjega...

Senzacionale ::

Če drugače ne bo šlo, lahko ukažeš izklop LVM modulov v kernelu z opcijskim paramterov (domnevam) ali celo znova skokmpajlaš kernel brez LVMa.

Kak pa naj izklopim modeul, ne da bi kompajlu kernel se enkrt, ker to je prezamudno pa se dotikrat kej pozbim vkljucit, itd.

Senzacionale ::

Saos hvala ti za idejo in vsem za pomoc.

Krivo je bilo, da je bil v biosu prizgan sata krmilnik. Tudi pred zagonom Winsov je iskal naprave v raidu toda ne tako dolgo kot v linuxu. Sedaj sem izklopil in stvar dela normalno naprej brez cakanja.

Hvala vsem

Zgodovina sprememb…

BigWhale ::

Ko bi se vsak spomnil poslati svoj dmesg...

;)


Vredno ogleda ...

TemaSporočilaOglediZadnje sporočilo
TemaSporočilaOglediZadnje sporočilo
»

Ubuntu vprašanja

Oddelek: Operacijski sistemi
482552 (1301) roksson
»

Ubuntu 7.04 + Pinnacle PCTV = slika super, zvoka ni - Linux n00b here (strani: 1 2 )

Oddelek: Operacijski sistemi
705893 (3334) Matthai
»

[Linux] Pinnaclova kartica

Oddelek: Operacijski sistemi
301483 (1238) christooss
»

Linux Read only file system ??

Oddelek: Operacijski sistemi
91286 (1245) 2g00d4u
»

problemi z zvocno v linuxu

Oddelek: Operacijski sistemi
81148 (1091) BigWhale

Več podobnih tem